Closed Bug 898598 Opened 6 years ago Closed 6 years ago

[Page Thumbnails] Thumbnail service capture thumbnails on every new tab opening for certain sites.

Categories

(Firefox :: Tabbed Browser, defect)

x86_64
Windows 7
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 25
Tracking Status
firefox24 --- unaffected
firefox25 + verified

People

(Reporter: Optimizer, Unassigned)

References

Details

I have 12 tiles on my ntp. Using latest nightly, whenever I open a new tab page, browser console shows certain sites to be loading in the background each time. I do not know the full set, but out of the 12 thumbnails, I have one as youtube.com and other as outlook's web client (office 365) . so each time I open a ntp, all the network calls are made that would have been made if I open those sites myself.
Here is the network log when I open and close new tab page 2 times back to back : http://pastebin.mozilla.org/2717570

Note that opening youtube means several calls to load the ads on the page, and opening outlook means redirecting to the sso page.
Can you please check the browser/error console?  The only thing I can see which might cause this is a failure to complete the capture and/or save it to disk - and hopefully if that happens it would appear in the console.

It would also be helpful if you could check your thumbnail directory and see if the thumbnails for these sites appear.  If things are working correctly, they would obviously be the most-recent thumbnails in that directory (the filenames are based on the md5 hash or the URL, so it will be hard to determine from the filename what the site is).  They are just png files, so you can open the thumbnails directly in an image viewer.

Note that the thumbnails are stored in a 'thumbnails' directory in the profile directory under AppData\Local - *not* under AppData\Roaming as most of the profile data is.
(In reply to Mark Hammond (:markh) from comment #1)
> Can you please check the browser/error console?  The only thing I can see
> which might cause this is a failure to complete the capture and/or save it
> to disk - and hopefully if that happens it would appear in the console.

I don't see any error in the Browser Console.

> It would also be helpful if you could check your thumbnail directory and see
> if the thumbnails for these sites appear.  If things are working correctly,
> they would obviously be the most-recent thumbnails in that directory (the
> filenames are based on the md5 hash or the URL, so it will be hard to
> determine from the filename what the site is).  They are just png files, so
> you can open the thumbnails directly in an image viewer.
> 
> Note that the thumbnails are stored in a 'thumbnails' directory in the
> profile directory under AppData\Local - *not* under AppData\Roaming as most
> of the profile data is.

The thumbnails are very well present, and the youtube and outlook thumbnail actually get updated on each new tab page opening in that directory too.
Blocks: 870100
Perhaps we can give Optimizer a try build with some extra debug logging, if we're not able to reproduce this ourselves?
Depends on: 899436
It turns out I could also repro this - we were asking for the "last modified" time but due to bug 899436 we were actually getting back the "last accessed" time (and the "last accessed" time on Windows is the file creation time unless some hidden, perf-sucking option is turned on in Windows itself).  Hence we always thought such thumbnails were stale.
Yay!
(In reply to Girish Sharma [:Optimizer] from comment #5)
> Yay!

Given 899436 recently landed, is this fixed for you now ?
I will try with 1st Nightly as the bug will be fixed in that only.
Yup, fixed by bug 899436
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 25
I could intermittently reproduce the issue on the Nightly build mentioned in Description (20130726030203) on Win 7, 64-bit.
I tried several times using Fx 25 beta 4 and it is not reproducing.
Considering this and the Comment 8, I'm removing the verifyme keyword.
Status: RESOLVED → VERIFIED
Keywords: verifyme
I could intermittently reproduce the issue on the Nightly build mentioned in Description (20130726030203) on Win 7, 64-bit.
I tried several times using Fx 25 beta 4 and it is not reproducing.
Considering this and the Comment 8, I'm removing the verifyme keyword.
QA Contact: petruta.rasa
You need to log in before you can comment on or make changes to this bug.