OS.File stat.lastModificationDate returns lastAccessDate on Windows

RESOLVED FIXED in Firefox 24

Status

()

Toolkit
OS.File
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: markh, Assigned: markh)

Tracking

unspecified
mozilla25
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox24 fixed, firefox25 fixed)

Details

(Whiteboard: [qa-])

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Found via bug 898598.  The give-away is the line in osfile_win_allthreads.jsm:

   this._lastModificationDate = lastAccessDate;

:)
(Assignee)

Comment 1

5 years ago
Created attachment 782958 [details] [diff] [review]
osfile-last-modified-time.patch

The tests seem to pass with this change, but I'm not sure if anything else is necessary?
Assignee: nobody → mhammond
Attachment #782958 - Flags: review?(dteller)
Ahaha, that would certainly be useful.
Comment on attachment 782958 [details] [diff] [review]
osfile-last-modified-time.patch

Review of attachment 782958 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, thanks.
Attachment #782958 - Flags: review?(dteller) → review+

Comment 5

5 years ago
https://hg.mozilla.org/mozilla-central/rev/5e5bb1036572
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla25

Comment 6

5 years ago
Any chance of landing this in Firefox 24 for the ESR? It looks pretty straightforward, and this bug is preventing us from using OS.File for various fairly impactful things involving hundreds or thousands of files in Zotero. At best, it will require us to maintain two versions of code (asynchronous and synchronous) for another year, and Zotero users on the ESR will have significantly worse performance.
Looks pretty straightforward, I don't see any reason not to uplift. Mark, want to request approvals?
(Assignee)

Comment 8

5 years ago
Comment on attachment 782958 [details] [diff] [review]
osfile-last-modified-time.patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Unknown
User impact if declined: Addon authors are unable to OS.File in some contexts.
Testing completed (on m-c, etc.): Landed on M-C on July 31.
Risk to taking this patch (and alternatives if risky): Low risk, limited to OS.File functionality on Windows.
String or IDL/UUID changes made by this patch: None

Please see comment 6 and comment 7
Attachment #782958 - Flags: approval-mozilla-beta?
Attachment #782958 - Flags: approval-mozilla-aurora?

Updated

5 years ago
Attachment #782958 - Flags: approval-mozilla-beta?
Attachment #782958 - Flags: approval-mozilla-beta+
Attachment #782958 - Flags: approval-mozilla-aurora?
Attachment #782958 - Flags: approval-mozilla-aurora+
(Assignee)

Updated

5 years ago
status-firefox24: --- → affected
status-firefox25: --- → affected
status-firefox26: --- → verified disabled
(Assignee)

Comment 9

5 years ago
Sorry for the spam, it seems I mis-clicked on the flags
status-firefox26: verified disabled → fixed
This landed on m-c for Fx25, so this doesn't need uplifting to Aurora.

https://hg.mozilla.org/releases/mozilla-beta/rev/6c752934f8b5
status-firefox24: affected → fixed
status-firefox25: affected → fixed
status-firefox26: fixed → ---
Assuming no verification needed here. Please add the verifyme keyword and remove the [qa-] whiteboard tag to request verification.
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.