[B2G][EVERYTHING.ME] [Unagi] User is unable to add apps to Homescreen from everything.me

VERIFIED FIXED

Status

VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: ssuresh, Assigned: amirn)

Tracking

({regression, smoketest})

unspecified
ARM
Gonk (Firefox OS)
regression, smoketest
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:koi+)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

5 years ago
Description:
User is unable to add facebook app to Homescreen through the star button in the bottom of the screen for facebook and twitter apps from everyhting.me

Repro Steps:
1) Updated Unagi to Build ID: 20130726030202
2) Navigate to Everything.me
3) Under Social category, Tap on Facebook/twitter app 
4) Enter the login information and sign into the account
5) Tap on the up arrow and select Star button at the bottom of the screen
6) Select Facebook/Twitter app to add to homescreen 
7) Navigate to Homescreen, observe that facebook/twitter apps are not added to homescreen

Actual:
Facebook/twitter apps cannot be added to Homescreen from everyhting.me

Expected:
Facebook/twitter apps can be added to Homescreen from everyhting.me

Environmental Variables
Build ID: 20130726030202
Gecko: http://hg.mozilla.org/mozilla-central/rev/46d73e889cb4
Gaia: a3d7268219f6ff92d296a3305bdfef14209885dc
Platform Version: 25.0a1

Notes:
Repro frequency: 100%
See attached: screenshot,logcat
(Reporter)

Comment 1

5 years ago
Created attachment 781974 [details]
LogCat
Blocks: 884399
Ran Ben Aharon - Can you look into this? This is breaking daily smoke tests on 1.2 right now.
Flags: needinfo?(ran)
We're investigating it.
A few of our findings - happens for all apps. Not only facebook and twitter. Happens in the Gaia browser as well.

Will fill you in soon when we have more info.
Flags: needinfo?(ran)
(In reply to Ran Ben Aharon (Everything.me) from comment #3)
> We're investigating it.
> A few of our findings - happens for all apps. Not only facebook and twitter.
> Happens in the Gaia browser as well.

So this happens when adding bookmarks to the homescreen then, right?
That's right. But it all works fine unless Evme is loaded :/
(Assignee)

Comment 6

5 years ago
Created attachment 786224 [details]
Patch - redirect to github PR
Attachment #786224 - Flags: review?(21)
Created attachment 786412 [details]
Patch - redirect to github PR
Attachment #786224 - Attachment is obsolete: true
Attachment #786224 - Flags: review?(21)
Attachment #786412 - Flags: review?
Attachment #786412 - Flags: review? → review?(21)
Summary: [B2G][EVERYTHING.ME] [Unagi] User is unable to add facebook and twitter apps to Homescreen from everyhting.me → [B2G][EVERYTHING.ME] [Unagi] User is unable to add apps to Homescreen from everything.me
Comment on attachment 786412 [details]
Patch - redirect to github PR

use strict! This patch is just a very small patch to add some missing |var|.
Attachment #786412 - Flags: review?(21) → review+
I'm not sure it's crucial for leo Vivien. It seems to work fine without it.
(In reply to Ran Ben Aharon (Everything.me) from comment #9)
> I'm not sure it's crucial for leo Vivien. It seems to work fine without it.

Right. I thought this only impacted 1.2?
Oups! koi? would be fine by me.
blocking-b2g: leo? → koi?
Ran - Is this ready to land?
Flags: needinfo?(ran)
blocking-b2g: koi? → koi+
Working on landing it on master
Flags: needinfo?(ran)
Tested and landed in master 91b529657a01a4e3e8781dc28533ed192320c210
Assignee: nobody → amirnissim
Closing per landing in https://github.com/mozilla-b2g/gaia/commit/91b529657a01a4e3e8781dc28533ed192320c210.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 16

5 years ago
This issue no longer occurs on Buri v1.2. Verifying as Works for me.
User is able to add apps to Home screen from everything.me(Homescreen)

Environmental Variables
Build ID: 20130904040205
Gecko: http://hg.mozilla.org/mozilla-central/rev/7ff96bd19c1c
Gaia: b6c5bf1d24230bfed4a8f680e625fa2175001f82
Platform Version: 26.0a1
RIL Version: 01.01.00.019.206
Status: RESOLVED → VERIFIED
Resolution: FIXED → WORKSFORME
This should be fixed per the landing, not works for me.
Resolution: WORKSFORME → FIXED

Updated

5 years ago
Blocks: 930815

Updated

5 years ago
No longer blocks: 930815
You need to log in before you can comment on or make changes to this bug.