Closed Bug 898840 Opened 7 years ago Closed 7 years ago

ERROR: Double ordered argument when localising calendar-extract.properties

Categories

(Mozilla Localizations :: Infrastructure, defect)

x86_64
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 890900

People

(Reporter: iann_bugzilla, Unassigned)

Details

When trying to localise calendar/chrome/calendar/calendar-extract.properties, I have altered one line from:
duration.days = %1$S days
to
duration.days = %1$S day | %1$S days

and when running compare-locales I get:
en-GB/calendar/chrome/calendar/calendar-extract.properties
    ERROR: Double ordered argument 1 at line 212, column 27 for duration.days

When comparing to other entries in the file I cannot see any syntax fault.
It also shows up as an error on the dashboard - https://l10n.mozilla.org/shipping/dashboard?locale=en-GB
Blocks: 893581
This is compare-locales being a bit too strict when localization includes a parameter twice and original contains it only once. See also https://groups.google.com/forum/#!topic/mozilla.dev.l10n/In7T8rSvb6E
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 890900
No longer blocks: 893581
You need to log in before you can comment on or make changes to this bug.