Flash 'pure virtual function call' Error Dialogue

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
5 years ago
3 years ago

People

(Reporter: elvenspellmakerbugzilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 782320 [details]
PureVirtualCall.png

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20130727 Firefox/25.0 (Nightly/Aurora)
Build ID: 20130727030206

Steps to reproduce:

This bug only seems to apply to Windows, as "Linux" (annoyingly) doesn't keep Flash full-screen when switching context. I don't own a Mac and so can't verify whether this applies to that platform also.

The bug applies to Firefox, Aurora and Nightly.

1.) Load up a video on YouTube using the Flash player (not the HTML5 player).
2.) Make the video full-screen.
3.) Go back to the YouTube tab (via any means, Alt Tab is one way). (The Flash player will be in the background or on another monitor)
4.) Refresh the tab. (Such as clicking the refresh button or pressing F5.)


Actual results:

A 'pure virtual function call' error dialogue is displayed on the primary monitor and Nightly locks up (you can't even click on the error message) until you click back on the flash and dismiss the 'continue' or 'stop plug-in' dialogue that appears to tell you the plug-in has become unresponsive.
This dialogue doesn't show until you click back on the full-screen Flash "window", and takes a "random" amount of time to appear.

If you close the flash window by right clicking on the icon on the taskbar and clicking close then an "Adobe Flash Player <version string> is not responding" error pops up, which when dismissed causes Nightly to respond again. Sometimes the 'not responding' plug-in dialogue pops up after this, sometimes not.


Expected results:

The page should have refreshed without the error and the full-screen Flash window should be silently closed.
(Reporter)

Updated

5 years ago
Version: 25 Branch → unspecified

Comment 1

5 years ago
Mozilla/5.0 (Windows NT 6.1; rv:27.0) Gecko/20100101 Firefox/27.0 ID:20130922030201 CSet: 8b4d14afc4f6

I confirm. Tried it in x_86 win7. You should probably change platform to All.

Note: I can reproduce this bug only while playing the video. If I pause the video and perform the STR the full screen flash window silently closes after going back to the youtube tab - no need to refresh.

Last good nightly: 2010-04-09
First bad nightly: 2010-04-10
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=5022d0baf80c&tochange=bd0b0915864b

Note: opening a youtube video in "First bad Nightly" freezes the browser.
(Reporter)

Updated

5 years ago
Hardware: x86_64 → All

Updated

5 years ago
Status: UNCONFIRMED → NEW
Component: Untriaged → Flash (Adobe)
Ever confirmed: true
Product: Firefox → Plugins
Similar to bug 891813.
See Also: → bug 891813
(In reply to Adrian Stanciu from comment #1)
> Note: opening a youtube video in "First bad Nightly" freezes the browser.

Could you file a bug on this, possibly using [1] to get a crash-report if needed? Thanks.

[1] http://benjamin.smedbergs.us/crashfirefox.exe

Comment 4

5 years ago
Here's a better link for the crashfirefox.exe tool: https://developer.mozilla.org/en-US/docs/How_to_Report_a_Hung_Firefox

Updated

5 years ago
See Also: → bug 924862

Comment 5

5 years ago
(In reply to Georg Fritzsche [:gfritzsche] from comment #3)
> Could you file a bug on this, possibly using [1] to get a crash-report if
> needed? Thanks.

I have filed Bug 924862.

Updated

5 years ago
Duplicate of this bug: 925613

Comment 7

3 years ago
I'm closing a lot of bugs which are filed as Adobe Flash bugs which are either irrelevant, not actionable, or not serious enough to track in the Mozilla bug tracker. For the most part, Flash bugs should be filed in Adobe bugbase, and we'll only track a few highly-critical issues in the Mozilla tracker.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.