Closed Bug 899050 Opened 7 years ago Closed 6 years ago

No sound with STEREO output.

Categories

(Core :: Audio/Video, defect)

25 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla27
Tracking Status
firefox24 --- unaffected
firefox25 + verified
firefox26 + verified
firefox27 + verified

People

(Reporter: alice0775, Assigned: padenot)

References

()

Details

(Keywords: regression)

Attachments

(1 file)

Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/73b69c146ca6
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20130728 Firefox/25.0 ID:20130728030204

This is spun off from Bug 894801.
No sound with default STEREO output.
Bug 893307 does not fix.

Aurora24.0a2 works fine.
Nightly25.0a1 with media.gstreamer.enabled=true on ubuntu12.04 works fine.

So, this problem only happens on Nightly25.0a1 Windows7.

Steps To Reproduce
1. Open http://www.brucewiggins.co.uk/Audio/HTML5_51.m4a

Actual Results:
No sound play back

Exoected Results:
Sound should be play back

Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/26f83c4cb81e
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20130709 Firefox/25.0 ID:20130709022917
Bad: no sound
http://hg.mozilla.org/integration/mozilla-inbound/rev/ebdf97f9ec52
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20130709 Firefox/25.0 ID:20130709030058
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=26f83c4cb81e&tochange=ebdf97f9ec52

Regressed by:
ebdf97f9ec52	Paul Adenot — Bug 866675 - Add a WASAPI backend to cubeb. r=kinetik
Right, this is a multichannel file, I had not looked closely at the file before. Not sure what the problem is, though, because the decoders are supposed to downmix it to stereo, and thus request a stereo cubeb stream, later upmixed in WASAPI. I'll see what happens.
Assignee: nobody → paul
What happens here is that we don't downmix multichannel files at the decoder level when using WMF (we do when using opus or vorbis).

Before WASAPI, we were using winmm, that handled everything for us (sample rate conversion, channel mapping, etc.). WASAPI wants the developer to write everything, so we will need to handle the downmix.

It seems a nicer solution anyway, to handle the downmix at the output stream level rather than at the decoder level.
https://hg.mozilla.org/mozilla-central/rev/f74f1e59dc50
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla26
Ha, it seems that I mixed up bug numbers when pushing this one, this is not fixed.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: mozilla26 → ---
Depends on: 911482
Attached patch wasapi-downmixSplinter Review
This make WASAPI behave in the same way as the winmm backend, dropping the channels we can't render.

We can't really do a proper downmixing here (with a downmix matrix of weights and channels). We would need to do at least one of the following:
- Send channel mapping info to cubeb so it can remap (using platform facilities in some backends, manually in other backends).
- Normalize the channel mapping in the *Reader output, and decide of a channel mapping in cubeb.
Attachment #814880 - Flags: review?(kinetik)
Comment on attachment 814880 [details] [diff] [review]
wasapi-downmix

Review of attachment 814880 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for the ping email, I'm still traveling so might not have seen the r? for a couple of days.
Attachment #814880 - Flags: review?(kinetik) → review+
Comment on attachment 814880 [details] [diff] [review]
wasapi-downmix

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 866675
User impact if declined: No sound when playing a multichannel file (I believe this is extremely rare)
Testing completed (on m-c, etc.): try, locally
Risk to taking this patch (and alternatives if risky): no very risky. Alternative is to backout the wasapi backend for this cycle.
String or IDL/UUID changes made by this patch: none.
Attachment #814880 - Flags: approval-mozilla-beta?
Attachment #814880 - Flags: approval-mozilla-aurora?
Comment on attachment 814880 [details] [diff] [review]
wasapi-downmix

Let's get this on Aurora, will leave it up to Alex to decide if this can get into Beta at this late stage.
Attachment #814880 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/rev/18c8f9d64847
Status: REOPENED → RESOLVED
Closed: 7 years ago6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla27
Attachment #814880 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Verified on
- Firefox 25.0b8
- Aurora 26.0a2 buildid 20131015004002
- Nightly 27.0a1 buildid 20131015030319
Status: RESOLVED → VERIFIED
Keywords: verifyme
QA Contact: ananuti
Thanks for your help Ekanan.
Depends on: 927443
Depends on: 952326
No longer depends on: 952326
You need to log in before you can comment on or make changes to this bug.