Change - Create a second shortcut on desktop which launches the Metro browser directly

RESOLVED DUPLICATE of bug 915375

Status

defect
P2
normal
RESOLVED DUPLICATE of bug 915375
6 years ago
5 years ago

People

(Reporter: bbondy, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [preview] feature=change c=Install_and_setup u=browser_user p=0)

Reporter

Description

6 years ago
We currently only have 1 icon on the user's Desktop which launches the Desktop browser on Windows 8.

Asa suggested that we may be able to increase usage of the Metro browser, if we have a second icon that launches the Metro browser directly.

Open question before work should begin on this task: 
1. What does this icon do differently if we are not the default browser (Or should we attempt to delete it in that case)
2. What should the icon be called?
3. Should we restrict this icon to Nightly only? (so that when we uplift it won't go on Aurora, Beta, Release)
4. Do we want this as a new story in v1?
I think we want this for the preview, the sooner the better. 

Strawman answers for Asa:
1 - can it load a page or pop up a blurb that says "We'd love to show you metrofx, but firefox has to be the default browser for that" ?
2 - Is firefox for windows 8 our official title?
3 - I think I'd prefer it to uplift. The point is to clear up user confusion, and we'll want that on all channel right?
4 - I don't see a good reason why not?
Flags: needinfo?(asa)
Whiteboard: [preview]
Priority: -- → P2
I don't think we want to ship this to end users so we should try it out on Nightly and if it's useful there, uplift to Aurora but not Beta. 

For "v1" of this,  let's just do it in the case that you've made Firefox your default browser and not deal with the complexities of non-default browser. 

The launcher's icon should probably called "Firefox Metro" or "Firefox Modern" until we have a better name :)  I suppose it's time for me to get with the Brand team on this one. 

User: Desktop Firefox Tester/Developer

Story: As a Desktop Firefox user on Mozilla's Nightly channel, I can easily find and launch Metro Firefox from the Windows Desktop so that I can contribute to testing. 

Flow: 
1. User sets Firefox as default browser.
2. User sees a Metro Firefox icon appear on her Windows Desktop. 
3. User taps or double-clicks on launcher and is taken to Metro Firefox. 

How's that?
Blocks: 831497
Flags: needinfo?(asa)
Whiteboard: [preview] → c=Install_and_setup u=browser_user [preview]
Summary: Create a second shortcut on desktop which launches the Metro browser directly → Change - Create a second shortcut on desktop which launches the Metro browser directly
Whiteboard: c=Install_and_setup u=browser_user [preview] → feature=change c=Install_and_setup u=browser_user [preview]
Reporter

Comment 3

6 years ago
If in step #2, user sets the default through Firefox and not directly through control panel, then that sounds reasonable to me.   There's a different bug somewhere about "if a user goes directly to control panel to set default" then the Metro tile is not activated.  Likewise this would have the same problem since we don't actually have any code that gets executed when the default changes to us directly through control panel.
(In reply to Brian R. Bondy [:bbondy] from comment #3)
> If in step #2, user sets the default through Firefox and not directly
> through control panel, then that sounds reasonable to me.   There's a
> different bug somewhere about "if a user goes directly to control panel to
> set default" then the Metro tile is not activated.  Likewise this would have
> the same problem since we don't actually have any code that gets executed
> when the default changes to us directly through control panel.

Yeah. Can we fix it so that when you try to set default browser from Firefox preferences we pop up the little picker flyout instead of the control panel? I'm afraid that control panel experience is far too confusing for someone that just wants to open Firefox and make it their default.
Summary: Change - Create a second shortcut on desktop which launches the Metro browser directly → MP Change - Create a second shortcut on desktop which launches the Metro browser directly
Whiteboard: feature=change c=Install_and_setup u=browser_user [preview] → [preview] feature=change c=Install_and_setup u=browser_user
Reporter

Comment 5

6 years ago
(In reply to Asa Dotzler [:asa] from comment #4)
> Yeah. Can we fix it so that when you try to set default browser from Firefox
> preferences we pop up the little picker flyout instead of the control panel?

So right now we have the prompt on startup that will pop that up, but Firefox Options launches the control panel.  That's the same as what IE doe. 

The problem is that the flyout prompt can only set one of: (http&https) or (html&htm).  But not both. 

Chrome opts to always show the flyout and only ever grabs (http&https).  And (http&https) is what gives you a metro browser.

I'd personally like to see Firefox options changed to this on Windows 8:

> [x] Always check to see if Firefox is the default browser on startup
>      [Make Firefox the default HTTP(S) handler] (Also enables Modern style Firefox)
>      [Manage other defaults]

If you want to do that, let me know and I'll file a new bug to handle that work.

> I'm afraid that control panel experience is far too confusing for someone
> that just wants to open Firefox and make it their default.

I agree, I wish they had a better way to set all defaults at once, but even in 8.1 they haven't improved it.
Flags: needinfo?(asa)
Summary: MP Change - Create a second shortcut on desktop which launches the Metro browser directly → [MP] Change - Create a second shortcut on desktop which launches the Metro browser directly
Whiteboard: [preview] feature=change c=Install_and_setup u=browser_user → [preview] feature=change c=Install_and_setup u=browser_user p=0
Blocks: metrov1backlog
No longer blocks: metrov1defect&change
Reporter

Comment 6

6 years ago
p=3 given that there are updater, installer and uninstaller considerations and testing involved.
Whiteboard: [preview] feature=change c=Install_and_setup u=browser_user p=0 → [preview] feature=change c=Install_and_setup u=browser_user p=3
Reporter

Comment 7

6 years ago
So I'm going to call myself blocked on this bug based on me not being sure we want this.

I discussed with Jim on IRC and he feels that adding a second desktop shortcut seems like a shareware-like thing to do.  Is this for sure something we want to do considering others may perceive it the same way?  I'm not confident doing this work will lead to an r+ unless we have a firm assertion that this is a requirement feature.

If you're sure we do want this. I had the idea of always keeping an icon on Desktop for Metro Firefox (since we can't reliably detect and run code when we gain/lose defaults).  If you opened the link when we were not default, we could directly prompt with the HTTP defaults select your browser flyout.  If they didn't select Firefox then we'd close it.

For an alternate idea to accomplish the same goal of Metro Firefox visibility, see bug 915375.

Currently blocked, waiting feedback on the above.
The alternative in my view is just coopt the desktop icon we already create for metro. We have a taskbar and a desktop icon, so I don't see any harm in marking the current desktop icon as immersive.
Reporter

Comment 9

6 years ago
(In reply to Jim Mathies [:jimm] from comment #8)
> The alternative in my view is just coopt the desktop icon we already create
> for metro. We have a taskbar and a desktop icon, so I don't see any harm in
> marking the current desktop icon as immersive.

My personal opinion is that if the user is already in desktop, then they probably want to stay in desktop, but this would definitely be the easiest thing to implement.
(In reply to Brian R. Bondy [:bbondy] from comment #9)
> (In reply to Jim Mathies [:jimm] from comment #8)
> > The alternative in my view is just coopt the desktop icon we already create
> > for metro. We have a taskbar and a desktop icon, so I don't see any harm in
> > marking the current desktop icon as immersive.
> 
> My personal opinion is that if the user is already in desktop, then they
> probably want to stay in desktop, but this would definitely be the easiest
> thing to implement.

I'm sure a few users (desktop purists?) will be like WTF, but I think it's a small annoyance. We'll likely get just as much grief for spamming their desktop with multiple shortcuts. Plus there is an easy work around - delete the metro desktop shortcut and create a new one. Also none of this applies if this install isn't the default in which case the metro shortcut will launch the desktop browser.

What we get from this is a ton of users in looking at the new metro browser.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → INVALID
Flags: needinfo?(asa)
Reporter

Comment 11

6 years ago
As per meeting, after we decided it would be resolved/invalid we talked about leaving this open as a placeholder for some kind of solution to increase exposure.  Re-opening for now.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Summary: [MP] Change - Create a second shortcut on desktop which launches the Metro browser directly → [MP] Increase exposure to Metro Firefox (Needs a decision on how to proceed)
Reporter

Updated

6 years ago
Whiteboard: [preview] feature=change c=Install_and_setup u=browser_user p=3 → [preview] feature=change c=Install_and_setup u=browser_user p=0
Reporter

Updated

6 years ago
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → DUPLICATE
Summary: [MP] Increase exposure to Metro Firefox (Needs a decision on how to proceed) → Change - Create a second shortcut on desktop which launches the Metro browser directly
Duplicate of bug: 915375
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.