Change - Make it easier to get into Metro Firefox (Add a way to "View in Metro" Firefox from Desktop Firefox)

RESOLVED DUPLICATE of bug 924914

Status

()

RESOLVED DUPLICATE of bug 924914
5 years ago
5 years ago

People

(Reporter: bbondy, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Getting into "Metro Firefox" from "Desktop Firefox" is getting harder in Windows 8.1.  Users need to manually pin "Metro Firefox" to the start screen, or go to the 2nd start screen for all apps. [1]

We currently allow switching from "Metro Firefox" to "Desktop Firefox", but not the other way around.

Adding an option in Desktop Firefox is a good idea because it allows users who are detaching their keyboard to easily switch to a touch friendly browser. 

More importantly, it gives us an extra chance to prompt for default browser status (which is linked to the ability to use Metro Firefox).  If the browser isn't the default, and the user selects to switch to Metro Firefox, then we would prompt for default status there. 

I'd normally say let's add an option to the Firefox Menu, but I think that's going away with Australis.  Maybe we need an enabled by default toolbar icon on the top right?

It's currently too hard for a user to i) Set the default via Firefox, ii) Finish with the flyout or control panel, iii) go to the start screen, iv) click on all apps, v) finally click on the browser, or pin it.  A single point of entry via a single button from Desktop Firefox would help.

I think the button would be something like "View page in Metro Firefox" on the button tooltip.

[1]: http://winsupersite.com/windows-8/windows-81-tip-find-your-installed-apps
Yep. This sounds useful to me. Shorlander, Madhava, Gavin, Dolske, what do you all think about a (conditional on being a Windows 8.x user) "View in Metro" trigger appearing somewhere prominently in Australis Aero Flat?
(Reporter)

Updated

5 years ago
Duplicate of this bug: 899269
(Reporter)

Updated

5 years ago
Blocks: 899390
Summary: Make it easier to get into Metro Firefox (Add a way to switch to Metro Firefox from Desktop Firefox) → [MP] Change - Make it easier to get into Metro Firefox (Add a way to switch to Metro Firefox from Desktop Firefox)
Whiteboard: [preview-triage][ux-wanted] → [preview][ux-wanted]
I don't have any philosophical objections :) I'll defer to UXers on what it should look like/how it should work.
No longer blocks: 899390
Summary: [MP] Change - Make it easier to get into Metro Firefox (Add a way to switch to Metro Firefox from Desktop Firefox) → Change - Make it easier to get into Metro Firefox (Add a way to switch to Metro Firefox from Desktop Firefox)
Whiteboard: [preview][ux-wanted] → [ux-wanted]
(Reporter)

Updated

5 years ago
Summary: Change - Make it easier to get into Metro Firefox (Add a way to switch to Metro Firefox from Desktop Firefox) → Change - Make it easier to get into Metro Firefox (Add a way to "View in Metro" Firefox from Desktop Firefox)
(Reporter)

Updated

5 years ago
See Also: → bug 924914
(Reporter)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 924914
No longer blocks: 838081
Whiteboard: [ux-wanted]
You need to log in before you can comment on or make changes to this bug.