apostrophes added in Inspector are changed to '

RESOLVED DUPLICATE of bug 899375

Status

()

Firefox
Developer Tools: Inspector
RESOLVED DUPLICATE of bug 899375
5 years ago
5 years ago

People

(Reporter: Mark Bokil, Assigned: bgrins)

Tracking

23 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0 (Beta/Release)
Build ID: 20130725195523

Steps to reproduce:

In Inpsector attempt to add an apostrophe to a line such as onclick="javascript:sort('a');"


Actual results:

apostrophe is changed to '


Expected results:

should stay as an apostrophe character
(Assignee)

Updated

5 years ago
Assignee: nobody → bgrinstead
(Assignee)

Comment 1

5 years ago
Paul/Mike: Is there a reason why ' is being replaced with ' in the markup view?  https://github.com/mozilla/mozilla-central/blob/fx-team/browser/devtools/markupview/markup-view.js#L1471.  Removing it resolves this issue.
Flags: needinfo?(paul)
Flags: needinfo?(mratcliffe)
(Assignee)

Comment 2

5 years ago
Mark,
Thanks for reporting this!

I talked with dcamp about this issue, and we should be fine with not escaping the ' character inside of attributes.  Patch is incoming.
(Reporter)

Comment 3

5 years ago
Sure, no problem. I noticed it debugging a site and it kept switching characters on me. I figured it would affect others. Are you also working on the Network tab? I used it the other day to debug a large intranet. Very handy tool. We could see the response code was wrong coming from our web cache app and the Network tool made it easy to find. I would love to be able to collapse all columns to the left of Header so I can see the Response 100% width. Is that planned?
Flags: needinfo?(paul)
Flags: needinfo?(mratcliffe)
(Assignee)

Comment 4

5 years ago
>Are you also working on the Network tab?

Mark, 
This is for a different component, so I went ahead and opened a new bug for it: https://bugzilla.mozilla.org/show_bug.cgi?id=899727.  You can add yourself to the CC list for that bug to get updates, and feel free to leave a comment there with any more information.

Updated

5 years ago
Component: Untriaged → Developer Tools: Inspector
(Assignee)

Comment 5

5 years ago
Created attachment 784400 [details] [diff] [review]
899380.patch

Prevents converting ' into '
Attachment #784400 - Flags: review?(mratcliffe)
Comment on attachment 784400 [details] [diff] [review]
899380.patch

Review of attachment 784400 [details] [diff] [review]:
-----------------------------------------------------------------

Looks simple but we always need to ensure that all tests still run properly.

e.g. Test browser/devtools/markupview/test/browser_inspector_markup_edit.js would fail with this patch.

Can you fix the test and I will review it again?
Attachment #784400 - Flags: review?(mratcliffe)
(Assignee)

Comment 7

5 years ago
Created attachment 784433 [details] [diff] [review]
bug-899380-1.patch

Fixes browser_inspector_markup_edit.js test with new expected ' behavior.
Attachment #784400 - Attachment is obsolete: true
Attachment #784433 - Flags: review?(mratcliffe)
Are you able to run this through try yourself?
(Assignee)

Comment 9

5 years ago
(In reply to Michael Ratcliffe [:miker] [:mratcliffe] from comment #8)
> Are you able to run this through try yourself?

No, waiting for approval on this bug: https://bugzilla.mozilla.org/show_bug.cgi?id=900170
Attachment #784433 - Flags: review?(mratcliffe) → review+
(Assignee)

Comment 11

5 years ago
This will be resolved by Bug 899375.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 899375
You need to log in before you can comment on or make changes to this bug.