Last Comment Bug 899635 - Intermittent Ubuntu64 debug "Marionette exited with return code 256: harness failures" errors since the landing of bug 853301
: Intermittent Ubuntu64 debug "Marionette exited with return code 256: harness ...
Status: RESOLVED WORKSFORME
: intermittent-failure
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: x86_64 Linux
-- normal (vote)
: ---
Assigned To: Jeff Walden [:Waldo] (remove +bmo to email)
:
: Jason Orendorff [:jorendorff]
Mentors:
Depends on: 892958 900080
Blocks: 853301
  Show dependency treegraph
 
Reported: 2013-07-30 09:58 PDT by Ryan VanderMeulen [:RyanVM]
Modified: 2014-07-31 04:34 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description User image Ryan VanderMeulen [:RyanVM] 2013-07-30 09:58:32 PDT
No clue why, but a multitude of retriggers have narrowed it down to changeset a297a9937018, which was the enabling of the Internationalization API for desktop builds.

https://tbpl.mozilla.org/php/getParsedLog.php?id=25913869&tree=Mozilla-Inbound

Ubuntu VM 12.04 x64 mozilla-inbound debug test marionette on 2013-07-30 09:05:01 PDT for push a297a9937018
slave: tst-linux64-ec2-004

09:06:57     INFO - #####
09:06:57     INFO - ##### Running run-marionette step.
09:06:57     INFO - #####
09:06:57     INFO - Running pre-action listener: _resource_record_pre_action
09:06:57     INFO - Running main action method: run_marionette
09:06:57     INFO - Getting output from command: ['/builds/slave/test/build/venv/bin/python', '-c', 'from distutils.sysconfig import get_python_lib; print(get_python_lib())']
09:06:57     INFO - Copy/paste: /builds/slave/test/build/venv/bin/python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())"
09:06:57     INFO - Reading from file tmpfile_stdout
09:06:57     INFO - Output received:
09:06:57     INFO -  /builds/slave/test/build/venv/lib/python2.7/site-packages
09:06:57     INFO - retry: Calling <built-in function remove> with args: ('tmpfile_stderr',), kwargs: {}, attempt #1
09:06:57     INFO - retry: Calling <built-in function remove> with args: ('tmpfile_stdout',), kwargs: {}, attempt #1
09:06:57     INFO - Running command: ['/builds/slave/test/build/venv/bin/python', '-u', '/builds/slave/test/build/tests/marionette/marionette/runtests.py', '--binary', '/builds/slave/test/build/application/firefox/firefox', '--address', 'localhost:2828', '--type', 'browser', '/builds/slave/test/build/tests/marionette/tests/testing/marionette/client/marionette/tests/unit-tests.ini']
09:06:57     INFO - Copy/paste: /builds/slave/test/build/venv/bin/python -u /builds/slave/test/build/tests/marionette/marionette/runtests.py --binary /builds/slave/test/build/application/firefox/firefox --address localhost:2828 --type browser /builds/slave/test/build/tests/marionette/tests/testing/marionette/client/marionette/tests/unit-tests.ini
09:06:57     INFO -  /builds/slave/test/build/venv/local/lib/python2.7/site-packages/mozrunner/utils.py:20: UserWarning: Module marionette was already imported from /builds/slave/test/build/tests/marionette/marionette/marionette.py, but /builds/slave/test/build/venv/lib/python2.7/site-packages is being added to sys.path
09:06:57     INFO -    import pkg_resources
09:06:57     INFO -  starting httpd
09:06:58     INFO -  running webserver on http://10.134.57.70:52440/
09:06:58     INFO -  Xlib:  extension "RANDR" missing on display ":0".
09:07:00     INFO -  1375200420542	Marionette	INFO	MarionetteComponent loaded
09:07:00     INFO -  ++DOCSHELL 0x1f8af90 == 1 [id = 1]
09:07:00     INFO -  ++DOMWINDOW == 1 (0x1f654b8) [serial = 1] [outer = (nil)]
09:07:00     INFO -  ++DOMWINDOW == 2 (0x1fa5718) [serial = 2] [outer = 0x1f654b8]
09:07:01     INFO -  pldhash: for the table at address 0x20fbd68, the given entrySize of 168 definitely favors chaining over double hashing.
09:07:01     INFO -  WARNING: No disk space watcher component available!: file ../../../dom/indexedDB/IndexedDatabaseManager.cpp, line 174
09:07:02     INFO -  1375200422691	Marionette	INFO	marionette enabled via command-line
09:07:02     INFO -  1375200422706	Marionette	INFO	marionette-server.js loaded
09:07:02     INFO -  WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80520012: file ../../../../js/xpconnect/loader/mozJSComponentLoader.cpp, line 953
09:07:02     INFO -  1375200422791	Marionette	INFO	Listening on port 2828
09:07:02     INFO -  1375200422794	Marionette	INFO	Marionette server ready
09:07:02     INFO -  ++DOCSHELL 0x264a310 == 2 [id = 2]
09:07:02     INFO -  ++DOMWINDOW == 3 (0x2650728) [serial = 3] [outer = (nil)]
09:07:02     INFO -  ++DOMWINDOW == 4 (0x2654078) [serial = 4] [outer = 0x2650728]
09:07:02     INFO -  ++DOMWINDOW == 5 (0x26fcc78) [serial = 5] [outer = 0x1f654b8]
09:07:03     INFO -  1375200423298	Marionette	DEBUG	accepted connection on 127.0.0.1:37691
09:07:03     INFO -  1375200423929	Marionette	INFO	sendToClient: {"from":"0","ok":true}, {2937b4a0-37c7-4f1e-87f9-c864f34c481f}, {2937b4a0-37c7-4f1e-87f9-c864f34c481f}
09:07:03     INFO -  1375200423998	Marionette	TRACE	Connection closed.
09:07:04     INFO -  ++DOCSHELL 0x2caa850 == 3 [id = 3]
09:07:04     INFO -  ++DOMWINDOW == 6 (0x2cabdb8) [serial = 6] [outer = (nil)]
09:07:04     INFO -  ++DOCSHELL 0x2cae7a0 == 4 [id = 4]
09:07:04     INFO -  ++DOMWINDOW == 7 (0x2caf328) [serial = 7] [outer = (nil)]
09:07:07     INFO -  WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80040111: file ../../../../content/base/src/nsFrameLoader.cpp, line 401
09:07:07     INFO -  ++DOCSHELL 0x3473c90 == 5 [id = 5]
09:07:07     INFO -  ++DOMWINDOW == 8 (0x3475278) [serial = 8] [outer = (nil)]
09:07:07     INFO -  WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80040111: file ../../../../content/base/src/nsFrameLoader.cpp, line 401
09:07:07     INFO -  ++DOMWINDOW == 9 (0x35ee0b8) [serial = 9] [outer = 0x3475278]
09:07:07     INFO -  WARNING: NS_ENSURE_TRUE(NS_SUCCEEDED(rv) && subjPrincipal) failed: file ../../../docshell/base/nsDocShell.cpp, line 8392
09:07:07     INFO -  WARNING: OpenGL-accelerated layers are not supported on this system: file ../../../widget/xpwidgets/nsBaseWidget.cpp, line 893
09:07:07     INFO -  WARNING: Subdocument container has no frame: file ../../../layout/base/nsDocumentViewer.cpp, line 2374
09:07:07     INFO -  ++DOMWINDOW == 10 (0x37023f8) [serial = 10] [outer = 0x2cabdb8]
09:07:07     INFO -  WARNING: Subdocument container has no frame: file ../../../layout/base/nsDocumentViewer.cpp, line 2374
09:07:07     INFO -  ++DOMWINDOW == 11 (0x3714188) [serial = 11] [outer = 0x2caf328]
09:07:07     INFO -  ++DOMWINDOW == 12 (0x372ff58) [serial = 12] [outer = 0x3475278]
09:07:08     INFO -  1375200428588	Marionette	DEBUG	accepted connection on 127.0.0.1:37692
09:07:08     INFO -  1375200428884	Marionette	TRACE	Got: {"to": "root", "type": "getMarionetteID"}
09:07:08     INFO -  1375200428896	Marionette	TRACE	Got: {"to": "0", "type": "newSession"}
09:07:08     INFO -  ++DOCSHELL 0x3a7aba0 == 6 [id = 6]
09:07:08     INFO -  ++DOMWINDOW == 13 (0x3a7c0d8) [serial = 13] [outer = (nil)]
09:07:09     INFO -  ++DOMWINDOW == 14 (0x3aca878) [serial = 14] [outer = 0x3a7c0d8]
09:07:09     INFO -  ++DOMWINDOW == 15 (0x3b83bc8) [serial = 15] [outer = 0x3a7c0d8]
09:07:09     INFO -  1375200429501	Marionette	INFO	loaded marionette-listener.js
09:07:09     INFO -  1375200429577	Marionette	INFO	loaded marionette-listener.js
09:07:09     INFO -  1375200429623	Marionette	INFO	loaded marionette-listener.js
09:07:09     INFO -  1375200429630	Marionette	INFO	sendToClient: {"from":"0","value":"13"}, {5ae3e6fb-59f3-4c95-9397-100f5bec8aea}, {5ae3e6fb-59f3-4c95-9397-100f5bec8aea}
09:07:09     INFO -  1375200429690	Marionette	TRACE	Got: {"to": "0", "session": "13", "type": "getSessionCapabilities"}
09:07:09     INFO -  1375200429696	Marionette	INFO	sendToClient: {"from":"0","value":{"appBuildId":"20130729145427","XULappId":"{ec8030f7-c20a-464f-9b0e-13a3a9e97384}","cssSelectorsEnabled":true,"browserName":"Firefox","handlesAlerts":false,"javascriptEnabled":true,"nativeEvents":false,"platform":"Linux","device":"desktop","rotatable":false,"takesScreenshot":false,"version":"25.0a1"}}, {5fbdfe90-7250-4e0c-a025-1b91f6608167}, {5fbdfe90-7250-4e0c-a025-1b91f6608167}
09:07:09     INFO -  1375200429706	Marionette	TRACE	Got: {"to": "0", "session": "13", "type": "deleteSession"}
09:07:09     INFO -  Traceback (most recent call last):
09:07:09     INFO -    File "/builds/slave/test/build/tests/marionette/marionette/runtests.py", line 791, in <module>
09:07:09     INFO -      cli()
09:07:09     INFO -    File "/builds/slave/test/build/tests/marionette/marionette/runtests.py", line 786, in cli
09:07:09     INFO -      runner = startTestRunner(runner_class, options, tests)
09:07:09     INFO -    File "/builds/slave/test/build/tests/marionette/marionette/runtests.py", line 778, in startTestRunner
09:07:09     INFO -      runner.run_tests(tests)
09:07:09     INFO -    File "/builds/slave/test/build/tests/marionette/marionette/runtests.py", line 423, in run_tests
09:07:09     INFO -      self.run_test(test)
09:07:09     INFO -    File "/builds/slave/test/build/tests/marionette/marionette/runtests.py", line 499, in run_test
09:07:09     INFO -      device=self.device,
09:07:09     INFO -    File "/builds/slave/test/build/tests/marionette/marionette/runtests.py", line 293, in device
09:07:09     INFO -      self._device = self.capabilities.get('device')
09:07:09     INFO -    File "/builds/slave/test/build/tests/marionette/marionette/runtests.py", line 285, in capabilities
09:07:09     INFO -      self.marionette.delete_session()
09:07:09     INFO -    File "/builds/slave/test/build/tests/marionette/marionette/marionette.py", line 465, in delete_session
09:07:09     INFO -      response = self._send_message('deleteSession', 'ok')
09:07:09     INFO -    File "/builds/slave/test/build/tests/marionette/marionette/marionette.py", line 352, in _send_message
09:07:09     INFO -      self._handle_error(response)
09:07:09     INFO -    File "/builds/slave/test/build/tests/marionette/marionette/marionette.py", line 414, in _handle_error
09:07:09     INFO -      raise MarionetteException(message=response, status=500)
09:07:09     INFO -  errors.MarionetteException: {u'message': {}, u'error': u"error occurred while processing 'deleteSession"}
09:07:10    ERROR - Return code: 256
09:07:10     INFO - gecko.log not found
09:07:10     INFO - TinderboxPrint: marionette: <em class="testfail">T-FAIL</em>
09:07:10    ERROR - Marionette exited with return code 256: harness failures
09:07:10    ERROR - # TBPL FAILURE #
09:07:10     INFO - Running post-action listener: _resource_record_post_action
09:07:10     INFO - Running post-run listener: _resource_record_post_run
09:07:11     INFO - Total resource usage - Wall time: 27s; CPU: 99%; Read bytes: 4030464; Write bytes: 40722432; Read time: 2988; Write time: 109500
09:07:11     INFO - install - Wall time: 15s; CPU: 100%; Read bytes: 868352; Write bytes: 23314432; Read time: 272; Write time: 72804
09:07:11     INFO - run-marionette - Wall time: 13s; CPU: 100%; Read bytes: 2453504; Write bytes: 17408000; Read time: 2572; Write time: 36696
Comment 4 User image Ryan VanderMeulen [:RyanVM] 2013-07-30 12:56:21 PDT
https://tbpl.mozilla.org/php/getParsedLog.php?id=25924645&tree=Birch
Comment 5 User image Ryan VanderMeulen [:RyanVM] 2013-07-30 17:18:35 PDT
https://tbpl.mozilla.org/php/getParsedLog.php?id=25934732&tree=Fx-Team
Comment 6 User image Jeff Walden [:Waldo] (remove +bmo to email) 2013-07-30 17:57:28 PDT
I am currently working through https://developer.mozilla.org/en-US/docs/Marionette at P1 priority to hopefully figure out this craziness, fwiw.  If there's anything I need to know that isn't documented on that page or via links from it, people should chime in and explain.  :-)
Comment 7 User image Ryan VanderMeulen [:RyanVM] 2013-07-30 17:58:32 PDT
CCing a few ATeamers who are familiar with Marionette.
Comment 8 User image Ryan VanderMeulen [:RyanVM] 2013-07-31 04:37:31 PDT
https://tbpl.mozilla.org/php/getParsedLog.php?id=25960666&tree=Birch
Comment 9 User image Jonathan Griffin (:jgriffin) 2013-07-31 09:54:09 PDT
There's a small bug in Marionette which is causing us to lose some error information here; at http://mxr.mozilla.org/mozilla-central/source/testing/marionette/marionette-server.js#171, 'e' should be 'e.message'.  I'll push this fix asap.  Hopefully that will help us see what the problem is.
Comment 10 User image Treeherder Robot 2013-07-31 16:44:25 PDT
KWierso
https://tbpl.mozilla.org/php/getParsedLog.php?id=25994525&tree=Mozilla-Inbound
Ubuntu VM 12.04 x64 mozilla-inbound debug test marionette on 2013-07-31 16:34:27
revision: 133bde40e6bc
slave: tst-linux64-ec2-030

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 11 User image Jonathan Griffin (:jgriffin) 2013-07-31 16:51:18 PDT
So with the patch from bug 900080, this gives us more info:

16:36:04     INFO -  errors.MarionetteException: {u'message': u"'Illegal value' when calling method: [nsISessionStore::setNumberOfTabsClosedLast]", u'error': u"error occurred while processing 'deleteSession"}
Comment 12 User image Jonathan Griffin (:jgriffin) 2013-07-31 16:52:16 PDT
(In reply to Jonathan Griffin (:jgriffin) from comment #11)
> So with the patch from bug 900080, this gives us more info:
> 
> 16:36:04     INFO -  errors.MarionetteException: {u'message': u"'Illegal
> value' when calling method: [nsISessionStore::setNumberOfTabsClosedLast]",
> u'error': u"error occurred while processing 'deleteSession"}

Probably coming from:

http://mxr.mozilla.org/mozilla-central/source/testing/marionette/marionette-server.js#1969
Comment 13 User image Treeherder Robot 2013-07-31 20:48:43 PDT
KWierso
https://tbpl.mozilla.org/php/getParsedLog.php?id=26003160&tree=Birch
Ubuntu VM 12.04 x64 birch debug test marionette on 2013-07-31 20:06:00
revision: 7b639a0f9688
slave: tst-linux64-ec2-444

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 14 User image Norbert Lindenberg 2013-07-31 22:48:51 PDT
I was curious how successful test runs differ from failing ones, and noticed one strange difference in the logs: The successful runs have a few warnings that the failing ones don't have, just before the point where the failing runs actually fail. I've marked the lines of a successful log that have no equivalent in a failing log with ">":

  16:40:51     INFO -  WARNING: Subdocument container has no frame: file ../../../layout/base/nsDocumentViewer.cpp, line 2374
  16:40:51     INFO -  ++DOMWINDOW == 11 (0x44dbe28) [serial = 11] [outer = 0x3a73298]
  16:40:51     INFO -  ++DOMWINDOW == 12 (0x44f5e18) [serial = 12] [outer = 0x423ca58]
> 16:40:52     INFO -  WARNING: NS_ENSURE_TRUE(!aStringURI.IsEmpty()) failed: file ../../../docshell/base/nsDefaultURIFixup.cpp, line 119
> 16:40:53     INFO -  WARNING: NS_ENSURE_TRUE(mMutable) failed: file ../../../../netwerk/base/src/nsSimpleURI.cpp, line 266
  16:40:53     INFO -  1375314053907	Marionette	DEBUG	accepted connection on 127.0.0.1:39777
  16:40:53     INFO -  1375314053922	Marionette	TRACE	Got: {"to": "root", "type": "getMarionetteID"}
  16:40:53     INFO -  1375314053931	Marionette	TRACE	Got: {"to": "0", "type": "newSession"}
  16:40:53     INFO -  ++DOCSHELL 0x4b58b80 == 6 [id = 6]
  16:40:53     INFO -  ++DOMWINDOW == 13 (0x4b5a088) [serial = 13] [outer = (nil)]
  16:40:54     INFO -  ++DOMWINDOW == 14 (0x4ba8238) [serial = 14] [outer = 0x4b5a088]
> 16:40:54     INFO -  WARNING: NS_ENSURE_TRUE(mMutable) failed: file ../../../../netwerk/base/src/nsSimpleURI.cpp, line 266
> 16:40:54     INFO -  WARNING: NS_ENSURE_TRUE(mMutable) failed: file ../../../../netwerk/base/src/nsSimpleURI.cpp, line 266
  16:40:54     INFO -  ++DOMWINDOW == 15 (0x4c34678) [serial = 15] [outer = 0x4b5a088]
> 16:40:54     INFO -  WARNING: NS_ENSURE_TRUE(mMutable) failed: file ../../../../netwerk/base/src/nsSimpleURI.cpp, line 266
  16:40:54     INFO -  1375314054945	Marionette	INFO	loaded marionette-listener.js
  16:40:55     INFO -  1375314055005	Marionette	INFO	loaded marionette-listener.js
  16:40:55     INFO -  1375314055050	Marionette	INFO	loaded marionette-listener.js
  16:40:55     INFO -  1375314055056	Marionette	INFO	sendToClient: {"from":"0","value":"13"}, {0d750893-bc91-4671-8fa0-8d6aa8dba934}, {0d750893-bc91-4671-8fa0-8d6aa8dba934}
  16:40:55     INFO -  1375314055171	Marionette	TRACE	Got: {"to": "0", "session": "13", "type": "getSessionCapabilities"}
  16:40:55     INFO -  1375314055178	Marionette	INFO	sendToClient: {"from":"0","value":{"appBuildId":"20130731150450","XULappId":"{ec8030f7-c20a-464f-9b0e-13a3a9e97384}","cssSelectorsEnabled":true,"browserName":"Firefox","handlesAlerts":false,"javascriptEnabled":true,"nativeEvents":false,"platform":"Linux","device":"desktop","rotatable":false,"takesScreenshot":false,"version":"25.0a1"}}, {748e1113-b355-4c30-8a84-e71d14e31dd8}, {748e1113-b355-4c30-8a84-e71d14e31dd8}
  16:40:55     INFO -  1375314055186	Marionette	TRACE	Got: {"to": "0", "session": "13", "type": "deleteSession"}
> 16:40:55     INFO -  WARNING: NS_ENSURE_TRUE(mMutable) failed: file ../../../../netwerk/base/src/nsSimpleURI.cpp, line 266

This is the point where the failure occurs in the failing runs.

I have no idea what this means, if anything, but maybe somebody else has an idea...

The section above is from
https://tbpl.mozilla.org/php/getParsedLog.php?id=25994954&tree=Mozilla-Inbound&full=1
a nearby failing log is
https://tbpl.mozilla.org/php/getParsedLog.php?id=25994525&full=1&branch=mozilla-inbound
Comment 15 User image Jeff Walden [:Waldo] (remove +bmo to email) 2013-08-01 01:11:35 PDT
On the browser side, this seems like it might be hitting

http://hg.mozilla.org/mozilla-central/annotate/05d3797276d3/browser/components/sessionstore/src/SessionStore.jsm#l1577

which doesn't track back meaningfully.

My guess is those warnings are a symptom of something extra happening, that doesn't happen in the builds that fail.  But I don't have a huge amount more understanding of this (other than wrt the location of the failing thing) than I did before getting the elaborated error message.
Comment 16 User image Treeherder Robot 2013-08-01 07:48:40 PDT
edmorley
https://tbpl.mozilla.org/php/getParsedLog.php?id=26022569&tree=B2g-Inbound
Ubuntu VM 12.04 x64 b2g-inbound debug test marionette on 2013-08-01 05:49:08
revision: 8a4c07bae3e8
slave: tst-linux64-ec2-330

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 17 User image Jonathan Griffin (:jgriffin) 2013-08-01 09:25:14 PDT
These errors are all occurring at the very beginning of the test run.

When Marionette creates a new session, it opens a tab...is it possible that doing this too early after browser startup now silently fails, causing a later attempt to close the tab to error out?
Comment 18 User image Treeherder Robot 2013-08-01 10:16:42 PDT
RyanVM
https://tbpl.mozilla.org/php/getParsedLog.php?id=26029282&tree=Fx-Team
Ubuntu VM 12.04 x64 fx-team debug test marionette on 2013-08-01 10:04:01
revision: 57ee510e991e
slave: tst-linux64-ec2-305

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 19 User image Treeherder Robot 2013-08-01 11:26:15 PDT
RyanVM
https://tbpl.mozilla.org/php/getParsedLog.php?id=26027750&tree=Mozilla-Inbound
Ubuntu VM 12.04 x64 mozilla-inbound debug test marionette on 2013-08-01 09:08:51
revision: fc6a6ed70338
slave: tst-linux64-ec2-306

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 20 User image Treeherder Robot 2013-08-01 11:32:25 PDT
RyanVM
https://tbpl.mozilla.org/php/getParsedLog.php?id=26025100&tree=Mozilla-Inbound
Ubuntu VM 12.04 x64 mozilla-inbound debug test marionette on 2013-08-01 07:17:03
revision: 0ef8b0214e7e
slave: tst-linux64-ec2-116

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 21 User image Treeherder Robot 2013-08-02 05:36:30 PDT
edmorley
https://tbpl.mozilla.org/php/getParsedLog.php?id=26070438&tree=Fx-Team
Ubuntu VM 12.04 x64 fx-team debug test marionette on 2013-08-02 05:24:12
revision: 489187b2309d
slave: tst-linux64-ec2-066

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 22 User image Treeherder Robot 2013-08-02 06:45:05 PDT
RyanVM
https://tbpl.mozilla.org/php/getParsedLog.php?id=26071533&tree=B2g-Inbound
Ubuntu VM 12.04 x64 b2g-inbound debug test marionette on 2013-08-02 06:22:05
revision: 739e82b9a884
slave: tst-linux64-ec2-125

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 23 User image Treeherder Robot 2013-08-02 07:48:19 PDT
RyanVM
https://tbpl.mozilla.org/php/getParsedLog.php?id=26074262&tree=Mozilla-Inbound
Ubuntu VM 12.04 mozilla-inbound debug test marionette on 2013-08-02 07:37:20
revision: c116372d7ad4
slave: tst-linux32-ec2-368

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 24 User image Treeherder Robot 2013-08-02 10:29:35 PDT
RyanVM
https://tbpl.mozilla.org/php/getParsedLog.php?id=26080827&tree=Mozilla-Inbound
Ubuntu VM 12.04 x64 mozilla-inbound debug test marionette on 2013-08-02 10:16:58
revision: 32dc36c6af9f
slave: tst-linux64-ec2-406

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 25 User image Treeherder Robot 2013-08-02 12:48:52 PDT
RyanVM
https://tbpl.mozilla.org/php/getParsedLog.php?id=26087176&tree=Fx-Team
Ubuntu VM 12.04 x64 fx-team debug test marionette on 2013-08-02 12:40:02
revision: 37a90c3f8cfe
slave: tst-linux64-ec2-314

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 26 User image Treeherder Robot 2013-08-02 13:06:54 PDT
msucan
https://tbpl.mozilla.org/php/getParsedLog.php?id=26086594&tree=Try
Ubuntu VM 12.04 x64 try debug test marionette on 2013-08-02 12:25:17
revision: 0258b12aba0b
slave: tst-linux64-ec2-406

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 27 User image Treeherder Robot 2013-08-02 13:42:47 PDT
:emk
https://tbpl.mozilla.org/php/getParsedLog.php?id=26076337&tree=Try
Ubuntu VM 12.04 x64 try debug test marionette on 2013-08-02 08:26:27
revision: ed05dfdc8a1a
slave: tst-linux64-ec2-115

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 28 User image Treeherder Robot 2013-08-02 14:23:18 PDT
dkeeler
https://tbpl.mozilla.org/php/getParsedLog.php?id=26088888&tree=Try
Ubuntu VM 12.04 x64 try debug test marionette on 2013-08-02 13:32:03
revision: 5cef3e67da49
slave: tst-linux64-ec2-134

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 29 User image Treeherder Robot 2013-08-05 03:13:36 PDT
Tomcat
https://tbpl.mozilla.org/php/getParsedLog.php?id=26153918&tree=B2g-Inbound
Ubuntu VM 12.04 x64 b2g-inbound debug test marionette on 2013-08-05 00:48:21
revision: 87ae4544f967
slave: tst-linux64-ec2-411

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 30 User image Treeherder Robot 2013-08-08 23:39:42 PDT
Tomcat
https://tbpl.mozilla.org/php/getParsedLog.php?id=26329736&tree=B2g-Inbound
Ubuntu VM 12.04 b2g-inbound debug test marionette on 2013-08-08 17:02:11
revision: f51ee719becf
slave: tst-linux32-ec2-006

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 31 User image Treeherder Robot 2013-08-09 03:26:35 PDT
Tomcat
https://tbpl.mozilla.org/php/getParsedLog.php?id=26345417&tree=Mozilla-B2g18
b2g_ics_armv7a_gecko_emulator mozilla-b2g18 opt test marionette-webapi on 2013-08-09 03:12:01
revision: 45480132106b
slave: talos-r3-fed-075

ImportError: cannot import name OrderedDict
errors.InvalidResponseException: Could not successfully complete transport of message to Gecko, socket closed?
Return code: 256
F/libc    (  396): Fatal signal 11 (SIGSEGV) at 0x44100000 (code=2)
This usually indicates the B2G process has crashed
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 32 User image Treeherder Robot 2013-08-12 16:23:06 PDT
jwalden
https://tbpl.mozilla.org/php/getParsedLog.php?id=26455668&tree=Mozilla-Inbound
Ubuntu VM 12.04 x64 mozilla-inbound debug test marionette on 2013-08-12 16:10:58
revision: 680a80d15f3e
slave: tst-linux64-ec2-362

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 33 User image Jeff Walden [:Waldo] (remove +bmo to email) 2013-08-12 16:27:19 PDT
Comment 32's hit for this is thoroughly bizarre.  That hit is with ICU and the Intl API stuff built, but without it being enabled/exposed to JS.  That is, that build should be exactly identical in functionality to builds without any ICU stuff in them at all.  We shouldn't init ICU, we shouldn't destroy it, we should be ignoring it completely at runtime.  Why this intermittent failure would occur in that situation, then, eludes me completely.  Maybe it's something about binary/library size, tickled only incidentally?  I got nothin'.
Comment 34 User image Treeherder Robot 2013-08-13 06:50:13 PDT
edmorley
https://tbpl.mozilla.org/php/getParsedLog.php?id=26484534&tree=Mozilla-Inbound
Ubuntu VM 12.04 x64 mozilla-inbound debug test marionette on 2013-08-13 06:24:42
revision: ca193619b815
slave: tst-linux64-ec2-089

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 35 User image Treeherder Robot 2013-08-13 16:30:08 PDT
KWierso
https://tbpl.mozilla.org/php/getParsedLog.php?id=26510005&tree=Mozilla-Central
Ubuntu VM 12.04 x64 mozilla-central debug test marionette on 2013-08-13 15:47:54
revision: d8a62355ea26
slave: tst-linux64-ec2-350

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 36 User image Treeherder Robot 2013-08-13 16:30:27 PDT
KWierso
https://tbpl.mozilla.org/php/getParsedLog.php?id=26510005&tree=Mozilla-Central
Ubuntu VM 12.04 x64 mozilla-central debug test marionette on 2013-08-13 15:47:54
revision: d8a62355ea26
slave: tst-linux64-ec2-350

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 37 User image Treeherder Robot 2013-08-14 10:23:02 PDT
RyanVM
https://tbpl.mozilla.org/php/getParsedLog.php?id=26544720&tree=B2g-Inbound
Ubuntu VM 12.04 x64 b2g-inbound debug test marionette on 2013-08-14 09:47:10
revision: 1a7502e440e3
slave: tst-linux64-ec2-417

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 38 User image Treeherder Robot 2013-08-14 21:12:24 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=26569772&tree=Mozilla-Inbound
Ubuntu VM 12.04 x64 mozilla-inbound debug test marionette on 2013-08-14 20:39:00
revision: 66e1ed80ba05
slave: tst-linux64-ec2-419

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 39 User image Treeherder Robot 2013-08-15 08:41:24 PDT
edmorley
https://tbpl.mozilla.org/php/getParsedLog.php?id=26584525&tree=Fx-Team
Ubuntu VM 12.04 x64 fx-team debug test marionette on 2013-08-15 06:32:00
revision: 986f2f71d1b6
slave: tst-linux64-ec2-305

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 40 User image Treeherder Robot 2013-08-16 19:14:25 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=26660952&tree=Fx-Team
Ubuntu VM 12.04 fx-team debug test marionette on 2013-08-16 16:53:29
revision: ca3adb47f9b7
slave: tst-linux32-ec2-342

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 41 User image Treeherder Robot 2013-08-18 23:49:36 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=26708883&tree=Mozilla-Inbound
Ubuntu VM 12.04 x64 mozilla-inbound debug test marionette on 2013-08-18 23:07:15
revision: 9e1ae1f29036
slave: tst-linux64-ec2-120

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 42 User image Treeherder Robot 2013-08-19 05:03:29 PDT
edmorley
https://tbpl.mozilla.org/php/getParsedLog.php?id=26715520&tree=Mozilla-Inbound
Ubuntu VM 12.04 x64 mozilla-inbound debug test marionette on 2013-08-19 04:51:03
revision: 5b5a0de73c74
slave: tst-linux64-ec2-021

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 43 User image Treeherder Robot 2013-08-20 12:57:13 PDT
RyanVM
https://tbpl.mozilla.org/php/getParsedLog.php?id=26781989&tree=Fx-Team
Ubuntu VM 12.04 x64 fx-team debug test marionette on 2013-08-20 12:50:12
revision: c29ab370bfd5
slave: tst-linux64-ec2-429

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 44 User image Treeherder Robot 2013-08-20 18:13:48 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=26784019&tree=Fx-Team
Rev4 MacOSX Snow Leopard 10.6 fx-team debug test marionette on 2013-08-20 13:47:53
revision: ceb9333feb21
slave: talos-r4-snow-022

ImportError: cannot import name OrderedDict
Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 45 User image Treeherder Robot 2013-08-22 03:40:54 PDT
edmorley
https://tbpl.mozilla.org/php/getParsedLog.php?id=26860119&tree=B2g-Inbound
Ubuntu VM 12.04 x64 b2g-inbound debug test marionette on 2013-08-22 02:10:38
revision: 1562233fed4d
slave: tst-linux64-ec2-018

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 46 User image Treeherder Robot 2013-08-22 11:29:11 PDT
RyanVM
https://tbpl.mozilla.org/php/getParsedLog.php?id=26878691&tree=Mozilla-Inbound
Ubuntu VM 12.04 x64 mozilla-inbound debug test marionette on 2013-08-22 10:33:59
revision: 698bf87a8347
slave: tst-linux64-ec2-108

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 47 User image Treeherder Robot 2013-08-22 12:39:12 PDT
RyanVM
https://tbpl.mozilla.org/php/getParsedLog.php?id=26883564&tree=Fx-Team
Ubuntu VM 12.04 x64 fx-team debug test marionette on 2013-08-22 12:27:06
revision: bc7f9e3e52ea
slave: tst-linux64-ec2-108

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 48 User image Treeherder Robot 2013-08-22 17:09:12 PDT
KWierso
https://tbpl.mozilla.org/php/getParsedLog.php?id=26896186&tree=Fx-Team
Ubuntu VM 12.04 fx-team debug test marionette on 2013-08-22 16:27:02
revision: 83254f71904c
slave: tst-linux32-ec2-312

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 49 User image Treeherder Robot 2013-08-23 13:02:10 PDT
RyanVM
https://tbpl.mozilla.org/php/getParsedLog.php?id=26933772&tree=Fx-Team
Ubuntu VM 12.04 x64 fx-team debug test marionette on 2013-08-23 12:37:08
revision: d7f20a38e66e
slave: tst-linux64-ec2-074

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 50 User image Treeherder Robot 2013-08-23 14:10:00 PDT
RyanVM
https://tbpl.mozilla.org/php/getParsedLog.php?id=26937330&tree=Mozilla-Inbound
Ubuntu VM 12.04 x64 mozilla-inbound debug test marionette on 2013-08-23 13:57:07
revision: 76a5ca209147
slave: tst-linux64-ec2-136

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 51 User image Treeherder Robot 2013-08-26 17:03:25 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=27029380&tree=Mozilla-Inbound
Ubuntu VM 12.04 x64 mozilla-inbound debug test marionette on 2013-08-26 16:48:39
revision: 64f105f3569c
slave: tst-linux64-ec2-303

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 52 User image Treeherder Robot 2013-08-27 13:35:07 PDT
Gijs
https://tbpl.mozilla.org/php/getParsedLog.php?id=27077011&tree=UX
Rev4 MacOSX Snow Leopard 10.6 ux debug test marionette on 2013-08-27 12:48:56
revision: 4154345daff7
slave: talos-r4-snow-059

ImportError: cannot import name OrderedDict
Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 53 User image Treeherder Robot 2013-09-02 06:24:48 PDT
edmorley
https://tbpl.mozilla.org/php/getParsedLog.php?id=27293494&tree=B2g-Inbound
b2g_emulator b2g-inbound opt test marionette-webapi on 2013-09-02 05:08:57
revision: 616d5df5723f
slave: talos-r3-fed-025

ImportError: cannot import name OrderedDict
AttributeError: 'NoneType' object has no attribute 'close'
Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 54 User image Treeherder Robot 2013-09-05 08:53:17 PDT
RyanVM
https://tbpl.mozilla.org/php/getParsedLog.php?id=27433394&tree=Mozilla-Inbound
Ubuntu VM 12.04 x64 mozilla-inbound debug test marionette on 2013-09-05 08:31:20
revision: c747fd285dfa
slave: tst-linux64-ec2-308

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 55 User image Treeherder Robot 2013-09-05 11:05:38 PDT
RyanVM
https://tbpl.mozilla.org/php/getParsedLog.php?id=27439877&tree=Fx-Team
Ubuntu VM 12.04 x64 fx-team debug test marionette on 2013-09-05 10:53:51
revision: fb3a60e0feda
slave: tst-linux64-ec2-434

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 56 User image Treeherder Robot 2013-09-09 06:45:49 PDT
Tomcat
https://tbpl.mozilla.org/php/getParsedLog.php?id=27576330&tree=Mozilla-Central
Ubuntu VM 12.04 x64 mozilla-central debug test marionette on 2013-09-09 06:33:47
revision: 9846f07d5867
slave: tst-linux64-ec2-092

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 57 User image Treeherder Robot 2013-09-11 17:06:48 PDT
KWierso
https://tbpl.mozilla.org/php/getParsedLog.php?id=27731551&tree=Mozilla-Inbound
Ubuntu VM 12.04 x64 mozilla-inbound debug test marionette on 2013-09-11 17:00:37
revision: c10263f35b2c
slave: tst-linux64-ec2-071

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 58 User image Treeherder Robot 2013-09-12 06:24:25 PDT
edmorley
https://tbpl.mozilla.org/php/getParsedLog.php?id=27765049&tree=Fx-Team
Ubuntu VM 12.04 x64 fx-team debug test marionette on 2013-09-12 06:01:18
revision: 29a87d8049b0
slave: tst-linux64-ec2-350

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 59 User image Treeherder Robot 2013-09-20 20:54:37 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=28186464&tree=Mozilla-Central
Ubuntu VM 12.04 x64 mozilla-central debug test marionette on 2013-09-20 20:15:40
revision: 1e33678f89fe
slave: tst-linux64-ec2-360

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 60 User image Treeherder Robot 2013-10-17 10:44:42 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=29260687&tree=Mozilla-Inbound
Ubuntu VM 12.04 x64 mozilla-inbound debug test marionette on 2013-10-17 10:28:37
revision: 81b505e9a435
slave: tst-linux64-ec2-356

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 61 User image Treeherder Robot 2013-10-17 16:34:57 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=29278242&tree=Mozilla-Inbound
Ubuntu VM 12.04 x64 mozilla-inbound debug test marionette on 2013-10-17 16:21:58
revision: 999ed39dc0e7
slave: tst-linux64-ec2-078

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 62 User image Treeherder Robot 2013-10-18 15:42:24 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=29333431&tree=Mozilla-Inbound
Ubuntu VM 12.04 x64 mozilla-inbound debug test marionette on 2013-10-18 15:19:48
revision: 4d2eb79e83b3
slave: tst-linux64-ec2-111

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 63 User image Treeherder Robot 2013-10-19 09:26:48 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=29369319&tree=Mozilla-Inbound
Ubuntu VM 12.04 x64 mozilla-inbound debug test marionette on 2013-10-19 08:57:35
revision: 77f70432fdcd
slave: tst-linux64-ec2-033

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 64 User image Treeherder Robot 2013-10-19 21:44:59 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=29390574&tree=Mozilla-Inbound
Ubuntu VM 12.04 x64 mozilla-inbound debug test marionette on 2013-10-19 21:30:19
revision: 0502bca5354d
slave: tst-linux64-ec2-041

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 65 User image Treeherder Robot 2013-10-21 13:05:50 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=29451193&tree=Mozilla-Inbound
Ubuntu VM 12.04 x64 mozilla-inbound debug test marionette on 2013-10-21 12:53:33
revision: 4503553be6de
slave: tst-linux64-ec2-052

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 66 User image Treeherder Robot 2013-10-23 11:36:29 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=29558661&tree=Mozilla-Inbound
Ubuntu VM 12.04 mozilla-inbound debug test marionette on 2013-10-23 11:04:34
revision: eafe6b0acd33
slave: tst-linux32-ec2-123

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 67 User image Treeherder Robot 2013-10-24 20:01:22 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=29634676&tree=Fx-Team
Ubuntu VM 12.04 x64 fx-team debug test marionette on 2013-10-24 19:45:25
revision: 3f41909b9433
slave: tst-linux64-ec2-067

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 68 User image Treeherder Robot 2013-10-25 04:43:14 PDT
edmorley
https://tbpl.mozilla.org/php/getParsedLog.php?id=29651756&tree=B2g-Inbound
Ubuntu VM 12.04 b2g-inbound debug test marionette on 2013-10-25 04:12:58
revision: 48118186773b
slave: tst-linux32-ec2-143

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 69 User image Treeherder Robot 2013-10-31 21:29:18 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=29946667&tree=Mozilla-Inbound
Ubuntu VM 12.04 x64 mozilla-inbound debug test marionette on 2013-10-31 21:16:22
revision: f532e4f26307
slave: tst-linux64-ec2-004

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 70 User image Treeherder Robot 2013-11-01 17:36:02 PDT
KWierso
https://tbpl.mozilla.org/php/getParsedLog.php?id=30000619&tree=Mozilla-Inbound
Ubuntu VM 12.04 mozilla-inbound debug test marionette on 2013-11-01 17:19:38
revision: 3436653be106
slave: tst-linux32-ec2-075

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 71 User image Treeherder Robot 2013-11-02 00:53:33 PDT
:nigelb
https://tbpl.mozilla.org/php/getParsedLog.php?id=30012720&tree=Mozilla-Inbound
Ubuntu VM 12.04 mozilla-inbound debug test marionette on 2013-11-02 00:43:17
revision: 29a30f4e9ad5
slave: tst-linux32-ec2-034

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 72 User image Treeherder Robot 2013-11-03 18:48:03 PST
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=30058553&tree=Mozilla-Inbound
Ubuntu VM 12.04 x64 mozilla-inbound debug test marionette on 2013-11-03 18:15:20
revision: 07cedf69a2ed
slave: tst-linux64-ec2-068

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 73 User image Treeherder Robot 2013-11-04 16:17:03 PST
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=30103658&tree=Fx-Team
Ubuntu VM 12.04 x64 fx-team debug test marionette on 2013-11-04 16:06:53
revision: c800ad2e84d2
slave: tst-linux64-ec2-101

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 74 User image Treeherder Robot 2013-11-06 13:20:10 PST
KWierso
https://tbpl.mozilla.org/php/getParsedLog.php?id=30227746&tree=Mozilla-Inbound
Ubuntu VM 12.04 mozilla-inbound debug test marionette on 2013-11-06 13:05:51
revision: 0b5ffddb8bad
slave: tst-linux32-ec2-012

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 75 User image Treeherder Robot 2013-11-06 14:21:46 PST
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=30230756&tree=Mozilla-Inbound
Ubuntu VM 12.04 x64 mozilla-inbound debug test marionette on 2013-11-06 14:01:15
revision: 4e84bb9b38fa
slave: tst-linux64-ec2-097

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 76 User image Treeherder Robot 2013-11-06 15:40:15 PST
KWierso
https://tbpl.mozilla.org/php/getParsedLog.php?id=30235771&tree=Mozilla-Inbound
Ubuntu VM 12.04 x64 mozilla-inbound debug test marionette on 2013-11-06 15:26:15
revision: faee77ddc112
slave: tst-linux64-ec2-026

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 77 User image Treeherder Robot 2013-11-07 10:10:23 PST
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=30279980&tree=Mozilla-Inbound
Ubuntu VM 12.04 x64 mozilla-inbound debug test marionette on 2013-11-07 09:50:22
revision: b48e11fc1f35
slave: tst-linux64-ec2-308

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 78 User image Treeherder Robot 2013-11-08 09:16:14 PST
RyanVM
https://tbpl.mozilla.org/php/getParsedLog.php?id=30333574&tree=Fx-Team
Ubuntu VM 12.04 fx-team debug test marionette on 2013-11-08 08:37:14
revision: ff3e6bc839c6
slave: tst-linux32-ec2-143

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 79 User image Treeherder Robot 2013-11-11 10:26:19 PST
KWierso
https://tbpl.mozilla.org/php/getParsedLog.php?id=30420940&tree=Mozilla-Inbound
Ubuntu VM 12.04 x64 mozilla-inbound debug test marionette on 2013-11-11 08:13:27
revision: 8c2d1c1b2eaf
slave: tst-linux64-ec2-072

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 80 User image Treeherder Robot 2013-11-12 10:32:10 PST
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=30480421&tree=Mozilla-Inbound
Ubuntu VM 12.04 x64 mozilla-inbound debug test marionette on 2013-11-12 10:19:17
revision: 059604ce6eb7
slave: tst-linux64-ec2-092

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 81 User image Treeherder Robot 2013-11-12 12:18:05 PST
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=30486401&tree=Mozilla-Inbound
Ubuntu VM 12.04 mozilla-inbound debug test marionette on 2013-11-12 12:04:31
revision: 475bd77c3400
slave: tst-linux32-ec2-365

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 83 User image Treeherder Robot 2013-11-14 15:29:41 PST
RyanVM
https://tbpl.mozilla.org/php/getParsedLog.php?id=30576409&tree=Try
Ubuntu VM 12.04 try debug test marionette on 2013-11-14 15:11:06
revision: e25c11152c0a
slave: tst-linux32-ec2-066

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 84 User image Treeherder Robot 2013-11-18 05:14:06 PST
Tomcat
https://tbpl.mozilla.org/php/getParsedLog.php?id=30694997&tree=Mozilla-Inbound
Ubuntu VM 12.04 x64 mozilla-inbound debug test marionette on 2013-11-18 04:42:34
revision: 3d78b5d79128
slave: tst-linux64-ec2-144

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 85 User image Treeherder Robot 2013-11-19 13:36:59 PST
KWierso
https://tbpl.mozilla.org/php/getParsedLog.php?id=30786759&tree=B2g-Inbound
Ubuntu VM 12.04 x64 b2g-inbound debug test marionette on 2013-11-19 13:19:05
revision: 62a986812642
slave: tst-linux64-ec2-101

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 86 User image Treeherder Robot 2013-11-19 16:38:10 PST
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=30796634&tree=Fx-Team
Ubuntu VM 12.04 x64 fx-team debug test marionette on 2013-11-19 16:22:39
revision: a549ddceda0a
slave: tst-linux64-ec2-339

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 87 User image Treeherder Robot 2013-11-21 09:28:50 PST
RyanVM
https://tbpl.mozilla.org/php/getParsedLog.php?id=30901382&tree=B2g-Inbound
Ubuntu VM 12.04 x64 b2g-inbound debug test marionette on 2013-11-21 09:13:32
revision: 4c959d937a76
slave: tst-linux64-ec2-097

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 88 User image Treeherder Robot 2013-11-22 14:10:41 PST
KWierso
https://tbpl.mozilla.org/php/getParsedLog.php?id=30978964&tree=Mozilla-Central
Ubuntu VM 12.04 x64 mozilla-central debug test marionette on 2013-11-22 13:46:16
revision: b9980eb88a26
slave: tst-linux64-ec2-316

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 89 User image Treeherder Robot 2013-11-28 08:18:43 PST
edmorley
https://tbpl.mozilla.org/php/getParsedLog.php?id=31225371&tree=Mozilla-Inbound
Ubuntu VM 12.04 x64 mozilla-inbound debug test marionette on 2013-11-28 07:29:24
revision: ee99af9fdbb3
slave: tst-linux64-ec2-384

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 90 User image Treeherder Robot 2013-12-01 23:10:51 PST
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=31306729&tree=Fx-Team
Ubuntu VM 12.04 x64 fx-team debug test marionette on 2013-12-01 22:59:23
revision: 9cbe6533c480
slave: tst-linux64-spot-123

Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 91 User image Treeherder Robot 2013-12-04 02:27:19 PST
Tomcat
https://tbpl.mozilla.org/php/getParsedLog.php?id=31435019&tree=B2g-Inbound
b2g_emulator_vm b2g-inbound opt test marionette-webapi on 2013-12-04 01:44:25
revision: 253e97c9c3f0
slave: tst-linux64-ec2-113

AttributeError: 'NoneType' object has no attribute 'close'
Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 92 User image Treeherder Robot 2013-12-04 02:54:54 PST
Tomcat
https://tbpl.mozilla.org/php/getParsedLog.php?id=31436742&tree=Mozilla-Central
b2g_emulator_vm mozilla-central opt test marionette-webapi on 2013-12-04 02:22:42
revision: 9688476c1544
slave: tst-linux64-ec2-332

AttributeError: 'NoneType' object has no attribute 'close'
Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 93 User image Treeherder Robot 2013-12-04 03:40:42 PST
Tomcat
https://tbpl.mozilla.org/php/getParsedLog.php?id=31438435&tree=B2g-Inbound
b2g_emulator_vm b2g-inbound opt test marionette-webapi on 2013-12-04 03:09:26
revision: 77d878ef10aa
slave: tst-linux64-ec2-461

AttributeError: 'NoneType' object has no attribute 'close'
Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 94 User image Treeherder Robot 2014-01-17 19:50:29 PST
RyanVM
https://tbpl.mozilla.org/php/getParsedLog.php?id=33208907&tree=Mozilla-Aurora
Ubuntu VM 12.04 mozilla-aurora debug test marionette on 2014-01-17 19:17:35
revision: 1f9d7af12960
slave: tst-linux32-spot-447

raise TimeoutException(message='socket.timeout', status=ErrorCodes.TIMEOUT, stacktrace=None)
errors.TimeoutException: socket.timeout
Return code: 256
Marionette exited with return code 256: harness failures
# TBPL FAILURE #
Comment 95 User image Ed Morley [:emorley] 2014-07-31 04:34:07 PDT
Closing bugs where TBPLbot has previously commented, but have now not been modified for >3 months & do not contain the whiteboard strings for disabled/annotated tests or use the keyword leave-open. Filter on: mass-intermittent-bug-closure-2014-07

Note You need to log in before you can comment on or make changes to this bug.