Closed Bug 899641 Opened 11 years ago Closed 11 years ago

Support Windows 8.1 (Windows NT 6.3) reporting

Categories

(Socorro :: Database, task)

task
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: kairo, Assigned: selenamarie)

Details

(Whiteboard: [qa-])

I just saw a good amount of "Windows Unknown" in the signature summary of this one: https://crash-stats.mozilla.com/report/list?signature=mozilla%3A%3Anet%3A%3AFTPChannelParent%3A%3AOnStartRequest%28nsIRequest*%2C%20nsISupports*%29

Most, if not all, of those are actually "Windows NT 6.3.9431" if you look into the Reports tab. We should map Windows NT 6.3.* to Windows 8.1, actually, and not put it under "Unknown".
rhelmer says this is in the windows_versions table in the database. Over to selena
Component: General → Database
Assignee: nobody → sdeckelmann
Target Milestone: --- → 55
Commits pushed to master at https://github.com/mozilla/socorro

https://github.com/mozilla/socorro/commit/305e59e6aa42fbc8948ecf7d36a019aef3f914d0
Fixes bug 899641 Add Windows NT 6.3 support

https://github.com/mozilla/socorro/commit/50b62bd9f50fbb836e2feaf3d07a2d50ea444d29
Merge pull request #1375 from selenamarie/bug899641-windows-nt-6.3

Fixes bug 899641 Add Windows NT 6.3 support
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
I think you made this "Windows 8" here, but NT 6.3 is "Windows 8.1", actually (Windows 8[.0] is NT 6.2 and that's already in the DB).
Whiteboard: [DB Changes][qa-]
It's not fixed for the above example and even in the stage server (see https://crash-stats.allizom.org/report/list?signature=zzz_AsmCodeRange_Begin).
There are 17 Unknown Windows crashes matching Windows 5.2 (Windows Server 2003) and Windows 6.3 (Windows 8.1).
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Windows NT 5.2 was not covered by this bug, so it doesn't matter for this.

Also, I'm pretty sure that only newly added crashes are caught by the change, not ones that have already been aggregated. Not sure when this aggregation first ran for stage with this DB change applied.
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #6)
> Also, I'm pretty sure that only newly added crashes are caught by the
> change, not ones that have already been aggregated. Not sure when this
> aggregation first ran for stage with this DB change applied.
Socorro 55 was pushed on July 31 (see bug 900176) and there have been crashes on Windows 8.1 for zzz_AsmCodeRange_Begin | nsDependentCString::nsDependentCString(char const*) since (see https://crash-stats.mozilla.com/report/list?signature=zzz_AsmCodeRange_Begin%20|%20nsDependentCString%3A%3AnsDependentCString%28char%20const*%29) but they are still classified as Windows Unknown in the summary.
Changes for this bug are going out in 56.
Target Milestone: 55 → 56
Status: REOPENED → RESOLVED
Closed: 11 years ago11 years ago
Resolution: --- → FIXED
Hmm, https://crash-stats.mozilla.com/report/list?product=Firefox&signature=mozilla%3A%3AWebGLTexture%3A%3AHasImageInfoAt%28unsigned+int%2C+int%29 is still reporting the Win8.1 crashes as "Windows Unknown" in the signature summary.

Did this not work?
Reopening so comment #9 is being looked at, it looks like this isn't working.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Turns out the os_versions table already had been updated to say 'Windows Unknown' instead of Windows 8.1 

I believe this will fix the problem: 

breakpad=# update os_versions set os_version_string = 'Windows 8.1' where major_version = 6 and minor_version = 3;
Confirmed Windowns 8.1 is now showing up properly in this report: https://crash-stats.mozilla.com/report/list?product=Firefox&range_value=7&range_unit=days&date=2013-11-01&signature=mozilla%3A%3Adom%3A%3AWindowBinding%3A%3Aget_content&version=Firefox%3A28.0a1

Let me know if there are further problems!
Status: REOPENED → RESOLVED
Closed: 11 years ago11 years ago
Resolution: --- → FIXED
Whiteboard: [DB Changes][qa-] → [qa-]
Target Milestone: 56 → 65
Bumping to verified as [qa-].
Status: RESOLVED → VERIFIED
Commit pushed to master at https://github.com/mozilla-services/socorro

https://github.com/mozilla-services/socorro/commit/b6885b7a6ea7e4f692ab046fd92066dfac137525
Fresh socorro installations misses some win-versions (#3840)

Changes from Bug899641 and Bug1132652 are not presented in staticdata
file that used on fresh socorro installations.
Here we add missed win versions.
You need to log in before you can comment on or make changes to this bug.