If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Give the start-msvc*.bat files clearer names

RESOLVED FIXED

Status

mozilla.org
MozillaBuild
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: botond, Assigned: emorley)

Tracking

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
I think the names of the start-msvc*.bat files are misleading. 

I would expect a batch file named start-msvc11.bat to, well, start MSVC 11, but it doesn't do that - it opens up a /terminal/, with some environment variables related to MSVC 11 set.

In fact, having assumed that start-msvc11.bat starts MSVC 11 itself, I spent a good bit of time looking for something that would start a terminal with an appropriate environment set up...

How about start-msvc11-terminal.bar or start-msvc11-shell.bat instead?
(Assignee)

Comment 1

4 years ago
Ryan, do you have a preference for the naming?

Either:
  start-shell-FOO.bat
or
  start-FOO-shell.bat

Where FOO is {msvc11,msvc10,...}
Flags: needinfo?(ryanvm)
start-shell-FOO.bat
Flags: needinfo?(ryanvm)
(Assignee)

Comment 3

4 years ago
Created attachment 829267 [details] [diff] [review]
Give the start-*.bat files clearer names

Renamed as follows:
guess-msvc.bat -> start-shell-autodetect-msvc.bat
start-l10n.bat -> start-shell-l10n.bat
start-msvc10.bat -> start-shell-msvc10.bat
start-msvc10-x64.bat -> start-shell-msvc10-x64.bat
start-msvc11.bat -> start-shell-msvc11.bat
start-msvc11-x64.bat -> start-shell-msvc11-x64.bat
start-msvc12.bat -> start-shell-msvc12.bat
start-msvc12-x64.bat -> start-shell-msvc12-x64.bat

Will update wiki etc for build l10n stuff once the new version of mozilla-build that includes this is released.
Attachment #829267 - Flags: review?(ryanvm)
(Assignee)

Updated

4 years ago
Assignee: nobody → emorley
Status: NEW → ASSIGNED
Attachment #829267 - Flags: review?(ryanvm) → review+
(Assignee)

Comment 4

4 years ago
https://hg.mozilla.org/mozilla-build/rev/1c39b251a654
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Comment 5

4 years ago
Is it too late to ask that we rename the scripts to have the user-facing product versions in them instead of the internal version identifier? e.g. "2012"
(Assignee)

Comment 6

4 years ago
(In reply to Gregory Szorc [:gps] from comment #5)
> Is it too late to ask that we rename the scripts to have the user-facing
> product versions in them instead of the internal version identifier? e.g.
> "2012"

Ryan, this sound ok to you?
Flags: needinfo?(ryanvm)
Fine by me.
Flags: needinfo?(ryanvm)
Please don't rename the guess-msvc.bat script. It doesn't actually set up your environment, it just does detection and sets some environment variables for the start-* scripts to use.
Also, this changeset is broken because you didn't rename the calls to guess-msvc.bat in the start scripts:
https://hg.mozilla.org/mozilla-build/file/1c39b251a654/start-shell-msvc12.bat#l11
(Assignee)

Comment 10

4 years ago
Ah I thought the file were totally independent.

They're even more of a mess than I thought then (given the sheer number of lines, even with calling the guess-msvc.bat file at the start).

We really need to just consolidate them all and provide an option to manually override the choice of VS version used.
(Assignee)

Updated

4 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 11

4 years ago
Have restored guess-msvc.bat's original name (left the others), which fixes comment 9 too:
https://hg.mozilla.org/mozilla-build/rev/02db92a7f797
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 12

4 years ago
Created attachment 8338528 [details] [diff] [review]
Give the start-*.bat files clearer names, mark 2;

This uses the more friendly names suggested by gps in comment 5.
(Assignee)

Comment 13

4 years ago
https://hg.mozilla.org/mozilla-build/rev/eae291fcd120

Net effects of the various landings in this bug are:

start-l10n.bat -> start-shell-l10n.bat
start-msvc10.bat -> start-shell-msvc2010.bat
start-msvc10-x64.bat -> start-shell-msvc2010-x64.bat
start-msvc11.bat -> start-shell-msvc2012.bat
start-msvc11-x64.bat -> start-shell-msvc2012-x64.bat
start-msvc12.bat -> start-shell-msvc2013.bat
start-msvc12-x64.bat -> start-shell-msvc2013-x64.bat

Comment 14

4 years ago
How to please use files for compile Windows 603 version from https://hg.mozilla.org/mozilla-build/file/eae291fcd120 ???

Or (better) what time finished MozillaBuildSetup-1.9.0.exe in http://ftp.mozilla.org/pub/mozilla.org/mozilla/libraries/win32/ ???

Thang You (and Sorry for O.T.)
Blocks: 988059

Comment 15

4 years ago
The above changes are not reflected in
http://ftp.mozilla.org/pub/mozilla.org/mozilla/libraries/win32/

MozillaBuildSetup-Latest.exe	29-Aug-2013 13:38	 85M	 

We are currently at VERSION 1.8.

We are looking forward to a revision bump to VERSION 1.9.

(In reply to Sladky Vladimir from comment #14)
> How to please use files for compile Windows 603 version from
> https://hg.mozilla.org/mozilla-build/file/eae291fcd120 ???
> 
> Or (better) what time finished MozillaBuildSetup-1.9.0.exe in
> http://ftp.mozilla.org/pub/mozilla.org/mozilla/libraries/win32/ ???
> 
> Thang You (and Sorry for O.T.)
(Assignee)

Comment 16

4 years ago
Updated the filenames listed for the following:
https://developer.mozilla.org/en-US/docs/Developer_Guide/Build_Instructions/Windows_Prerequisites
https://developer.mozilla.org/en-US/docs/Simple_Firefox_build/Windows_Firefox_build
https://developer.mozilla.org/en-US/docs/Mozilla/Debugging/Record_and_Replay_Debugging_Firefox
https://developer.mozilla.org/en-US/docs/NSS_reference/Building_and_installing_NSS/Build_instructions
https://developer.mozilla.org/en-US/docs/Localization_prerequisites
https://wiki.mozilla.org/QA/TDAI/RegressionFinder/Windows
You need to log in before you can comment on or make changes to this bug.