Closed Bug 899796 Opened 6 years ago Closed 6 years ago

[B2G][Unagi][Dialer] Touch tones are not being recognized during calls.

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 899063

People

(Reporter: jzimbrick, Unassigned)

Details

(Keywords: regression, smoketest)

Description:
Touch tones are not being recognized during calls, making 

Repro Steps:
1. Update Unagi device to Mozilla 1.2 build 20130730030200.
2. Open the dialer app.
3. Call a number where the user is prompted to navigate via touch tone. (I used the mozilla conference line)
4. Attempt to input touch tone numbers.
5. Observe that the numbers are not recorded and the user will be unable to use any service requiring touch tones.

Actual:
Number inputs are not recognized during a call, and the user is unable to navigate services that require touch tones.

Expected:
Number inputs are recognized during calls and the user can use touch tones.

Environmental Variables
Build ID: 20130730030200
Gecko: http://hg.mozilla.org/mozilla-central/rev/3d40d270c031
Gaia: ba5ff211fbf6a930326cc6a0d4a1205a7528630b
Platform Version: 25.0a1

Notes:
Repro frequency: 100% on 4 devices.
Julien - Do you know who would be a good person to investigate this bug about touch tones not working?
Flags: needinfo?(felash)
A good place to start for QA could be to try master on b2g18 ( ;-) ) and see if this works on this (unsupported) combination. This way we'll know if this comes from gaia or gecko.

For gaia: Étienne comes back next week and will be able to help, and otherwise :sasklacz (a contributor) worked on bug 829406 and might help here too.

For gecko: Gene Lian will probably know something.
Flags: needinfo?(felash)
We don't have builds for testing b2g18 on central, so we can't do that.

Etienne is out right now, so let's first go to Gene then on gecko side to see if this is a gecko bug.

Gene - Any ideas?
Flags: needinfo?(gene.lian)
(In reply to Jason Smith [:jsmith] from comment #3)
> We don't have builds for testing b2g18 on central, so we can't do that.

You can flash a v1.1 build, and then "make production" from the gaia master repository. (or only flashing the communications app should be enough here: "APP=communications make install-gaia")
I just had a quick check on gecko.

We should have received startTone and stopTone request from gaia when I was pressing a number in call. But, we didn't receive them, and I saw the error log
[JavaScript Error: "TypeError: this.dialerMessageText is null" {file: "app://communications.gaiamobile.org/dialer/js/keypad.js" line: 317}]

We might need some gaia check here.

Testing version:
gecko - mozilla-central (hg) ba5ff211fbf6a930326cc6a0d4a1205a7528630b
gaia - master, ba5ff211fbf6a930326cc6a0d4a1205a7528630b (as reported)
Flags: needinfo?(gene.lian)
Hmm...comment 5 seems to hint that this is a Gaia bug. We've got a undefined/null value present in the Gaia dialer app.

I'll try to confirm tomorrow using the approach in comment 4, but I think the JS error already hints that this likely is an issue on the Gaia side in the Dialer app.
Yep, I see the same thing with a master/b2g18 combination, so this is definitely a gaia issue.

However I quickly checked the code and I don't get how this variable can be null.
Oh Yes I know.

The same keypad.js file is used in both index.html (the normal dialer UI) and oncall.html (the UI displayed while on call). The problem appears when we're on call, and indeed, the DOM node is absent in oncall.html.
I think this is a dupe of bug 899063.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 899063
No longer blocks: b2g-central-dogfood
You need to log in before you can comment on or make changes to this bug.