Closed Bug 899063 Opened 7 years ago Closed 7 years ago

[Dialer] Unable to input any keypad number during a call

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: gerard-majax, Assigned: gerard-majax)

References

Details

(Keywords: regression, smoketest)

Attachments

(1 obsolete file)

When in a call, we cannot anymore tap on the keypad's number. This is breaking, for example, voicemail usage.

Reproduced with gecko-18 @ 109818a and gaia master @ ea233c3 on Inari device
I'm not reproducing this one on uptodate v1-train.
Reverting bug 892880 fixes the issue. I'm investigating whether with Gecko master the issue is also present.
I can confirm that the issue is present with up to date gecko master too.
OS: Linux → Gonk (Firefox OS)
Hardware: x86_64 → ARM
FYI, logcat shows:

E/GeckoConsole( 1310): [JavaScript Error: "TypeError: this.dialerMessageText is null" {file: "app://communications.gaiamobile.org/dialer/gaia_build_defer_oncall.js" line: 86}]
Assignee: nobody → lissyx+mozillians
Clearly, either the code should ensure that this.dialerMessageText does returns something useful, or we need to add the element in the oncall.html file. I'm not sure which one is the correct fix, I'll leave it to you guys. FYI, the second one worksaround the issue for me.
Flags: needinfo?(gtorodelvalle)
Please find attached a link to Gitub pull request #11227 https://github.com/mozilla-b2g/gaia/pull/11227 that fixes the issue by checking the existence of the dialerMessageText element before using it. This fix makes more sense to me than adding a fake element inside oncall.html. From my current testing, it fixes the issue.
Attachment #782634 - Flags: review?(gtorodelvalle)
Attachment #782634 - Flags: review?(etienne)
In bug 899186, I'm proposing to review this text entirely. So maybe the fix for this is removing code. :)

I think the fix is fine, I just have one comment in the PR.
Keywords: qawanted
I have added to confirm qawanted to confirm this issue on the latest Build.

Alexandre, Also bug 892880 is koi+ and does not seem to have landed on 1.1, so why is this need on on 1.1. Confused :|
Flags: needinfo?(jhammink)
(In reply to Alexandre LISSY :gerard-majax from comment #1)
> I'm not reproducing this one on uptodate v1-train.

Setting leo+ only happens for regressions that occur in what will become v1.1 and not on master.
blocking-b2g: leo? → -
Keywords: qawanted
(In reply to bhavana bajaj [:bajaj] from comment #8)
> I have added to confirm qawanted to confirm this issue on the latest Build.
> 
> Alexandre, Also bug 892880 is koi+ and does not seem to have landed on 1.1,
> so why is this need on on 1.1. Confused :|

Because at first I thought it was on gecko-18 thus v1.1, and after I got dragged in somehting else, and forgot to switch back. My apologies :(
Depends on: 892880
Duplicate of this bug: 899796
No longer depends on: b2g-central-dogfood
Adding smoketest keyword - this is breaking daily smoke tests. Can we finish off this patch here and get this landed?
blocking-b2g: - → koi?
Keywords: smoketest
Attachment #782634 - Attachment is obsolete: true
Attachment #782634 - Flags: review?(gtorodelvalle)
Attachment #782634 - Flags: review?(etienne)
I have a patch in bug 899186 that removes the faulty code so this will get fixed when it lands.
Flags: needinfo?(jhammink)
Flags: needinfo?(gtorodelvalle)
Closing as bug 899186 landed.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
blocking-b2g: koi? → ---
Issue no longer seems to be occurring on an Unagi device running the latest 1.2 mozril build:

Environmental  Variables:
Build ID: 20130802070203
Gecko: http://hg.mozilla.org/mozilla-central/rev/c489af94ada5
Gaia: 4b347e4e39b1716b68463dccc63c1b3eb49158b3
Platform Version: 25.0a1

This issue is no longer breaking our smoketests. Removing keywords.
(In reply to J Zimbrick from comment #15)
> Issue no longer seems to be occurring on an Unagi device running the latest
> 1.2 mozril build:
> 
> Environmental  Variables:
> Build ID: 20130802070203
> Gecko: http://hg.mozilla.org/mozilla-central/rev/c489af94ada5
> Gaia: 4b347e4e39b1716b68463dccc63c1b3eb49158b3
> Platform Version: 25.0a1
> 
> This issue is no longer breaking our smoketests. Removing keywords.

That means you've verified the bug is fixed then, which mean this gets marked verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.