Closed Bug 900026 Opened 8 years ago Closed 3 years ago

crash in JS_ShutDown() after selecting profile in profile chooser (debug builds only)

Categories

(Core :: XPCOM, defect)

All
macOS
defect
Not set
critical

Tracking

()

RESOLVED WONTFIX

People

(Reporter: spohl, Assigned: Waldo)

References

Details

(Keywords: crash, regression)

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-73b60d23-9a9f-4f3e-a882-429472130731 .
 ============================================================= 

Not sure about the component for this bug.

As mentioned in the crash log submitted to Socorro, this crash occurs every time I launch Firefox Debug with '-p' from the command line to get the profile chooser dialog. I hit this crash right after I selected my profile and clicked "Start Nightly". This is reproducible with local builds as well, as long as they're non-optimized builds. This used to work up until about a week ago. I'll try and find a regression range.

It might be worth mentioning that just before Firefox crashes, I hit this assertion failure:
Assertion failure: !JSRuntime::hasLiveRuntimes() (forgot to destroy a runtime before shutting down), at /Users/Stephen/Documents/mozilla-central/js/src/jsapi.cpp:710
Segmentation fault: 11

I hear that we don't upload symbols for our debug builds. Here is a better call stack from a locally built debug build (full log attached):

Crashed Thread:  0  Dispatch queue: com.apple.main-thread

Exception Type:  EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000000

VM Regions Near 0:
--> 
    __TEXT                 0000000100000000-000000010000b000 [   44K] r-x/rwx SM=COW  /Users/USER/Documents/*/NightlyDebug.app/Contents/MacOS/firefox

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   XUL                           	0x0000000105948e77 JS_ShutDown() + 151 (jsapi.cpp:709)
1   XUL                           	0x00000001045895cc mozilla::ShutdownXPCOM(nsIServiceManager*) + 1756 (nsXPComInit.cpp:782)
2   XUL                           	0x0000000104588ee5 NS_ShutdownXPCOM + 21 (nsXPComInit.cpp:615)
3   XUL                           	0x000000010154b71b ScopedXPCOMStartup::~ScopedXPCOMStartup() + 219 (nsAppRunner.cpp:1130)
4   XUL                           	0x000000010154b635 ScopedXPCOMStartup::~ScopedXPCOMStartup() + 21 (nsAppRunner.cpp:1133)
5   XUL                           	0x0000000101556986 ShowProfileManager(nsIToolkitProfileService*, nsINativeAppSupport*) + 2726 (nsAppRunner.cpp:1955)
6   XUL                           	0x0000000101551294 SelectProfile(nsIProfileLock**, nsIToolkitProfileService*, nsINativeAppSupport*, bool*, nsACString_internal*) + 4852 (nsAppRunner.cpp:2230)
7   XUL                           	0x000000010154ed8d XREMain::XRE_mainStartup(bool*) + 1901 (nsAppRunner.cpp:3509)
8   XUL                           	0x0000000101554b89 XREMain::XRE_main(int, char**, nsXREAppData const*) + 377 (nsAppRunner.cpp:3911)
9   XUL                           	0x000000010155510f XRE_main + 63 (nsAppRunner.cpp:4128)
10  org.mozilla.nightlydebug      	0x0000000100002322 do_main(int, char**, nsIFile*) + 1634 (nsBrowserApp.cpp:275)
11  org.mozilla.nightlydebug      	0x000000010000186c main + 316 (nsBrowserApp.cpp:635)
12  org.mozilla.nightlydebug      	0x00000001000012f4 start + 52
Component: XPConnect → XPCOM
Summary: crash in XUL@0x2760a15 | XUL@0x2f05955 | XUL@0x1dbcfd0 | XUL@0x1dca040 | XUL@0x9128 | XUL@0x2cf702e | XUL@0x11b9e | libsystem_c.dylib@0x19886 → crash in JS_ShutDown() after selecting profile in profile chooser (debug builds only)
Crash Signature: [@ XUL@0x2760a15 | XUL@0x2f05955 | XUL@0x1dbcfd0 | XUL@0x1dca040 | XUL@0x9128 | XUL@0x2cf702e | XUL@0x11b9e | libsystem_c.dylib@0x19886] → [@ JS_ShutDown()]
Duplicate of this bug: 900073
(In reply to Ted Mielczarek [:ted.mielczarek] (post-vacation backlog) from comment #1)
> Probably fallout from bug 896124, see bug 896124 comment 17.

Indeed. I've confirmed this locally:

https://hg.mozilla.org/mozilla-central/rev/3bc8a3f77169 <-- Good
https://hg.mozilla.org/mozilla-central/rev/e432690bf0fb <-- Crash
Blocks: 896124
You're aware that you can use the -profile path/to/profdir commandline flag instead of the profile manager, right?
Assignee: nobody → jwalden+bmo
Yes. So this isn't blocking me. I've been using -p profileName for now. I just thought it was deserving of a bug and I should file one. :-)
This might be related to 900077
Not directly.  Bug 896124 just turns many shutdown leaks into fatal assertions.
Crash Signature: [@ JS_ShutDown()] → [@ JS_ShutDown()] [@ JS_ShutDown]

Closing because no crashes reported for 12 weeks.

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.