Real Player Embed Not controllable from JavaScript

VERIFIED DUPLICATE of bug 59935

Status

()

Core
Plug-ins
VERIFIED DUPLICATE of bug 59935
17 years ago
15 years ago

People

(Reporter: Baron Schaaf, Assigned: av (gone))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.2) Gecko/20010628
BuildID:    2001062815

The Real Player is not controllable from JavaScript.  

Functions such as DoPlay() do not work.

A simple test page is included in the Additional Information section.


Reproducible: Always
Steps to Reproduce:
1. For comparison, open the attached page (at bottom) in NS6. The Real player
should start.
2.Click on each button.  The buttons should work.
3. Now open the page in 0.9.2 Gecko. The Real player should start.
4. Click on each button. The buttons will not work.


Actual Results:  Calls to the embedded object's functions do not work.

Expected Results:  The buttons that call the embedded object's functions should
work.

<HTML>
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
"http://www.w3.org/TR/html4/loose.dtd">
<head>
<title>RA Test Document</title>
<script>
	function writeProp(theOBJ){
		var strProps='';
		for(var theProp in theOBJ){
			if (theProp!='innerHTML'){
				strProps += theProp +  ':' + theOBJ[theProp]+ '<br>\n';
			}else{
				strProps += 'INNERHTML<BR>';
			}
		}
		return strProps;
	}
	
	function showRAProps(){

		var objPlayer = document.embeds[0];
		var newWin = window.open();
		newWin.document.write(writeProp(objPlayer));
		newWin.document.close();
	}
</script>

</head>
<body bgcolor="#FFFFFF" text="#000000">
<EMBED    type="audio/x-pn-realaudio-plugin" WIDTH=220 HEIGHT=180  
CONTROLS=ImageWindow    BACKGROUNDCOLOR=white    CENTER=true  autostart=true
SRC="http://acw.activate.net/activedemo/JeffSchrock-hi.ram"  ></embed>
<br>
<button onClick="showRAProps();" value="">Show RA Embed Props</button><br>
<button onClick="alert(document.embeds[0]);">Show Embedded Object</button><br>
<hr>
<button onClick="document.embeds[0].DoPlay();">Play</button><br>
<button onClick="document.embeds[0].DoStop();">Stop</button><br>
<button onClick="document.embeds[0].AboutBox();">About</button><br>
<script>
document.write(navigator.userAgent + '<br>');
</script>
</body>
</html>
(Assignee)

Comment 1

17 years ago
reporter: what does about:plugins say about RealPlayer regarding the location of 
the dll?
Duplicate of "Javascript function calls to plugin do not work (in Real Player)"

*** This bug has been marked as a duplicate of 59935 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

15 years ago
mass duplicate verifications . For filtering purposes, pls use keywd
"massdupverification"

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.