Closed Bug 900635 Opened 7 years ago Closed 3 years ago

Unchecking "Create shortcut on my taskbar" in stub installer still pins Firefox when also set as default browser

Categories

(Firefox :: Installer, defect, P2)

All
Windows 7
defect

Tracking

()

RESOLVED DUPLICATE of bug 1229626

People

(Reporter: ws.bugzilla, Unassigned)

References

()

Details

(Whiteboard: [stubv3=])

The new installer has the option named [Create Shortcuts for Firefox] "On my Task bar".

Even with the option un-checked, Firefox still pins itself to the taskbar.
I have re-installed Firefox x86_64 Windows edition (version 27.0.1). I see no problem with the pin "On my Task Bar" checkbox. I installed it with the option checked and again with the option unchecked. The expected outcomes were the actual outcomes. In conclusion, I believe that the bug (if there was one) from the version 22 installer is no long in the current version 27 installer.
The bug is still there: http://screencast.com/t/n7PMRxTjc9CC
Hardware: x86_64 → All
Version: 22 Branch → Trunk
Summary: "On my taskbar" has no effect → 'On my taskbar' has no effect when installing with the stub installer and setting as the default browser
Whiteboard: [stubv2=]
Assignee: nobody → robert.strong.bugs
Status: NEW → ASSIGNED
Whiteboard: [stubv2=] → [stubv3=]
It's unlikely that I will get to work on this in the next two weeks, so unassigning myself for now.
Assignee: robert.strong.bugs → nobody
Duplicate of this bug: 1165692
Status: ASSIGNED → NEW
See Also: → 1229626, 1190351
What does this bug actually cover? Is it just investigating why this sometimes doesn't happen? Bug 1229626 fixed a different case, so presumably pinning works in general, so I'm not sure if this but is actually now WORKSFORME or covers something else.
Flags: needinfo?(robert.strong.bugs)
We add pinning when setting as default. In the stub UI when choosing options we have a checkbox that when unchecked should not pin. When setting as default it is always pinned even when unchecking.
Flags: needinfo?(robert.strong.bugs)
Ah, I see. Attempting to clarify title.
Summary: 'On my taskbar' has no effect when installing with the stub installer and setting as the default browser → Unchecking "Create shortcut on my taskbar" in stub installer still pins Firefox when also set as default browser
Roman, could you check if this is still an issue with a Nightly build now that bug 1229626 has been fixed? Thanks!
Flags: needinfo?(ws.bugzilla)
Cory -- can anyone reproduce this in any of the onboarding or QX work? I'm not sure if the reporter is still attentive to this after 4 years.
Flags: needinfo?(cprice)
I'm closing this as a dup per comment 8. Feel free to re-open with STR if the issue still exists.
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(ws.bugzilla)
Flags: needinfo?(cprice)
Resolution: --- → DUPLICATE
Duplicate of bug: 1229626
You need to log in before you can comment on or make changes to this bug.