Closed Bug 900660 Opened 6 years ago Closed 6 years ago

enable tab audio notifiers

Categories

(Firefox :: Tabbed Browser, defect, major)

25 Branch
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 486262

People

(Reporter: asmodeusme, Unassigned)

Details

(Keywords: ux-userfeedback, Whiteboard: parity chrome)

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:25.0) Gecko/20130801 Firefox/25.0 (Nightly/Aurora)
Build ID: 20130801030223

Steps to reproduce:

enable tab audio notifiers in all versions
I look forward to when it is included as I have a problem with a mysterious voice that starts up when I have about 10 tabs open.


Actual results:

add audio indicators to tabs so that users would know immediately where audio was coming from that is playing in the browser. This can be especially useful on start if you restore a previous session with dozens of tabs. One or some may load videos, ads with sound or other audio contents and start playing them right away, and it is a great help to quickly uncover where that audio is coming from to turn it off.


Expected results:

Sometimes it is difficult to tell where audio playback is coming from in a browser. This is especially true in situations where you have dozens of tabs open already, or opened a bunch of websites at the same time in your browser of choice. I sometimes open ten or twenty websites in new tabs at the same time in Firefox using the excellent Multi Links add-on, and it can happen that audio starts playing as a consequence because at least one of the websites is running media contents or multimedia advertisement on its pages.

This is especially disturbing if I'm already listening to music or watching a video on the PC. The only two options available at this point in time is to either mute the web browser if you are using an operating system that allows you to do so, or flip through all tabs quickly to try and locate the tab or tabs that play the audio.

The indicator is animated so that it should not be a problem to locate the tab responsible for playing audio in the browser
Severity: normal → major
Keywords: ux-userfeedback
OS: Windows NT → All
Priority: -- → P1
Hardware: x86_64 → All
Whiteboard: parity chrome
Component: Untriaged → Tabbed Browser
Blocks: australis
No longer blocks: australis-tabs-win, australis
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 486262
You need to log in before you can comment on or make changes to this bug.