Closed Bug 900741 Opened 7 years ago Closed 7 years ago

[B2G] [Unagi] [System] Audio does not play through headphones until the volume is adjusted

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:koi+)

VERIFIED DUPLICATE of bug 895822
blocking-b2g koi+

People

(Reporter: ckreinbring, Assigned: jwwang)

Details

(Keywords: regression)

Attachments

(1 file)

Description:
When headphones are plugged in, audio will still play through the device until the volume is adjusted.  Then the audio will play through the headphones.

Repro Steps:
1) Update Unagi to Build ID: 20130801030224
2) Plug in headphones then play some audio (music, YouTube video, etc).
3) Observe where the audio plays from.
4) Adjust the volume then observe where the audio plays from.

Actual:
Audio plays through the device when headphones are plugged in until the volume is adjusted.

Expected:
When the headphones are plugged in, audio starts playing through them with no adjustments needed.

Environmental Variables
Build ID: 20130801030224
Gecko: http://hg.mozilla.org/mozilla-central/rev/05d3797276d3
Gaia: c1620a242c937c7fcb171b88c85ef63561165081
Platform Version: 25.0a1

Notes:
Repro frequency: 100%
See attached logcat logs
blocking-b2g: --- → koi?
blocking-b2g: koi? → koi+
Keywords: regression
Hema, is your team the right one to take a look at this?
Flags: needinfo?(hkoka)
No longer blocks: b2g-central-dogfood
Keywords: smoketest
Adding CJ
Flags: needinfo?(cku)
Flags: needinfo?(hkoka)
Assignee: nobody → jwwang
Flags: needinfo?(cku)
Assign to JW and loop in Marco/ Randy for consult
This bug patch can be solved by this bug's patch
https://bugzilla.mozilla.org/show_bug.cgi?id=895822
But the volume setting still keep in low at first boot-up.
Another issue?
Fire a new Bug 904531 for what Randy mentioned on Comment 4 and set this is a duplicate with bug 895822.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 895822
Verifying as duplicate due to being unable to repro on the Buri 1.2 mozilla RIL.  Audio plays through the headphones immediately after plugging them in.

Build ID: 20130904040205
Gecko: http://hg.mozilla.org/mozilla-central/rev/7ff96bd19c1c
Gaia: b6c5bf1d24230bfed4a8f680e625fa2175001f82
Platform Version: 26.0a1
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.