[Firefox] [PDF Viewer] Firefox can't handle write-protected PDF files correctly

VERIFIED FIXED in Firefox 27

Status

()

P3
normal
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: rdaub, Assigned: yury)

Tracking

22 Branch
Firefox 28
Points:
---

Firefox Tracking Flags

(firefox27 verified, firefox28 verified)

Details

(Whiteboard: [pdfjs-c-rendering][pdfjs-f-fixed-upstream]https://github.com/mozilla/pdf.js/pull/3931)

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
This is reported by a user in the SUMO forums:
https://support.mozilla.org/pt-BR/questions/966691

STEPS TO REPLICATE:
Open a PDF which has an Owner password, but the User password is left blank. This should give the user permission to View and Print the PDF.

EXPECTED BEHAVIOR:
According to the user, the file should open automatically for Viewing and/or Printing, without being prompted for a password.

ACTUAL BEHAVIOR:
When using Firefox, the user is prompted for a password when opening this file.

If the user changes the internal PDF viewer to the Adobe plugin it works perfectly (as it does in Chrome, Safari, Opera and IE)

I am requesting a copy of the password-protected PDF to help investigate the issue.

Please let me know if there are any questions, or if there is anything else that I should ask the user.

Thanks!!

- Ralph

Comment 1

5 years ago
Could you attach such a PDF, please.
Flags: needinfo?(rdaub)

Comment 2

5 years ago
Created attachment 785099 [details]
PDF with print only permission, user pw blank. Shouldn't ask for pasword to show.

This is a test pdf I've made generated by my app that works correctly with Adobe Acrobat and the other browsers.
Flags: needinfo?(rdaub)
Priority: -- → P2
Hardware: x86_64 → All
Whiteboard: [pdfjs-c-ux]

Comment 3

5 years ago
When is this bug going to be fixed? I see it was reported early August this year. It has been over 3 months with no update. I work for a software company and all of our clients are having this same issue. Therefore they are directed to use other browsers. That can't be good for business.

Comment 4

5 years ago
Ahhh... seems that I'm not alone in my quest. <g> I've directed all my clients to other browsers. I can't wait for one or two years for something like this to be fixed as I see this as a reasonable show stopper for business. But then, that only my opinion. If I knew how to fix it, I already would have done the necessary fixing...

Comment 5

5 years ago
I'm having the same problem. I'm using mozilla's pdf.js viewer for my mobile application in Sencha to show my pdf which has the same permissions as mentioned above. But I get nothing (blank page) ,the pdf comes to my application encrypted even thought user permissions are allowed. What's happened with this bug ? Any idea to jump the password check for user only ?
(Assignee)

Comment 6

5 years ago
Andrew, thank you for the test. (The fix for your issue can be found at https://github.com/mozilla/pdf.js/pull/3931 and will land soon to the m-c)
Priority: P2 → P3
Whiteboard: [pdfjs-c-ux] → [pdfjs-c-rendering] https://github.com/mozilla/pdf.js/pull/3931
Whiteboard: [pdfjs-c-rendering] https://github.com/mozilla/pdf.js/pull/3931 → [pdfjs-c-rendering][pdfjs-f-fixed-upstream]https://github.com/mozilla/pdf.js/pull/3931

Comment 7

5 years ago
Hi - I'm having the same problems - you say you have a fix in Comment 6 but will that be rolled out to Firefox as an update any time soon - or is it a fix that needs to be made to the code that we write to create our pdf's? I have a multitude of customers complaining about this!
(Assignee)

Comment 8

5 years ago
(In reply to Steve from comment #7)
> Hi - I'm having the same problems - you say you have a fix in Comment 6 but
> will that be rolled out to Firefox as an update any time soon - or is it a
> fix that needs to be made to the code that we write to create our pdf's? I
> have a multitude of customers complaining about this!

We have plans to land it in Firefox 28. The issues is connected with "ReportBuilder" (?) assigning really long file id. If you 100% sure that you have the same issue, then fix for your customers will be available in about 15 weeks. (If we have more information about how much people is affected by this issue, it's possible to uplift that to Firefox 27)

(As a workaround, the software that generates PDFs can be modified to assign shorter/typical-to-normal-PDF file ID)

Comment 9

5 years ago
To confirm that this is EXACTLY the same issue can I email you a copy of a PDF?

(In reply to Yury Delendik (:yury) from comment #8)
> (In reply to Steve from comment #7)
> > Hi - I'm having the same problems - you say you have a fix in Comment 6 but
> > will that be rolled out to Firefox as an update any time soon - or is it a
> > fix that needs to be made to the code that we write to create our pdf's? I
> > have a multitude of customers complaining about this!
> 
> We have plans to land it in Firefox 28. The issues is connected with
> "ReportBuilder" (?) assigning really long file id. If you 100% sure that you
> have the same issue, then fix for your customers will be available in about
> 15 weeks. (If we have more information about how much people is affected by
> this issue, it's possible to uplift that to Firefox 27)
> 
> (As a workaround, the software that generates PDFs can be modified to assign
> shorter/typical-to-normal-PDF file ID)
(Assignee)

Comment 10

5 years ago
(In reply to Steve from comment #9)
> To confirm that this is EXACTLY the same issue can I email you a copy of a
> PDF?
> 

Yes. You can e-mail your file to Brendan Dahl or myself.
(Assignee)

Comment 11

5 years ago
(In reply to Yury Delendik (:yury) from comment #10)
> (In reply to Steve from comment #9)
> > To confirm that this is EXACTLY the same issue can I email you a copy of a
> > PDF?
> > 
> 
> Yes. You can e-mail your file to Brendan Dahl or myself.

Will be fixed by https://github.com/mozilla/pdf.js/pull/3951
(Reporter)

Comment 12

5 years ago
Thanks so much, Brendan and Yury, for following up and finding a solution to this bug, and thanks Andrew for the testing! 

It's really awesome to see different teams and contributors working together to improve Firefox. =)

- Ralph
(Assignee)

Comment 13

5 years ago
Created attachment 8355682 [details] [diff] [review]
Uplift pdf.js patches 3931 and 3951 for FF27

See https://github.com/mozilla/pdf.js/pull/3931 and https://github.com/mozilla/pdf.js/pull/3951
Attachment #8355682 - Flags: review?(bdahl)
(Assignee)

Updated

5 years ago
Depends on: 947260
OS: Windows 7 → All
Attachment #8355682 - Flags: review?(bdahl) → review+
(Assignee)

Comment 14

5 years ago
Comment on attachment 8355682 [details] [diff] [review]
Uplift pdf.js patches 3931 and 3951 for FF27

[Approval Request Comment]
Bug caused by (feature/regressing bug #): n/a 
User impact if declined: some PDFs protected by password cannot be opened by PDF Viewer. One of the users claims that his company handles about 250 support calls monthly to provide workaround to bypass the internal viewer.
Testing completed (on m-c, etc.): the fix is present in Firefox 28 and 29
Risk to taking this patch (and alternatives if risky): low, affects only PDF Viewer and only PDF files protected by a password
String or IDL/UUID changes made by this patch: no
Attachment #8355682 - Flags: approval-mozilla-beta?
(Assignee)

Updated

5 years ago
Assignee: nobody → ydelendik
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 28
Comment on attachment 8355682 [details] [diff] [review]
Uplift pdf.js patches 3931 and 3951 for FF27

low risk patch helping with password protected PDF's which many users are running into per bug comments
Attachment #8355682 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
Whiteboard: [pdfjs-c-rendering][pdfjs-f-fixed-upstream]https://github.com/mozilla/pdf.js/pull/3931 → checkin needed for FF27 uplift patch [pdfjs-c-rendering][pdfjs-f-fixed-upstream]https://github.com/mozilla/pdf.js/pull/3931
https://hg.mozilla.org/releases/mozilla-beta/rev/4f51977e2f71
status-firefox27: --- → fixed
status-firefox28: --- → fixed
Keywords: checkin-needed
Whiteboard: checkin needed for FF27 uplift patch [pdfjs-c-rendering][pdfjs-f-fixed-upstream]https://github.com/mozilla/pdf.js/pull/3931 → [pdfjs-c-rendering][pdfjs-f-fixed-upstream]https://github.com/mozilla/pdf.js/pull/3931

Comment 17

5 years ago
Verified as fixed with Firefox 27 beta 4 on Windows 7 x64bit, Mac OS X 10.9, Ubuntu 13.04 32bit.
status-firefox27: fixed → verified
Ioana, please also verify this in Aurora 28.
Keywords: verifyme

Comment 19

5 years ago
Verified as fixed on Windows XP 32bit, Mac OS X 10.8 and Ubuntu 13.04 32bit with the 01/16 Firefox 28.0a2.
Status: RESOLVED → VERIFIED
status-firefox28: fixed → verified
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.