Closed Bug 947260 Opened 6 years ago Closed 6 years ago

Update pdf.js to version 0.8.759

Categories

(Firefox :: PDF Viewer, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 28

People

(Reporter: RyanVM, Assigned: RyanVM)

References

Details

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #937670 +++

Changes since the last update:
#3864 Make 'zoom' independent from 'page' in the hash parameters
#3913 Reduce the memory usage of the operator list.
#3887 Fixing glyphs with invalid flags
#3848 Don't traverse all pages to get a single page.
#3917 Fixes gidStart for CID fonts
#3920 Use page promise for text extraction.
#3916 Remove slow commands check.
#3904 Reduces amount of memory allocated during worker operations
#3929 Fixed Typo
#3922 Open Find bar instead of toggling it on Ctrl + F
#3911 Cleaning up fonts when viewer is idle for some time
#3931 Allocates bigger hashData buffer
#3927 Prevent updating the current transformation matrix when the stateStack is empty
#3850 Implement default preferences
#3939 Fix error in 'PdfStreamConverter.js' that prevents the user from setting a boolean preference to false
#3938 Update docs on the workerSrc setting.
#3943 Fixes cleaning up of the rendered pages
#3936 Leave initial request open until the viewer is ready to switch to range requests.
#3951 Limits U and O entries size
#3934 [PDFHistory] Fix "Warning: Unhandled rejection: [Exception... "The operation is insecure."" when opening local file
#3952 [CRX] Reload extension tab after session restore
#3940 Combine if/else block with switch for getOperatorList.
#3957 Add BOM to viewer.
#3961 [PDFHistory] Fix "Warning: Unhandled rejection: [Exception... "The operation is insecure."" in Firefox 25
#3955 Fix issues with /FitR destinations
#3964 Fixes chunks grouping
#3968 Fixes find position in HiDPI displays
#3954 Index objects if Prev xref was not found
#3970 Fix page rotation for unloaded pages.
#3971 Fix rotation regression from #3970.
#3976 Append entire DOM fragment at once.
#3972 Fix printing regression from #3848.
#3980 Remove </input> tag
#3978 Wait for one page to render before fetching all pages.
#3941 Begin searching from current page
#3996 Fix Blob creation in Safari 7.0
Assignee: nobody → ryanvm
Status: NEW → ASSIGNED
Attachment #8343767 - Flags: review?(bdahl)
Comment on attachment 8343767 [details] [diff] [review]
Update pdf.js to version 0.8.759

Review of attachment 8343767 [details] [diff] [review]:
-----------------------------------------------------------------

Filed follow up bug based on Mosssop's comments https://github.com/mozilla/pdf.js/issues/4005.
Attachment #8343767 - Flags: review?(bdahl) → review+
https://hg.mozilla.org/mozilla-central/rev/b86e8f77fa96
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 28
Is it possible to uplift to Firefox27beta?
This will fix Bug 901288.
Flags: needinfo?(ryanvm)
Blocks: 901288
Usually spot fixes are uplifted to aurora/beta.
Flags: needinfo?(ryanvm)
Blocks: 900822
Marking with verifyme for QA to do some exploratory on the PDF Viewer(check for regressions).
Keywords: verifyme
Alexandra, might this be a good candidate for a future test day given the scope of the manual/exploratory testing? :)
Flags: needinfo?(alexandra.lucinet)
(In reply to Liz Henry :lizzard from comment #8)
> Alexandra, might this be a good candidate for a future test day given the
> scope of the manual/exploratory testing? :)

Yes, Liz, it is an excellent candidate; It has been added in the next Testday event, February 27th. Thanks for the heads up! :)
Flags: needinfo?(alexandra.lucinet)
An exploratory testing was performed on the PDF Viewer due to the latest changes.
The environment used for testing was:

Firefox 28.0b9
Build Id: 20140306171728
OS: Ubuntu 13.10 x86, Mac Os x 10.9, Win 7 x 64

The PDF Viewer was also tested on the Testday event from February 27th by contributors.
No new issues were found by our exploratory testing and by the contributors during the testday.
Status: RESOLVED → VERIFIED
Keywords: verifyme
Depends on: 1108922
You need to log in before you can comment on or make changes to this bug.