If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Buri][CALL][Music]The ringtone and music will be reproduce at the same time when playing music and receiving a call

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Dialer
P2
normal
RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: sync-1, Unassigned)

Tracking

(Blocks: 1 bug)

unspecified

Firefox Tracking Flags

(b2g-v2.0 unaffected, b2g-v2.2 unaffected)

Details

(Reporter)

Description

4 years ago
AU_LINUX_GECKO_ICS_STRAWBERRY.01.01.00.019.171
 Firefox os  v1.1
 Mozilla build ID:20130722070207
 
 DEFECT DESCRIPTION:
 The ringtone will respond music for a moment when received a call
 
 REPRODUCING PROCEDURES:
 1.Launch Music app -> select a song to play
 2.Receive an incoming call -> the incoming interface displayed, but the song still ringing for a moment -> KO
 
 EXPECTED BEHAVIOUR:
 The incoming interface and ringtone should has synchronization
 
 ASSOCIATE SPECIFICATION:
 
 TEST PLAN REFERENCE:
 
 TOOLS AND PLATFORMS USED:
 
 USER IMPACT:mid
 
 REPRODUCING RATE:5/5
 
 For FT PR, Please list reference mobile's behavior:
This issue had been reported during certification in 1.3.

We had retested it with Flame in master Gecko-2fbbb04 and Gaia-59bd661, the issue is still there.

Playing a song at Music app, receive an incoming, you can hear both sounds at the same time for a moment... 

The expected behaviour: 
 mp3 file reproduction is paused while the call establishement, so user will not hear both sound at the same time.
Summary: [Buri][CALL][Music]The ringtone will respond music for a moment when received a call → [Buri][CALL][Music]The ringtone and music will be reproduce at the same time when playing music and receiving a call
Duplicate of this bug: 1020263
Putting this in our most-wanted if it's a certification issue.
Blocks: 1036516

Comment 4

3 years ago
I have re-tested it and working fine. 

The song at Music app is stopped when receiving a incoming call and it will continue playing when the call will be finished. Ringtone and music are reproduced separated, not at the same time.

I have used a flame master (Gecko 5a802aa Gaia 0a91952) and flame 2.0 (Gecko 8d0a186 Gaia 8d7f2ac)
Great!! resolving the bug with Worksforme
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
status-b2g-v2.0: --- → unaffected
status-b2g-v2.2: --- → unaffected
You need to log in before you can comment on or make changes to this bug.