uncaught exception in mailCommands.js when creating folders that already exist

RESOLVED DUPLICATE of bug 88775

Status

SeaMonkey
MailNews: Message Display
RESOLVED DUPLICATE of bug 88775
17 years ago
10 years ago

People

(Reporter: Henrik Gemal, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
If you try to create a folder called Trash in Local Folders you get:

Error: uncaught exception: [Exception... "Component returned failure code:
0x80550013 [nsIRDFCompositeDataSource.DoCommand]"  nsresult: "0x80550013
(<unknown>)"  location: "JS frame :: chrome://messenger/content/mailCommands.js
:: DoRDFCommand :: line 50"  data: no]

build 20010708
(Reporter)

Comment 1

16 years ago
Line numbers has changed a bit. But I'm still getting the exception.

Error: uncaught exception: [Exception... "Component returned failure code:
0x80550013 [nsIRDFCompositeDataSource.DoCommand]"  nsresult: "0x80550013
(<unknown>)"  location: "JS frame :: chrome://messenger/content/mailCommands.js
:: DoRDFCommand :: line 27"  data: no]

20020117
Product: Browser → Seamonkey

Updated

13 years ago
Assignee: sspitzer → mail
[Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.1a2) Gecko/20060524 SeaMonkey/1.1a] (nightly) (W98SE)

{{
Error: [Exception... "Component returned failure code: 0x80550013 [nsIRDFCompositeDataSource.DoCommand]"  nsresult: "0x80550013 (<unknown>)"  location: "JS frame :: chrome://messenger/content/mailCommands.js :: DoRDFCommand :: line 51"  data: no]
Source File: chrome://messenger/content/mailCommands.js
Line: 51
}}

I first get an alert dialog which says that the name is already used.
The exception happens when I click on its OK button.

(Except from the exception, the UI seems to behave as expected.)
OS: Windows 2000 → All
QA Contact: esther
Hardware: PC → All
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9pre) Gecko/2008052007 SeaMonkey/2.0a1pre] (SEA-WIN32-TBOX-trunk) (W2Ksp4)

Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 88775
You need to log in before you can comment on or make changes to this bug.