Closed Bug 901454 Opened 6 years ago Closed 6 years ago

The deck added in bug 895543 causes the source editor to not scroll properly

Categories

(DevTools :: Debugger, defect)

defect
Not set

Tracking

(firefox25 verified, firefox26 verified)

VERIFIED FIXED
Firefox 26
Tracking Status
firefox25 --- verified
firefox26 --- verified

People

(Reporter: vporof, Assigned: vporof)

References

Details

Attachments

(1 file)

STR:

1. Go to http://htmlpad.org/debugger/
2. Open debugger
3. Make sure the toolbox height is rather small (< 300px)
4. Try to scroll the source editor to line 120

Source editor can't scroll.
Blocks: 899877
Decks are the best thing ever.

Apart from the fix, I also made the padding take the actual toolbox height into consideration. I think this makes more sense, since not everybody keeps their toolbox at the same size.
Assignee: nobody → vporof
Status: NEW → ASSIGNED
Attachment #785683 - Flags: review?(nfitzgerald)
Attachment #785683 - Flags: review?(nfitzgerald) → review+
Whiteboard: [land-in-fx-team]
Blocks: 901296
https://hg.mozilla.org/integration/fx-team/rev/b45873908380
Whiteboard: [land-in-fx-team] → [fixed-in-fx-team]
Comment on attachment 785683 [details] [diff] [review]
dbg-blackbox-scroll.patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 895543
User impact if declined: Source editor can't scroll in the debugger :(
Testing completed (on m-c, etc.): locally, fx-team
Risk to taking this patch (and alternatives if risky): None, css only changes
String or IDL/UUID changes made by this patch: None
Attachment #785683 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/b45873908380
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 26
Attachment #785683 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Mozilla/5.0 (Windows NT 6.1; rv:25.0) Gecko/20100101 Firefox/25.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:25.0) Gecko/20100101 Firefox/25.0
Mozilla/5.0 (X11; Linux i686; rv:25.0) Gecko/20100101 Firefox/25.0

Reproduced this issue with Nightly 25.0a1 (2013-08-05).
Verified as fixed with Firefox 25 beta 2 (Build ID: 20130923194050).
Verified as fixed on the latest Aurora 26.0a2.
Verified on Ubuntu 13.04, Mac OS X 10.8 and Windows 7:
Mozilla/5.0 (X11; Linux i686; rv:26.0) Gecko/20100101 Firefox/26.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:26.0) Gecko/20100101 
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
Build ID: 20131003004003
Status: RESOLVED → VERIFIED
Keywords: verifyme
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.