Inconsistent spelling of "add-ons" in about:addons override for Metro, improve l10n structure of sentence

RESOLVED FIXED in Firefox 26

Status

Firefox for Metro
Browser
P1
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: flod, Assigned: ally)

Tracking

unspecified
Firefox 26
x86_64
Windows 8

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Changeset: http://hg.mozilla.org/mozilla-central/diff/b5abcd08bf67/browser/metro/locales/en-US/chrome/aboutAddons.dtd

aboutAddons.title "Addons are a Work In Progress"
aboutAddons.message "Sorry, &brandShortName; is busy working on supporting Add-ons for you!"

The common spelling in Mozilla products is "add-on". Note that you can just fix your string without changing the entity name.
It seems like these lines might also be a problem in some locales:

    1.16 +<!ENTITY aboutAddons.goBackToStart      "Go back to the ">
    1.17 +<!ENTITY aboutAddons.startPageLinkTitle "&brandShortName; Start Page.">

Should we split this string into three parts instead of two (before-link, link, after-link)?
Matt, you're absolutely right. I focused on the spelling and missed the other problem.

Personally I would go with something like this

<!ENTITY aboutAddons.goBackToStartStart "Go back to the ">
<!ENTITY aboutAddons.goBackToStartLink  "&brandShortName; Start Page">
<!ENTITY aboutAddons.goBackToStartEnd   ".">
Summary: Inconsistent spelling of "add-ons" in about:addons override for Metro → Inconsistent spelling of "add-ons" in about:addons override for Metro, improve l10n structure of sentence
(Assignee)

Comment 3

5 years ago
:flod, do we have a document somewhere about consistent spelling/nomenclature/sentence structure of things for l10n? 

It'd be really really handy to have that for when the designers do their mocks so we could get this kind of thing right one the first commit. (I copied the strings off the mock verbatim, assuming that the designer had taken care of l10n ux consistency)


p=1 for Marco. I didn't like having the period in the link anyway.
(Assignee)

Updated

5 years ago
Assignee: nobody → ally
The Mozilla Style Guide includes standards for copy, e.g.:
https://www.mozilla.org/en-US/styleguide/communications/copy-rules/
The spelling thing is not really l10n, it's more en-US copy, and it's something I usually notice because I have to translate all strings, and I have to pay attention to be consistent in my own locale with the same terms (the problem is usually with hyphens, like add-on, plugin, pop-up, etc.).

About l10n guidelines we don't have any complete documents, but usually it's enough to pay attention to plural form and sentences composed by multiple strings.
(Assignee)

Comment 6

5 years ago
wish it would mark as assigned when one clicks 'take', but such are bugzilla papercuts.
Status: NEW → ASSIGNED
(Assignee)

Comment 7

5 years ago
Created attachment 786060 [details] [diff] [review]
string fixin'

also removed the second '!' at yuan's request.

this should make everyone happier.
Attachment #786060 - Flags: review?(mbrubeck)
Comment on attachment 786060 [details] [diff] [review]
string fixin'

This could also use a brief LOCALIZATION NOTE explaining how the three parts form a sentence.
Attachment #786060 - Flags: review?(mbrubeck) → review+
Comment on attachment 786060 [details] [diff] [review]
string fixin'

Review of attachment 786060 [details] [diff] [review]:
-----------------------------------------------------------------

(In reply to Matt Brubeck (:mbrubeck) from comment #8)
> This could also use a brief LOCALIZATION NOTE explaining how the three parts
> form a sentence.

Yes please :-) And use this format so that tools can associate them with the right strings.

# LOCALIZATION NOTE (aboutAddons.goBackToStartStart,
# aboutAddons.goBacktoStartLink, aboutAddons.goBacktoStartEnd):


Another note:

-<!ENTITY aboutAddons.title "Addons are a Work In Progress">
+<!ENTITY aboutAddons.title "&brandShortName; Add-ons are a Work In Progress">

This should ok now (but I think we agreed to treat Metro as the other products lately), but it won't be acceptable once the localization of Metro is enabled on mozilla-central. If you're fixing a typo (e.g. "add-on" vs "addon") it's fine, if you're changing the string like this, adding an entity, you need to change the ID of the string.

https://developer.mozilla.org/en-US/docs/Making_String_Changes
Attachment #786060 - Flags: feedback-
(Assignee)

Comment 10

5 years ago
(In reply to Francesco Lodolo [:flod] from comment #9)
> Comment on attachment 786060 [details] [diff] [review]
> string fixin'
> 
> Review of attachment 786060 [details] [diff] [review]:
> -----------------------------------------------------------------
> Another note:
> 
> -<!ENTITY aboutAddons.title "Addons are a Work In Progress">
> +<!ENTITY aboutAddons.title "&brandShortName; Add-ons are a Work In
> Progress">
> 
> This should ok now (but I think we agreed to treat Metro as the other
> products lately), but it won't be acceptable once the localization of Metro
> is enabled on mozilla-central. If you're fixing a typo (e.g. "add-on" vs
> "addon") it's fine, if you're changing the string like this, adding an
> entity, you need to change the ID of the string.
> 
> https://developer.mozilla.org/en-US/docs/Making_String_Changes

Yes, I am taking full advantage of the fact that we are not localized at this time and we haven't declared a string freeze yet. We've talked about doing that on irc, but we haven't established a date sooner than the aurora uplift.

Once we string freeze, normal rules apply. Don't worry, it's not my first time at the l10n rodeo. :)
https://hg.mozilla.org/mozilla-central/rev/601a721f5f40
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 26
You need to log in before you can comment on or make changes to this bug.