changing the requestee of a pending needinfo flag should redirect the request rather than clearing it

RESOLVED FIXED

Status

()

bugzilla.mozilla.org
Extensions: Needinfo
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: Gavin, Assigned: glob)

Tracking

Production

Details

Attachments

(1 attachment)

STR:
1) Get a needinfo request on a bug
2) open show_bug.cgi, determine that someone else should handle that request
3) in the "flags" section, remove your account name from the requestee list and replace it with someone else's
4) Submit

Expected: needinfo request redirected
Actual: needinfo request cleared (I am assuming this is because the "clear my needinfo request" checkbox was also checked - it is checked by default)

I suppose an alternative solution would be to only have the "clear my needinfo" checkbox checked if you actually enter text in the comment box, but that wouldn't handle the case where you comment and also change the needinfo requestee.
(Assignee)

Updated

4 years ago
Duplicate of this bug: 956406
(Assignee)

Updated

4 years ago
Assignee: nobody → glob
(Assignee)

Comment 2

4 years ago
Created attachment 8385165 [details] [diff] [review]
901599_1.patch

this approach uses javascript to uncheck the "clear needinfo request" checkbox if the requestee is changed.
Attachment #8385165 - Flags: review?(dkl)
Comment on attachment 8385165 [details] [diff] [review]
901599_1.patch

Review of attachment 8385165 [details] [diff] [review]:
-----------------------------------------------------------------

Nice. r=dkl
Attachment #8385165 - Flags: review?(dkl) → review+
(Assignee)

Comment 4

4 years ago
To ssh://gitolite3@git.mozilla.org/webtools/bmo/bugzilla.git
   013e874..c2e0716  4.2 -> 4.2
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.