Closed Bug 902421 Opened 7 years ago Closed 7 years ago

|tools srcdir| breaks Firefox startup

Categories

(DevTools :: Framework, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 27

People

(Reporter: msucan, Assigned: jryans)

Details

(Keywords: regression)

Attachments

(1 file)

I just pulled from fx-team and did a build. On startup none of my previous session tabs load, no toolbars are shown, no devtools, almost nothing is loaded. The terminal shows:

JavaScript error: resource://gre/modules/devtools/Loader.jsm, line 76: NS_ERROR_FILE_UNRECOGNIZED_PATH: Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsILocalFile.initWithPath]

I had to manually clear the devtools.loader.srcdir pref to bring Firefox back to life.

Yesterday this command worked well enough - it seems to be a very recent regression. Do we have tests for this command?
Assignee: nobody → jryans
Status: NEW → ASSIGNED
OS: Linux → All
Hardware: x86_64 → All
Several people have added various paths to the loader without adding an equivalent path to the srcdir version.

I'd love to have a test here, but I am not sure what it would do...  This issue only comes up new files are loaded, so they would not be part of some test, unless the test is trying to require files all over the place, which sounds a bit crazy.
Attachment #807966 - Flags: review?(dcamp)
Comment on attachment 807966 [details] [diff] [review]
Add correct paths to the SrcdirProvider

Review of attachment 807966 [details] [diff] [review]:
-----------------------------------------------------------------

Yeah, testing this is hard.
Attachment #807966 - Flags: review?(dcamp) → review+
https://hg.mozilla.org/integration/fx-team/rev/4ef38d3cfbe2
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
This is not resolved fixed yet. (until it merges to m-c)
Status: RESOLVED → UNCONFIRMED
Ever confirmed: false
Resolution: FIXED → ---
Whiteboard: [fixed-in-fx-team]
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
https://hg.mozilla.org/mozilla-central/rev/4ef38d3cfbe2
Status: ASSIGNED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 27
Do we have a bug about adding tests for this stuff? We should make sure such regressions do not happen too often. Thanks!
Just ran into conflicts from this when uplifting bug 925199 to Aurora. Should we consider landing this there as well?
AFAIK, the srcdir feature is only used by Dev Tools contributors, and even then only sometimes, as it has some limitations with what changes will be picked up.  Since it is merely a convenience for faster loading when hacking on the tools locally, I don't think it's necessary to pull this up to Aurora.
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.