Closed Bug 902546 Opened 8 years ago Closed 8 years ago

IFrame contents rendering outside iframe boundaries (related to positioning: absolute?)

Categories

(Core :: Layout, defect)

23 Branch
defect
Not set
normal

Tracking

()

VERIFIED WORKSFORME
Tracking Status
firefox23 - affected
firefox24 + verified
firefox25 + verified
firefox26 + verified

People

(Reporter: Gijs, Assigned: roc)

References

()

Details

(Keywords: regression, testcase, verifyme)

Attachments

(2 files)

Reported over IRC, broken in OS X and Windows, Fx 23 as well as Nightly. Test page:

http://www.phpgangsta.de/download/ff23iframe.html

This can probably be narrowed down (as testcases go) but I don't have time to do that right now...
(In reply to :Gijs Kruitbosch (PTO Aug 8-Aug 18) from comment #1)
> Reported over IRC, broken in OS X and Windows, Fx 23 as well as Nightly.
> Test page:
> 
> http://www.phpgangsta.de/download/ff23iframe.html
> 
> This can probably be narrowed down (as testcases go) but I don't have time
> to do that right now...

Note that toggling position: absolute off on the #subSurfacePanel div from the web inspector allows the content to be properly constrained to the iframe.
Summary: Rendering problem with iframe and positioning: absolute → IFrame contents rendering outside iframe boundaries (related to positioning: absolute?)
Regression window (m-c Linux64 builds): 2013-04-05-03-09-18 -- 2013-04-06-03-09-22
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=55f9e3e3dae7&tochange=768af8d8fad4
so it's likely caused by bug 841192.
Blocks: 841192
Keywords: regression
Version: unspecified → 23 Branch
Attached file Testcase #1
Note that scrolling a bit seems to clip it (at least in Nightly Linux64).
Gijs Kruitbosch: Thanks for adding this bug, hope it will be fixed soon.

For me it does not fix the problem when I disable the position:absolute.. If I turn off the position:absolute it fits a bit better, but is still outside the iframe.. After scrolling a bit up and down it looks fine, but after waiting for 5 seconds it is again outside the iframe.
Using the attachment 787110 [details] from Mats, the bug can be fixed when you disable backface-visibility on the div with class front.
Tracking for branches as this is a recent regression and passing on to :roc for help with investigation given this may be a fallout form 841192
We don't have any indication right now that this is impacting a large amount of sites and given comment 6 has a workaround, not tracking for 23.
The comments in bug 906199 say this should now be fixed (by bug 906199).
Marking this resolved WFM given this should now be fixed by https://bugzilla.mozilla.org/show_bug.cgi?id=906199 in our latest beta(Fx24)/Aurora(Fx25) and nightly.Feel free to reopen if this is still an issue.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
Keywords: verifyme
verified with 24b10 and 20130913 builds of Nightly and Aurora.
You need to log in before you can comment on or make changes to this bug.