overflow:hidden only hides immediate children if 3d style applied.

VERIFIED FIXED in Firefox 24

Status

()

Core
Layout
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: ninjaqe, Assigned: roc)

Tracking

(Depends on: 1 bug, {regression, testcase})

23 Branch
mozilla26
x86
All
regression, testcase
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox23 affected, firefox24+ verified, firefox25+ verified, firefox26+ verified)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 791481 [details]
FF_Overflow3dBug.html

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_4) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/28.0.1500.95 Safari/537.36

Steps to reproduce:

Using overflow:hidden to a tag with 3d style that have a nested tag (grand child) also with 3d style.


Actual results:

Only the child level tag is cropped by the overflow:hidden but the grand child tag is not cropped. This happens in Firefox 23 (and 24 nightly build) but unable to reproduce with FF 22 and webkit browsers.


Expected results:

overflow:hidden crops grand child level element with 3d.

Updated

5 years ago
Attachment #791481 - Attachment mime type: text/plain → text/html

Comment 1

5 years ago
Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/f4f549a04ee8
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20130405 Firefox/23.0 ID:20130405125522
Bad:
http://hg.mozilla.org/mozilla-central/rev/139b6ba547fa
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20130405 Firefox/23.0 ID:20130405131405
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f4f549a04ee8&tochange=139b6ba547fa

Regressed by:Bug 841192
Blocks: 841192
Status: UNCONFIRMED → NEW
status-firefox23: --- → affected
tracking-firefox24: --- → ?
tracking-firefox25: --- → ?
tracking-firefox26: --- → ?
Component: Untriaged → Layout
Ever confirmed: true
Keywords: regression
OS: Mac OS X → All
Product: Firefox → Core

Updated

5 years ago
Keywords: testcase
Roc, can you please help with this, may be a fallout form 841192 ?
Flags: needinfo?(roc)
Assignee: nobody → roc
Flags: needinfo?(roc)
This fixes 907078, 903587, and 902546 as well.
Blocks: 907078, 903587, 902546
Attachment #792763 - Flags: review?(matt.woodrow) → review+

Updated

5 years ago
status-firefox24: --- → affected
status-firefox25: --- → affected
tracking-firefox24: ? → +
tracking-firefox25: ? → +
tracking-firefox26: ? → +
https://hg.mozilla.org/mozilla-central/rev/954a7a7a5051
Status: NEW → RESOLVED
Last Resolved: 5 years ago
status-firefox26: --- → fixed
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla26
Comment on attachment 792763 [details] [diff] [review]
fix

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 841192
User impact if declined: broken rendering on some sites using 3D transforms
Testing completed (on m-c, etc.): just landed
Risk to taking this patch (and alternatives if risky): pretty low-risk patch. At least, it's unlikely to make things any worse since it only affects preserve-3d with clipping that's currently broken.
String or IDL/UUID changes made by this patch: none
Attachment #792763 - Flags: approval-mozilla-beta?
Attachment #792763 - Flags: approval-mozilla-aurora?

Updated

5 years ago
Attachment #792763 - Flags: approval-mozilla-beta?
Attachment #792763 - Flags: approval-mozilla-beta+
Attachment #792763 - Flags: approval-mozilla-aurora?
Attachment #792763 - Flags: approval-mozilla-aurora+

Updated

5 years ago
Keywords: verifyme
status-firefox24: affected → fixed
status-firefox25: affected → fixed

Comment 11

5 years ago
Verified as fixed on Firefox 24 beta 6 (20130826142034) - Windows 7 64bit, Ubuntu 13.04 32bit and Mac OSX 10.7.5.
status-firefox24: fixed → verified
QA Contact: ioana.budnar
Duplicate of this bug: 907900
Verified as fixed on
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:26.0) Gecko/20100101 Firefox/26.0 ID:20130830030205 
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:25.0) Gecko/20100101 Firefox/25.0 ID:20130830004004

Updated

4 years ago
Depends on: 913997

Comment 14

4 years ago
Also verified on Firefox 25:
Mac OS X 10.8.4 - 20130912004004
Ubuntu 13.04 - 20130911004006
Windows 7 - 20130912004004
status-firefox25: fixed → verified

Comment 15

4 years ago
Updating flags per comment 13.
Status: RESOLVED → VERIFIED
status-firefox26: fixed → verified
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.