mozilla::layers::PGrallocBufferChild::Write(mozilla::layers::PGrallocBufferChild*, IPC::Message*, bool)

RESOLVED FIXED in Firefox 26

Status

()

Core
Graphics: Layers
--
critical
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Bebe, Assigned: BenWa)

Tracking

({crash, regression, smoketest})

Trunk
mozilla26
ARM
Gonk (Firefox OS)
crash, regression, smoketest
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:koi+, firefox26 fixed)

Details

(Whiteboard: [b2g-crash], crash signature)

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 787544 [details]
logcat of the issue

This bug was filed from the Socorro interface and is 
report bp-e15033b0-50e4-4a2b-90d8-39b8d2130808 .
 ============================================================= 

STR:

1. Activate the passcode lock on the lockscreen
2. Unlock to camera
3. Tap on the Video icon to switch source 

Actual:

3. The phone crashes (if it's not working from the first try switch source again)

Gecko  http://hg.mozilla.org/mozilla-central/rev/79b5c74ef97b
Gaia  43557e5392ab37d4f8c1fa08184cf1541b249a54
BuildID 20130807161117
Version 26.0a1


This crash might be related with:
https://bugzilla.mozilla.org/show_bug.cgi?id=902878
Problem in the graphics layers?
Flags: needinfo?(sotaro.ikeda.g)

Comment 2

4 years ago
Probably this comment will explain some things: https://bugzilla.mozilla.org/show_bug.cgi?id=900012#c36

Updated

4 years ago
Component: Gaia::System::Lockscreen → Graphics: Layers
Product: Boot2Gecko → Core
Version: unspecified → Trunk

Updated

4 years ago
See Also: → bug 900012
Summary: crash in mozalloc_abort(char const*) | NS_DebugBreak | mozilla::layers::PGrallocBufferChild::Write(mozilla::layers::PGrallocBufferChild*, IPC::Message*, bool) → crash in mozilla::layers::PGrallocBufferChild::Write with abort message: "actor has been |delete|d"
Whiteboard: [b2g-crash]

Updated

4 years ago
Summary: crash in mozilla::layers::PGrallocBufferChild::Write with abort message: "actor has been |delete|d" → crash in mozalloc_abort(char const*) | NS_DebugBreak | mozilla::layers::PGrallocBufferChild::Write(mozilla::layers::PGrallocBufferChild*, IPC::Message*, bool)

Updated

4 years ago
Blocks: 884399
Florin, how often does the crash happen at the STR in comment #0?
Flags: needinfo?(sotaro.ikeda.g) → needinfo?(florin.strugariu)
(In reply to Mike Habicher [:mikeh] from comment #1)
> Problem in the graphics layers?

This crash seems happen by trying to delete already deleted PGrallocBufferChild. Right now gfx layers is very unstable and very very suspicious. But there is no clear evidence graphics layers made this problem. I feel it is better to wait Bug 858914 fix.

Updated

4 years ago
Depends on: 858914

Updated

4 years ago
blocking-b2g: --- → koi?
Summary: crash in mozalloc_abort(char const*) | NS_DebugBreak | mozilla::layers::PGrallocBufferChild::Write(mozilla::layers::PGrallocBufferChild*, IPC::Message*, bool) → mozilla::layers::PGrallocBufferChild::Write(mozilla::layers::PGrallocBufferChild*, IPC::Message*, bool)

Updated

4 years ago
Keywords: regression, smoketest
Depends on: 902643
(Assignee)

Updated

4 years ago
Assignee: nobody → bgirard
(Assignee)

Comment 5

4 years ago
Created attachment 792284 [details]
Log - Buffer freed from IPC and GNW
(Assignee)

Updated

4 years ago
Blocks: 902643
No longer depends on: 902643
(Assignee)

Updated

4 years ago
Blocks: 901559
(Assignee)

Comment 6

4 years ago
I can verify this bug is fixed with patches from bug 858914 applied.

I spent some time working on a patch against current trunk but it's not possible without 858914.
Flags: needinfo?(florin.strugariu)

Comment 7

4 years ago
can we get this blocking=koi+'d?   according to bug 901559, comment 18, benoit thinks this is blocking a smoketest blocker.

Comment 8

4 years ago
BenWa, yes I can confirm that our automation has been passing for the last few days so I will mark this as Resolved.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla26
(Assignee)

Comment 9

4 years ago
(In reply to Zac C (:zac) from comment #8)
> BenWa, yes I can confirm that our automation has been passing for the last
> few days so I will mark this as Resolved.

Good. We're still looking into these issues because the surface lifetimes are still not correct so I wouldn't surprised if this gets re-open until the lifetime bugs are fixed.
No longer blocks: 902643
Blocks: 902643
blocking-b2g: koi? → koi+
status-firefox26: --- → fixed
You need to log in before you can comment on or make changes to this bug.