Closed Bug 903259 Opened 7 years ago Closed 7 years ago

[Gaia] NFC application: handle NDEF and pass to handover component

Categories

(Firefox OS Graveyard :: NFC, defect)

x86
macOS
defect
Not set

Tracking

(blocking-b2g:1.3+)

RESOLVED DUPLICATE of bug 903305
1.3 Sprint 5 - 11/22
blocking-b2g 1.3+

People

(Reporter: frlee, Assigned: dgarnerlee)

References

Details

once NFC app. received NDEF message and started to initial a transfer (video/image/URL/vCards), it needs to pass the request to the handover component
Depends on: 894320, 894676, 894678
Assignee: nobody → dgarnerlee
Blocks: 894320, 894676, 894678
No longer depends on: 894320, 894676, 894678
Hi Gabriele, are you interested in handling this bug?
Assignee: dgarnerlee → nobody
Flags: needinfo?(gsvelto)
(In reply to Ken Chang from comment #1)
> Hi Gabriele, are you interested in handling this bug?

The idea here is to implement this functionality (and the one in bug 903261 and bug 903305) as part of a Gaia helper application which we will use to handle NFC functionality as per our discussions correct? In this case I'd be willing to take this as soon as I'm finished with the WAP Push functionality which shaped up as a very similar type of "service application".
Flags: needinfo?(gsvelto)
(In reply to Gabriele Svelto [:gsvelto] from comment #2)
> (In reply to Ken Chang from comment #1)
> > Hi Gabriele, are you interested in handling this bug?
> 
> The idea here is to implement this functionality (and the one in bug 903261
> and bug 903305) as part of a Gaia helper application which we will use to
> handle NFC functionality as per our discussions correct? In this case I'd be

Yes, it is. Thanks for your help.
Gabriele, are you working on this bug? :)
(In reply to khu from comment #4)
> Gabriele, are you working on this bug? :)

Not yet, I was waiting for the Gecko parts to land first.
Alive, I think you will fix this bug for NFC.
Assignee: nobody → alive
blocking-b2g: --- → 1.3+
Blocks: NFC-Gaia
Hi, do we have a clear view on the target milestone on this bug now? Thanks.
It seems better to finish this bug before sprint5. If you think it isn't reasonable, please update target milestone.
Target Milestone: --- → 1.3 Sprint 5 - 11/22
(In reply to Ken Chang from comment #6)
> Alive, I think you will fix this bug for NFC.

Sorry, this should be handled by NFC manager.
Assignee: alive → dgarnerlee
Blocks: 933116
Per discussing with Arno, it is part of bug 903305.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 903305
No longer blocks: 894320
Whiteboard: [FT:RIL]
Whiteboard: [FT:RIL]
You need to log in before you can comment on or make changes to this bug.