Closed Bug 903261 Opened 7 years ago Closed 7 years ago

[Gaia] NFC application: broadcast unhandle NDEF message

Categories

(Firefox OS Graveyard :: NFC, defect)

x86
macOS
defect
Not set

Tracking

(blocking-b2g:1.3+)

RESOLVED DUPLICATE of bug 860910
1.3 Sprint 5 - 11/22
blocking-b2g 1.3+

People

(Reporter: frlee, Assigned: dgarnerlee)

References

Details

NFC app. needs to broadcast unhandle NDEF message
Depends on: 894320, 894676, 894678
Blocks: 894320, 894676, 894678
No longer depends on: 894320, 894676, 894678
Hi Gabriele, are you interested in handling this bug?
Flags: needinfo?(gsvelto)
Happy to do this as per bug 903259 comment 1.
Flags: needinfo?(gsvelto)
(In reply to Gabriele Svelto [:gsvelto] from comment #2)
> Happy to do this as per bug 903259 comment 1.

Assigned it to Gabriele. Gabriele, if you're not handling this bug, please remove your name from the assignee. Thanks.
Assignee: nobody → gsvelto
blocking-b2g: --- → 1.3+
Gabriele, may I know what's the target milestone in your mind for this bug? Thanks.
Flags: needinfo?(gsvelto)
(In reply to Kevin Hu [:khu] from comment #4)
> Gabriele, may I know what's the target milestone in your mind for this bug?

I will need some more information on what needs to be done here before establishing a timeline. I've been following the Gecko part for a while waiting for it to land but I'm still unsure what exactly is needed here and I've also been terribly busy with koi+ bugs so I didn't really have enough time to dig deeper myself.
Flags: needinfo?(gsvelto)
Got it. Thanks, Gabriele.
(In reply to Gabriele Svelto [:gsvelto] from comment #5)
> (In reply to Kevin Hu [:khu] from comment #4)
> > Gabriele, may I know what's the target milestone in your mind for this bug?
> 
> I will need some more information on what needs to be done here before
> establishing a timeline. I've been following the Gecko part for a while
> waiting for it to land but I'm still unsure what exactly is needed here and
> I've also been terribly busy with koi+ bugs so I didn't really have enough
> time to dig deeper myself.
Since Alive has concerns for the NFC manage in Gaia, we will know if this bug is necessary after next Monday's meeting.
Blocks: NFC-Gaia
Hi, do we have a clear view on the target milestone on this bug now? Thanks.
Garner, I think you need to handle this in NFC manager.
Assignee: gsvelto → dgarnerlee
It seems better to finish this bug before sprint5. If you think it isn't reasonable, please update target milestone.
Target Milestone: --- → 1.3 Sprint 5 - 11/22
Garner, should we keep this bug? It seems that NFC manager are going to handle this function.
Flags: needinfo?(dgarnerlee)
NFC Manager sort of already sends unhandled records as "tag-discovered", or failing that, prints "MiFare not supported" somewhere (this is not really a tested code path for us, since it is inherently a no-op without DOM support added beyond NDEF).

If that's the intended meaning captured by  this bug, then yes, we can close this bug.
Flags: needinfo?(dgarnerlee)
According to comment 12, close this bug.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 860910
Whiteboard: [FT:RIL]
Whiteboard: [FT:RIL]
You need to log in before you can comment on or make changes to this bug.