VoiceOver draws the bounding box of an element wrong on Retina displays

RESOLVED DUPLICATE of bug 980480

Status

()

Core
Disability Access APIs
RESOLVED DUPLICATE of bug 980480
4 years ago
4 years ago

People

(Reporter: maxli, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
It looks like the coordinates we report probably need to be scaled by the devicePixelRatio (or something similar).

Comment 1

4 years ago
When I run the Mochitest-a11y suite locally on my MBP Retina, I get the following consistent failures. Since these do not happen on the build infrastructure, they must be related to the Retina display:


 1:49.40 7010 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/a11y/accessible/tests/mochitest/scroll/test_zoom.html | Wrong y coordinate of ['a@id="bottom2" node', address: , role: link, address: [xpconnect wrapped nsIAccessible]] - got 300, expected 278
 1:49.40 7016 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/a11y/accessible/tests/mochitest/scroll/test_zoom.html | Wrong y coordinate of ['a@id="bottom2" node', address: , role: link, address: [xpconnect wrapped nsIAccessible]] - got 300, expected 278
 1:49.40 17157 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/a11y/accessible/tests/mochitest/test_nsIAccessibleImage.html | Wrong width for nonLinkedImage! - got 178, expected 89
 1:49.40 17158 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/a11y/accessible/tests/mochitest/test_nsIAccessibleImage.html | wrong height for nonLinkedImage! - got 76, expected 38
 1:49.40 17164 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/a11y/accessible/tests/mochitest/test_nsIAccessibleImage.html | Wrong width for linkedImage! - got 178, expected 89
 1:49.40 17165 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/a11y/accessible/tests/mochitest/test_nsIAccessibleImage.html | wrong height for linkedImage! - got 76, expected 38
 1:49.40 17171 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/a11y/accessible/tests/mochitest/test_nsIAccessibleImage.html | Wrong width for longdesc! - got 178, expected 89
 1:49.40 17172 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/a11y/accessible/tests/mochitest/test_nsIAccessibleImage.html | wrong height for longdesc! - got 76, expected 38
 1:49.40 17180 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/a11y/accessible/tests/mochitest/test_nsIAccessibleImage.html | Wrong width for clickAndLongdesc! - got 178, expected 89
 1:49.40 17181 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/a11y/accessible/tests/mochitest/test_nsIAccessibleImage.html | wrong height for clickAndLongdesc! - got 76, expected 38
 1:49.40 17190 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/a11y/accessible/tests/mochitest/test_nsIAccessibleImage.html | Wrong width for click! - got 178, expected 89
 1:49.40 17191 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/a11y/accessible/tests/mochitest/test_nsIAccessibleImage.html | wrong height for click! - got 76, expected 38
 1:49.40 17199 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/a11y/accessible/tests/mochitest/test_nsIAccessibleImage.html | Wrong width for longdesc2! - got 178, expected 89
 1:49.40 17200 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/a11y/accessible/tests/mochitest/test_nsIAccessibleImage.html | wrong height for longdesc2! - got 76, expected 38

Remarkable that the image coordinates are always the double of the expected value. And some of the other stuff, too.

I suspect that some of the calculation is already off in the platform-independent layer, and that that also affects what VoiceOver gets as bounds.
(Reporter)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 980480
You need to log in before you can comment on or make changes to this bug.