No titlebar context menu in both Nightly and Aurora (can't right-click)

RESOLVED DUPLICATE of bug 898577

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 898577
5 years ago
5 years ago

People

(Reporter: twocables, Unassigned)

Tracking

25 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130618035212

Steps to reproduce:

Right-click the titlebar above any tab. For me, I can right-click anywhere above a tab and get this bug, but you might have to right-click in that tiny space above a tab (like, in the millimeter of space above it).


Actual results:

Nothing


Expected results:

One of the following two context menus should have appeared, depending on if I right-click high or right-click low on the titlebar above a tab:

1. The system context menu (the one that contains Restore, Move, Size, Minimize, Maximize, Close)
2. The context menu containing the options for Menu Bar and Bookmarks Toolbar (and Customize)

This began happening after one of the relatively recent updates. It could have been when both Nightly and Aurora became version 25, but I'm not sure. Although, I assume so because this bug affected Nightly first and then it affected Aurora.

Note: If I right-click the titlebar where there is no tab below (such as when there's only 1 tab), then I get the expect results.

Note 2: this may be due to the extension called Aero Window Title: https://addons.mozilla.org/en-US/firefox/addon/aero-window-title/

Final note: The convenience is, I like being able to just right-click anywhere on the titlebar and choose either 'Close' or just press 'C' (my left hand is usually on home row), especially if the last thing I click before closing the browser is one of my tabs on the far left. I know about Alt+F4 and I do use that from time to time, but when I'm getting ready to close Firefox (Nightly or Aurora), my right-hand is usually on the mouse. So, just moving the mouse a millimeter up and then right-clicking the titlebar and choosing Close or pressing C is FAR more convenient. It's even more convenient than aiming at the red X and then clicking it. By not having this context menu, it instantly becomes inconsistent with Windows. Furthermore, the Firefox context menu needs to be there as well.


This is NOT a duplicate of Bug 898577 even though the text of the bug is mostly the same. That bug (898577) is for UX Nightly while THIS one is for both Nightly and Aurora (it's not for UX Nightly) even though it's the same bug.

I have now stopped using UX Nightly, Nightly and Aurora because of this. So, please don't let it get all the way to the stable release of Firefox 25.
Hi twocables, this looks like a duplicate bug to me; just explain in the first one that you filed, bug 898577, that you see the same issue in Nightly and Aurora. Thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 898577
(Reporter)

Comment 2

5 years ago
But I don't see this as a duplicate because this is for 3 different 'versions' of Firefox. So, I should really have 3 filed: one for UX Nightly, one for Nightly, and one for Aurora.

My goal here is to prevent this from getting to the stable release of Firefox 25. It affected UX Nightly first. Then it affected Nightly, and now it's affecting Aurora. Next is Beta 25 when that becomes version 25, and then after that it will be Firefox 25 when it becomes version 25.

So to be honest: I don't want this marked as Resolved because it's I don't see it as a duplicate. I want this marked differently and treated as an individual bug because to me, a duplicate bug is a duplicate for the exact same version of Firefox. In other words, a duplicate to me would be having 2 or more of this bug filed for UX Nightly, or 2 or more filed for Nightly, or 2 or more filed for Aurora, etc. As of right now, there's only one of this filed for UX Nightly, and again, I should really have 1 filed for Nightly and 1 filed for Aurora but still, there's only 1 files for Nightly and Aurora.

So yes, it's the same bug, but it's for these 3 different 'versions' of Firefox.
You need to log in before you can comment on or make changes to this bug.