Soundcloud Crackling Audio

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: nemisor, Assigned: padenot)

Tracking

25 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20130805 Firefox/24.0 (Nightly/Aurora)
Build ID: 20130805004006

Steps to reproduce:

Upgraded to Aurora 25.a2 from 24.a2


Actual results:

Immediately noticed crackling/static audio in all Soundcloud tracks.  Tested both Flash and HTML5 playback and it made no difference.  It may be a driver related issue with my older Creative X-Fi PCI card, however this is unlikely.  Also tested running in safe mode with all plugins disabled, but this again had no effect.


Expected results:

Sound playback should have been consistent and without artifacts.  I suspect that the "Experimental support for WebAudio, targeted at developer testing and feedback" is the culprit here, however I am not experienced enough to attempt disabling it to test while still running Aurora 25.a2

Please investigate.
Tried this in Aurora 25.a2 on MacOS 10.8.4 but didn't hear any crackling. Is it very obvious artifacts? Is there a particular track I should try to hear it in?
Flags: needinfo?(nemisor)
(Reporter)

Comment 2

5 years ago
It is very noticeable on all tracks.  Was testing with https://soundcloud.com/cottonmouthedge/cottonmouth-retro-kids at the time.  Seriously doubt it would be repeatable in MacOS.  Think it has something to do with the changed interaction between WebAudio and (guessing) DirectX or something in Win7x64.
Flags: needinfo?(nemisor)
Status: UNCONFIRMED → NEW
Component: Untriaged → Web Audio
Ever confirmed: true
Product: Firefox → Core

Comment 3

5 years ago
Paul, can you please take a look?  I can't reproduce on Mac.
Assignee: nobody → paul

Comment 4

5 years ago
If you want to hear crackling, try the demos here: http://webaudiodemos.appspot.com/MIDIDrums/index.html

Click either demo 3, 4, or 5 (especially #4) near the bottom right.  Not only is Firefox dog slow and consuming lots of CPU, it also crackles a lot.

Comment 5

5 years ago
Hey guys,

I'm an Engineering at SoundCloud and I just want to mention that to date we are not making any use of the WebAudio API.
We do make use of HTML5 Audio and Flash but it's pretty much different from what WebAudioAPI allows you to do.
The crackling you might hear might be a driver issue or a connector library in Firefox.
(Assignee)

Comment 6

5 years ago
Can you try again with an updated aurora build, or a nightly [1] build? I fixed a couple issues last week about how we do audio on Windows.

[1]: http://nightly.mozilla.org/
Flags: needinfo?(nemisor)
(Assignee)

Comment 7

5 years ago
(changing component per comment 5)
Component: Web Audio → Video/Audio
(Reporter)

Comment 8

5 years ago
Just noticed this.  Will test tonight with the latest build and verify...
Flags: needinfo?(nemisor)
(Reporter)

Comment 9

5 years ago
(In reply to Paul Adenot (:padenot) from comment #6)
> Can you try again with an updated aurora build, or a nightly [1] build? I
> fixed a couple issues last week about how we do audio on Windows.
> 
> [1]: http://nightly.mozilla.org/

Tested and it is working normally again!  Thanks a bunch.  It must have been something you changed recently.  

(In reply to Yves Van Goethem from comment #5)
> Hey guys,
> 
> I'm an Engineering at SoundCloud and I just want to mention that to date we
> are not making any use of the WebAudio API.
> We do make use of HTML5 Audio and Flash but it's pretty much different from
> what WebAudioAPI allows you to do.
> The crackling you might hear might be a driver issue or a connector library
> in Firefox.

Glad to hear that WebAudio isn't associated with this issue.  Thanks again everybody!
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.