Closed Bug 904534 Opened 6 years ago Closed 6 years ago

[Window Management] Use BrowserFrame to generate mozBrowser iframe in Window Manager

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: alive, Assigned: alive)

References

Details

Attachments

(1 file)

And deprecate appendFrame and createFrame.
The following would be moved into appWindow.
Looks like wrapper do much thing with the generated iframe so it's impossible to deprecate createFrame/appendFrame now.
Let's do it after wrapper handler is moved out of WM...
Attachment #789979 - Flags: review?(timdream)
Comment on attachment 789979 [details]
https://github.com/mozilla-b2g/gaia/pull/11517

r+ if you there is no functional regression.
Attachment #789979 - Flags: review?(timdream) → review+
Assignee: nobody → alive
Fix unit test and merged.
https://github.com/mozilla-b2g/gaia/commit/6f81d337135044c9eaae0516a49e8e9b3710a804
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
No longer blocks: task-manager
Alias: browser-frame
Alias: browser-frame
No longer blocks: window-management
You need to log in before you can comment on or make changes to this bug.