Spell checker not working in TinyMCE and CKEditor editor

RESOLVED INVALID

Status

()

RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: tempest, Assigned: Ehsan)

Tracking

({regression})

24 Branch
x86
All
regression
Points:
---

Firefox Tracking Flags

(firefox23 unaffected, firefox24 affected)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:24.0) Gecko/20100101 Firefox/24.0 (Beta/Release)
Build ID: 20130806170643

Steps to reproduce:

Firefox spell checker does not work when i write or edit posts on this forum:
http://www.bug.hr/forum/

Forum software uses TinyMCE


Actual results:

Misspelled words not underlined. 


Expected results:

Misspelled words underlined.

I realize TinyMCE had issues with gecko spell checker before, however this time spell checking works in firefox 23 and earlier, but in firefox 24 it doesn't. What changed?

Comment 1

5 years ago
STR
1. Open http://www.tinymce.com/tryit/custom_formats.php
2. Right click ont the editor and Turn on "Check Spelling"
3. Type something and press SPACE
    --- observe red wave-under-line

Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/8ea92aeab783
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20130619 Firefox/24.0 ID:20130619164023
Bad:
http://hg.mozilla.org/mozilla-central/rev/83aa31ec53d9
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20130620 Firefox/24.0 ID:20130620005958
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=8ea92aeab783&tochange=83aa31ec53d9

Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/069b2adf589e
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20130619 Firefox/24.0 ID:20130619134753
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/5b3196ad66f4
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20130619 Firefox/24.0 ID:20130619143654
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=069b2adf589e&tochange=5b3196ad66f4

Regressed by: Bug 674927
Blocks: 674927
Status: UNCONFIRMED → NEW
status-firefox23: --- → unaffected
tracking-firefox24: --- → ?
tracking-firefox25: --- → ?
tracking-firefox26: --- → ?
Component: Untriaged → Spelling checker
Ever confirmed: true
Keywords: regression
OS: Windows XP → All
Product: Firefox → Core

Comment 2

5 years ago
Err in comment#!
s/2. Right click ont the editor/2. Right click on the editor/



And CKEditor also affected.

STR
1. Open http://ckeditor.com/demo#standard
2. Shift-Right click to popup system context mneu on the editor and Turn on "Check Spelling"
3. Type something and press SPACE
    --- observe red wave-under-line
Summary: Spell checker not working in TinyMCE editor → Spell checker not working in TinyMCE and CKEditor editor
(Reporter)

Comment 3

5 years ago
Same behavior can be seen here:
http://www.tinymce.com/tryit/3_x/listbox_splitbutton.php

Firefox 23 and earlier with enabled spell checking underlines some words (because they are not in dictionary)

Firefox 24 does not underline anything, even with spell checking enabled
(Assignee)

Updated

5 years ago
Assignee: nobody → ehsan
(Assignee)

Comment 4

5 years ago
(In reply to Alice0775 White from comment #1)
> STR
> 1. Open http://www.tinymce.com/tryit/custom_formats.php
> 2. Right click ont the editor and Turn on "Check Spelling"
> 3. Type something and press SPACE
>     --- observe red wave-under-line

In this page, the editable section's <body> element contains a spellcheck="false" attribute, so our current behavior is correct.
(Assignee)

Comment 5

5 years ago
(In reply to tempest from comment #3)
> Same behavior can be seen here:
> http://www.tinymce.com/tryit/3_x/listbox_splitbutton.php
> 
> Firefox 23 and earlier with enabled spell checking underlines some words
> (because they are not in dictionary)
> 
> Firefox 24 does not underline anything, even with spell checking enabled

Same story here.
(Assignee)

Comment 6

5 years ago
The same might apply to bug.hr/forum.  I can't speak Hungarian so I can't figure out how to get to a page where this happens on bug.hr, but it seems like there is no bug here, we have just fixed an old bug which caused us to ignore the spellcheck attribute for contenteditable elements.

tempest, any chance you could give me a URL that I can go to in order to try this out?

Thanks!
(Assignee)

Updated

5 years ago
Flags: needinfo?(tempest)

Comment 7

5 years ago
(In reply to :Ehsan Akhgari (needinfo? me!) from comment #4)
> (In reply to Alice0775 White from comment #1)
> > STR
> > 1. Open http://www.tinymce.com/tryit/custom_formats.php
> > 2. Right click ont the editor and Turn on "Check Spelling"
> > 3. Type something and press SPACE
> >     --- observe red wave-under-line
> 
> In this page, the editable section's <body> element contains a
> spellcheck="false" attribute, so our current behavior is correct.

Does Step2(Turn on "Check Spelling" from contextmenu) not have an effect?

Comment 8

5 years ago
I filed Bug 905174 and Bug 905176 for context menu with the contradiction.
(Assignee)

Comment 9

5 years ago
(In reply to comment #7)
> (In reply to :Ehsan Akhgari (needinfo? me!) from comment #4)
> > (In reply to Alice0775 White from comment #1)
> > > STR
> > > 1. Open http://www.tinymce.com/tryit/custom_formats.php
> > > 2. Right click ont the editor and Turn on "Check Spelling"
> > > 3. Type something and press SPACE
> > >     --- observe red wave-under-line
> > 
> > In this page, the editable section's <body> element contains a
> > spellcheck="false" attribute, so our current behavior is correct.
> 
> Does Step2(Turn on "Check Spelling" from contextmenu) not have an effect?

No, and I don't think it should.  If content asks us to disable spell checking, we should assume that there is a good reason for that.  It might make sense to hide the context menu in that case...
(Reporter)

Comment 10

5 years ago
(In reply to :Ehsan Akhgari (needinfo? me!) from comment #6)
> The same might apply to bug.hr/forum.  I can't speak Hungarian so I can't
> figure out how to get to a page where this happens on bug.hr, but it seems
> like there is no bug here, we have just fixed an old bug which caused us to
> ignore the spellcheck attribute for contenteditable elements.
> 
> tempest, any chance you could give me a URL that I can go to in order to try
> this out?
> 
> Thanks!

No need to, i just checked it myself. It's the same thing. 

Sort of unexpected because i really don't see a good reason for it to be explicitly disabled. I just wrote myself a userscript to override such behavior.

Anyway, thank you for your effort.
Flags: needinfo?(tempest)
(Assignee)

Updated

5 years ago
See Also: → bug 905176
(Assignee)

Comment 11

5 years ago
Thanks for the bug report anyway, when in doubt, please always file a bug!  :-)
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID

Updated

5 years ago
status-firefox24: --- → affected
tracking-firefox24: ? → ---
tracking-firefox25: ? → ---
tracking-firefox26: ? → ---

Comment 12

5 years ago
tempest@net.hr from comment 10:
"...I just wrote myself a userscript to override such behavior."

Can you please elaborate on how you did that (what tools and resources you used to figure it out), or at least provide an example script so that others may benifit from your experience and or solution to the problem?

Thanks.

Comment 13

5 years ago
As you can see in my last post "...benifit..." should have been "benefit". 

I'm using firefox 24 and spellchecker isn't working by default as it should even though I have the en-US dictionary installed. 

I have to either right click in the text box used to enter this post and select "Add dictionary", or brows to "about:config" and either manually set or add a new key called "spellchecker.dictionary" that has a string value equal to "en-US", and I have to repeat this process every time I start firefox which is something I can easily forget to do (as you saw in my last post) so a script to set this every time firefox starts would be a great workaround.

The only solutions I can come up with for this are very memory and CPU intensive so help is obviously still needed here.

From what I'm seeing on Ubuntu 12.04, Gnome3, Firefox 24, this is definitely a problem. Why is this marked as RESOLVED INVALID? If this problem is still occurring shouldn't it be marked "VALID" or something like that?

Comment 14

5 years ago
Its worse than I thought. The spellchecker being disabled by default is occurring every time the browser reloads this webpage so the added dictionary is not being saved as a setting between page loads.
You need to log in before you can comment on or make changes to this bug.