For input/textarea/contenteditable with spellcheck="false", "Check Spelling" context menu should be disabled/hidden

VERIFIED FIXED in Firefox 24

Status

()

Firefox
Menus
VERIFIED FIXED
5 years ago
a year ago

People

(Reporter: Alice0775 White, Assigned: Ehsan)

Tracking

Trunk
Firefox 26
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox23 unaffected, firefox24+ verified, firefox25+ verified, firefox26+ verified)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 790239 [details]
spellcheck.html

Steps To Reproduce:
1. Open attached
2. Right click on these editable element

3. Try to turn on "Check Spelling" context menu 

Actual Results:
"Check Spelling" is enabled state
"Check Spelling" is able to toggle the state.

Expected Results:
"Check Spelling" should be disabled(gray color or hidden).
"Check Spelling" should be not able to toggle the state.
(Reporter)

Updated

5 years ago
Component: General → Menus
Version: 24 Branch → Trunk
(Assignee)

Comment 1

5 years ago
I think this is what we should do, yes!
(Assignee)

Updated

5 years ago
See Also: → bug 904553
(Assignee)

Comment 2

5 years ago
Created attachment 790326 [details] [diff] [review]
Patch (v1)
Assignee: nobody → ehsan
Status: NEW → ASSIGNED
Attachment #790326 - Flags: review?(mconley)
Comment on attachment 790326 [details] [diff] [review]
Patch (v1)

Review of attachment 790326 [details] [diff] [review]:
-----------------------------------------------------------------

This looks fine to me by inspection. Thanks!
Attachment #790326 - Flags: review?(mconley) → review+
(Assignee)

Comment 4

5 years ago
We need to track this instead of bug 904553.
status-firefox24: --- → affected
status-firefox25: --- → affected
status-firefox26: --- → affected
tracking-firefox24: --- → ?
tracking-firefox25: --- → ?
tracking-firefox26: --- → ?
(Assignee)

Comment 5

5 years ago
Bug 622284 managed to completely bitrot my test changes :(
(Assignee)

Updated

5 years ago
Depends on: 622284

Updated

5 years ago
status-firefox23: --- → unaffected
tracking-firefox24: ? → +
tracking-firefox25: ? → +
tracking-firefox26: ? → +
https://hg.mozilla.org/mozilla-central/rev/af6e46ed8494
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
status-firefox26: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 26
Ehsan, ready to uplift ?
(Reporter)

Comment 9

5 years ago
Did the patch fix for element contenteditable only?
"Check Spelling" menu still appears on <input> and <textarea> with spellcheck="false".
(Assignee)

Comment 10

5 years ago
(In reply to Alice0775 White from comment #9)
> Did the patch fix for element contenteditable only?
> "Check Spelling" menu still appears on <input> and <textarea> with
> spellcheck="false".

Yes, that's intentional, since we do support forcing spellchecking for them.
(Assignee)

Comment 11

5 years ago
Comment on attachment 790326 [details] [diff] [review]
Patch (v1)

Trivial fix that we need to backport in order to have consistent UI (see bug 904553 for the context.)
Attachment #790326 - Flags: approval-mozilla-beta?
Attachment #790326 - Flags: approval-mozilla-aurora?
(Reporter)

Comment 12

5 years ago
(In reply to :Ehsan Akhgari (needinfo? me!) from comment #10)
> (In reply to Alice0775 White from comment #9)
> > Did the patch fix for element contenteditable only?
> > "Check Spelling" menu still appears on <input> and <textarea> with
> > spellcheck="false".
> 
> Yes, that's intentional, since we do support forcing spellchecking for them.

Ok, I filed Bug 906979

Updated

5 years ago
Attachment #790326 - Flags: approval-mozilla-beta?
Attachment #790326 - Flags: approval-mozilla-beta+
Attachment #790326 - Flags: approval-mozilla-aurora?
Attachment #790326 - Flags: approval-mozilla-aurora+

Updated

5 years ago
Keywords: verifyme
There are some non-trivial merge conflicts with Aurora/Beta. Please create a branch-specific patch.
Flags: needinfo?(ehsan)
Keywords: branch-patch-needed
(Assignee)

Comment 14

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/1a1ff090cd02
https://hg.mozilla.org/releases/mozilla-beta/rev/b8c61de105bf
status-firefox24: affected → fixed
status-firefox25: affected → fixed
Flags: needinfo?(ehsan)
Keywords: branch-patch-needed

Comment 15

5 years ago
Verified as fixed on Firefox 24 beta 5 - 20130822154523 - on Windows 7, Mac OS X 10.7.5 and Ubuntu 13.04.
status-firefox24: fixed → verified
QA Contact: ioana.budnar

Comment 16

5 years ago
Verified as fixed on:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0 (20130908004001)

Spell checking can be forced for input and textarea, but not for contenteditable.

The "Add dictionaries..." option displayed in the contenteditable contextual menu is very confusing, considering that the spell checking option is gone. Has it been left there by design? Could it be removed with the "Spell Check" option?
status-firefox25: fixed → verified
Flags: needinfo?(ehsan)

Comment 17

5 years ago
Verified as fixed on 
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 (20130909030204)
Status: RESOLVED → VERIFIED
status-firefox26: fixed → verified
Keywords: verifyme
(Assignee)

Comment 18

5 years ago
(In reply to Ioana Budnar, QA [:ioana] from comment #16)
> Verified as fixed on:
> Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0
> (20130908004001)
> 
> Spell checking can be forced for input and textarea, but not for
> contenteditable.
> 
> The "Add dictionaries..." option displayed in the contenteditable contextual
> menu is very confusing, considering that the spell checking option is gone.
> Has it been left there by design? Could it be removed with the "Spell Check"
> option?

There's no design behind any of this, not at least a recent one.  Please feel free to file a bug on that, but I probably won't have enough time to work on it myself.  Sorry!
Flags: needinfo?(ehsan)

Comment 19

5 years ago
(In reply to :Ehsan Akhgari (needinfo? me!) from comment #18)
> There's no design behind any of this, not at least a recent one.  Please
> feel free to file a bug on that, but I probably won't have enough time to
> work on it myself.  Sorry!

Thanks for the info. I filed bug 915117.

Comment 20

5 years ago
Why must the web browser comply to a website request to turn off the ability to use Firefox built in spell checker? 

Why should a website force us to use their WYSIWYG text editor's clunky spell checker? 

We know Firefox spell checker out-best them. Why take in-line as you type spell checking in multiple languages [dictionaries] away from your browser's end users? I don't understand why websites should be able mess with our browser settings and mess with our on-the-web text editing experience. It is our body of text and we should be able to spell check the heck out of it with Firefox's spell checker.

I don't see what was wrong with the previous behavior. Firefox built-in spell checker was off and the user had to turn it on [right click menu > spell check] it was not "On" Firefox was empowering its users by allowing them to still be able to use the built-in spell checker. Now we have been robbed of such empowering for-user yet harmless to-the-website setting

I see this as a big step backward, thus broken.

Comment 21

4 years ago
This is highly annoying, please restore the old behavior. What harm can it do to a webmaster if people can spellcheck their submissions to him?

Worst is if it's not even the webmaster's decision, but some software he had installed which had this nonsense in without anybody knowing (... not even the current developers of said software...)

See https://bugzilla.mozilla.org/show_bug.cgi?id=909352#c13 for one example.

Please, do the user's bidding, and don't lick up to big media, banks or whomever. Firefox, you are _our_ browser not theirs!
(Assignee)

Comment 22

4 years ago
A good example of a case where a website would legitimately want to disable spell checking on a field is when they use it to display text which is not meant to be entered by the suer, and hence does not require to be spell checked.  A classic example is a textarea showing the EULA for a website.
(In reply to :Ehsan Akhgari (needinfo? me!) from comment #22)
> A good example of a case where a website would legitimately want to disable
> spell checking on a field is when they use it to display text which is not
> meant to be entered by the suer, and hence does not require to be spell
> checked.  A classic example is a textarea showing the EULA for a website.

Such fields should be read-only, so the readonly attribute might be a better indicator than spellcheck="false" that the user shouldn't be able to enable spell checking.
Depends on: 1350898
You need to log in before you can comment on or make changes to this bug.