If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Electrolysis: Assert(!mSurface) in TextureClient.cpp:346

RESOLVED DUPLICATE of bug 904343

Status

()

Core
Graphics: Layers
RESOLVED DUPLICATE of bug 904343
4 years ago
4 years ago

People

(Reporter: evilpie, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 789790 [details]
stacktrace

Bug 902330 changed mSurface = nullptr to assert(!mSurface). Since then this is hit quite often when running on Linux. Changing this line to the old code seems to cause no observable problems.
We think this is fixed by bug 904343.
Depends on: 904343
I see this too. Simply trying to unlock the phone causes this assertion to trigger and cause a crash every time.
(In reply to Botond Ballo :botond from comment #2)
> I see this too. Simply trying to unlock the phone causes this assertion to
> trigger and cause a crash every time.

The patch for bug 904343 (the one entitled "patch") resolves this issue for me.

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 904343
You need to log in before you can comment on or make changes to this bug.