Defect - Caret selection doesn't work properly in Metro Firefox

RESOLVED DUPLICATE of bug 858206

Status

Firefox for Metro
Input
RESOLVED DUPLICATE of bug 858206
5 years ago
4 years ago

People

(Reporter: Samvedana, Unassigned)

Tracking

Trunk
x86
Windows 8.1

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
See bug 851388 comment7 for more detail.
(Reporter)

Updated

5 years ago
Blocks: 851388

Updated

5 years ago
Whiteboard: [preview-triage] feature=defect c=tbd u=tbd p=0

Comment 1

5 years ago
We need steps to reproduce and a description of the bug please.
(Reporter)

Comment 2

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.2; Win64; x64; rv:26.0) Gecko/20100101 Firefox/26.0
Build ID: 20130808030205
Built from http://hg.mozilla.org/mozilla-central/rev/fd4cf30428b0

Tested on windows 8 using latest nightly  for iteration-11. 

Steps to reproduce:

1. Visits https://developer.mozilla.org/en-US/docs/HTML/HTML_Elements/textarea#HTML_Content and sees a text area with the text "Write something here"
2. Taps on the space between the words "something" and "here" and the cursor with gripper is inserted at the point of the tap.
3. Drags the gripper to the right or the left to select the text.
4. Select any gripper and try to move it in the direction of other gripper.

Expected: The text should be selected.   


Actual result:
When I tapped between "Write something here" I saw one monocle. I dragged to select word, the word was selected. If one monocle cross other then the behavior is not expected.
See attached video at http://youtu.be/QFuVziHhV2Y

Updated

5 years ago
No longer blocks: 838081, 851388
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Whiteboard: [preview-triage] feature=defect c=tbd u=tbd p=0
Duplicate of bug: 858206
(Reporter)

Comment 4

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
Build ID: 20130825030201
Built from http://hg.mozilla.org/mozilla-central/rev/01576441bdc6

WFM
Tested on windows 8 using latest nightly for iteration-12. I am still seeing same issue.
(Assignee)

Updated

4 years ago
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.