Closed Bug 904995 Opened 6 years ago Closed 6 years ago

[Wifi] Refactor Wifi enable/disable command queue

Categories

(Firefox OS Graveyard :: Wifi, defect)

All
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 906631

People

(Reporter: chucklee, Assigned: chucklee)

Details

Wifi enable/disable command queue is introduced to maintain wifi status while enable/disable command is sent while previous command is still progressing.
But we observe a race condition caused by un-sync between queue status and driver status.
Bug 900855 solves this by checking driver status before queue operation, but it's better do some refactory on command queue operation like providing a unified operation interface, find a better method to prevent driver race condition, etc.
This refactory is required as part of solution for bug 906631, so the refactory will be done along with that bug.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 906631
You need to log in before you can comment on or make changes to this bug.