Closed Bug 905316 Opened 9 years ago Closed 9 years ago

[Fig] - Awesomescreen thumbnails must only display bookmarks

Categories

(Firefox for Android Graveyard :: Awesomescreen, defect, P1)

26 Branch
ARM
Android
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 885084

People

(Reporter: aaronmt, Assigned: Margaret)

References

Details

Currently the top-sites are identified after site visits and their thumbnails are positioned into the 'Bookmarks' category which does not make any sense.

Expected: Tab title 'Boomarks & Top Sites'
Actual: Tab title 'Bookmarks'
That's actually not the case. 

We've changed how these work in the new Awesomescreen. Those thumbnails are now actually your *most visited bookmarks*

So since only pages you deem special enough to bookmark will show up automatically, we reduce the chance of having a lot of thumbnails of sites you don't care about, which is a common problem we have with our current "Top Sites" thumbnails on about:home.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → INVALID
What am I misunderstanding? I create a brand new profile, I visit http://thestar.com, I tap the address bar and swipe over to Bookmarks and I see it as a thumbnail. I never once bookmarked thestar.com
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Summary: [Fig] Identified top-sites as thumbnails in Bookmarks category → [Fig] - Awesomescreen thumnails must only display bookmarks
Summary: [Fig] - Awesomescreen thumnails must only display bookmarks → [Fig] - Awesomescreen thumbnails must only display bookmarks
Status: REOPENED → NEW
Ok, that's something we need to fix right away then. The whole point of moving the thumbnails over to this panel was to avoid 'false positives' like that.
Sriram, did you ever file a bug about updating the DB query we're doing to get the top bookmarks? If not, that can be this bug, and I can fix it.
Assignee: nobody → margaret.leibovic
Flags: needinfo?(sriram)
Priority: -- → P1
Status: NEW → RESOLVED
Closed: 9 years ago9 years ago
Flags: needinfo?(sriram)
Resolution: --- → DUPLICATE
Duplicate of bug: 885084
You can let me know if this is the same type of bug or not, but here's what's happening with me. I had 4 pinned thumbnails, and 2 'open' slots.

I use facebook *all* the time. It is listed as a bookmark below the top sites thumbnails, which I am supposing means that I have bookmarked it (although if I'm totally honest, until I today, I *never* scrolled past the actual Top Sites thumbnails).

However, my two unpinned thumbnail slots still show not an oft-used bookmark (but a page I visit frequently) and a link to the AMO. I can tell you that I visit the AMO once every few months to test it out and it hasn't changed since Fig was implemented in nightly. Facebook is nowhere to be seen.

So this leads me to asset that Top Sites still aren't working properly.
(In reply to Karen Rudnitski [:kar] from comment #6)
> You can let me know if this is the same type of bug or not, but here's
> what's happening with me. I had 4 pinned thumbnails, and 2 'open' slots.
> 
> I use facebook *all* the time. It is listed as a bookmark below the top
> sites thumbnails, which I am supposing means that I have bookmarked it
> (although if I'm totally honest, until I today, I *never* scrolled past the
> actual Top Sites thumbnails).
> 
> However, my two unpinned thumbnail slots still show not an oft-used bookmark
> (but a page I visit frequently) and a link to the AMO. I can tell you that I
> visit the AMO once every few months to test it out and it hasn't changed
> since Fig was implemented in nightly. Facebook is nowhere to be seen.
> 
> So this leads me to asset that Top Sites still aren't working properly.

Let's file a new bug to sort this out.

This bug was about the fact that we were showing non-bookmarks in the bookmarks thumbnails section, but it sound like you're just seeing an unexpected set of bookmarks in your thumbnails.

In the bookmarks page on about:home, you should only ever see bookmarked sites.
> Let's file a new bug to sort this out.

Done! bug 913116
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.