Message compose window sometimes not shown in the taskbar (possibly involving MS Remote Desktop Protocol/RDP)

RESOLVED WORKSFORME

Status

Thunderbird
Message Compose Window
RESOLVED WORKSFORME
4 years ago
a year ago

People

(Reporter: Moritz Franckenstein, Unassigned)

Tracking

17 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [support])

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 5.2; rv:23.0) Gecko/20100101 Firefox/23.0 (Beta/Release)
Build ID: 20130730113002

Steps to reproduce:

Opened a message compose window via reply or create button and later task-switched to some other windows or applications.


Actual results:

Window is there in the background, but has no taskbar entry. It cannot be seen anymore and is easily forgot. I have this happen every some days (since years and over many versions), maybe forget that I started writing some message and sometimes much later notice it when minimizing other windows.


Expected results:

I think it could be related to accessing TB over RDP (Windows XP). From other projects I know that screen operations can raise exceptions when using RDP over a slow or disconnected connection. In normal local mode, those would never happen. So, when this exception aborts some method which would later execute other commands, this could be an explanation.
(Reporter)

Updated

4 years ago
OS: Windows Server 2003 → Windows XP

Comment 1

4 years ago
Moritz, when this happens, can you single-left-click on the main taskbar button for TB and report back what you see?
When there are too many windows on task bar, XP starts to collate multiple taskbar entries of same program into a single taskbar entry, so it looks as if composition windows have disappeared but there's a little dropdown arrow on TB's main taskbar button to indicate several windows are hidden on same button.

I'm using XP (without RDP=Remote Desktop Protocol), and I've never had this problem. If it only happens with RDP, what makes you think that this a bug in TB?
Whiteboard: [support]

Updated

4 years ago
Summary: Message compose window is not shown in the taskbar → Message compose window sometimes not shown in the taskbar (involving MS Remote Desktop Protocol/RDP)
(Reporter)

Comment 2

4 years ago
Hello Thomas, that task bar option is off, and entries are never combined.

I didn't say it only happens with RDP. I just wanted to mention that I only tried it over RDP, in case it's related. Since there are no other people complaining about this problem, it must be some special situation on my machine. It could also be some plugin or so...

I think, it's too early to include RDP in the subject.

Comment 3

4 years ago
Does problem occur in TB's Safe Mode (Help > Restart with Addons disabled)?
Summary: Message compose window sometimes not shown in the taskbar (involving MS Remote Desktop Protocol/RDP) → Message compose window sometimes not shown in the taskbar (possibly involving MS Remote Desktop Protocol/RDP)
(Reporter)

Comment 4

4 years ago
I just noticed that I already disabled nearly all addons months ago. So it will be unlikely. But I have used this option now and we will see.

The problem is that I don't know how to reproduce it, and it could take days until it happens again. I will go on watching it and report when I have anything new.
Moritz, do you still see this problem?
Flags: needinfo?(maf-soft)
(Reporter)

Comment 6

a year ago
I'm still working the same way over RDP, but didn't see this issue for a year or so. So I think, it's safe to close it. Thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(maf-soft)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.