Closed Bug 905610 Opened 7 years ago Closed 6 years ago

VLC media player add on not reflecting correct version

Categories

(Firefox :: Untriaged, defect)

23 Branch
x86
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 905451

People

(Reporter: analyticalanarchy, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:23.0) Gecko/20100101 Firefox/23.0 (Beta/Release)
Build ID: 20130730113002

Steps to reproduce:

Uninstalled VLC media player 2.0.6, rebooted, installed VLC media player 2.0.8.  


Actual results:

Firefox add ons reporting old version (2.0.6) installed and vulnerable.
Tried the steps as outlined here with no success:  https://support.mozilla.org/en-US/questions/968058#answer-467866
Program Files and registry reflecting correct version.


Expected results:

Add on checker should have reflected updated version of the product installed.
Known issue:  https://forum.videolan.org/viewtopic.php?f=14&t=113048&p=383039#p383039
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → INVALID
Reopening as this is a verified issue, perhaps something Firefox can fix?  Since the .dll in question is not unsafe, there should be some way for the add on checker to ignore the finding when the program has been updated.  https://forum.videolan.org/viewtopic.php?f=14&t=113048
Status: RESOLVED → VERIFIED
This bug still exists (or regressed) when upgrading from VLC 2.1.1 to 2.1.2 with Firefox 26.0 (32 bit version of both under Windows 7); the above message says reopening as verified issue, but the bug status still says VERIFIED INVALID (and won't let me fix it).
Flags: needinfo?
Related discussion in the Firefox support forum:
https://support.mozilla.org/questions/982481 plugin check not working
Flags: needinfo?
The screenshots requested in the thread linked above that I would have uploaded look the same as the ones posted in the link above.
(In reply to LarkBea from comment #0) 
> Uninstalled VLC media player 2.0.6, rebooted, installed VLC media player
> 2.0.8.  
> Firefox add ons reporting old version (2.0.6) installed and vulnerable.

This looks to be a duplicate of an earlier bug:
Bug 905451 - FF 23.0 says VLC 2_0_6 plugin is out of date -But post install 2_0_8, still has 2_0_6 plugin

(In reply to Lucius Chiaraviglio from comment #3)
> This bug still exists (or regressed) when upgrading from VLC 2.1.1 to 2.1.2
> with Firefox 26.0 (32 bit version of both under Windows 7); the above
> message says reopening as verified issue, but the bug status still says
> VERIFIED INVALID (and won't let me fix it).
 
Here's what I wrote in the support forum thread on this,  
https://support.mozilla.org/questions/982481 plugin check not working

1/7/2013: 
"I think that the PluginCheck page should be reporting that version 2.1.0 of the VLC Web Plugin is up  to date, if that's the latest available version. If it's reporting that the plugin is outdated then I would call that a bug."  
"If there isn't any VLC plugin version 2.1.2 (if the latest version of the VLC media player Web Plugin file npvlc.dll included with VLC Media Player 2.1.2 is still at version 2.1.0) then I would add a comment to the bug I mentioned earlier, and add a link to this discussion." 
" * Bug 939699 - Update VLC plugin to 2.1.2 "

1/8/2013: 
"I've added a comment to bug 939699 linking back to this thread."
Status: VERIFIED → RESOLVED
Closed: 7 years ago6 years ago
Resolution: INVALID → DUPLICATE
Duplicate of bug: 905451
You need to log in before you can comment on or make changes to this bug.