[User Story] Firefox Account in Settings

RESOLVED DUPLICATE of bug 949051

Status

Firefox OS
Gaia::System
RESOLVED DUPLICATE of bug 949051
5 years ago
4 years ago

People

(Reporter: pdol, Assigned: sergi)

Tracking

({feature})

unspecified
ARM
Gonk (Firefox OS)
feature
Dependency tree / graph

Firefox Tracking Flags

(feature-b2g:2.0)

Details

(Whiteboard: [ucid:FxA3, 1.4:p2, ft:systems-fe][qa+],[dependency:Marketplace])

Attachments

(2 attachments, 2 obsolete attachments)

(Reporter)

Description

5 years ago
User Story:

As a user, I want to be able to set up a Firefox account or login using an existing Firefox or Persona account from the Settings menu so that I can chose to do this after the First Run Experience, giving me the freedom of choice and making it easy to create an account when I chose.


Acceptance Criteria:

1. If I do not currently have a Firefox or Persona account, I can create one under Settings and I will be signed in using it.
2. If I already have a Firefox or Persona account, I can log in under Settings using this account using my email address and password.
3. If I already have a Firefox or Persona account, but I have forgotten the password, I am able to reset my password in Settings by having an email sent to me with a link to reset my password.  
4. Once my password is reset (via the sent email), I can enter my Firefox or Persona email/password and am logged in.
5. If I am already logged in to a Firefox or Persona account, I can log out should I chose, preventing apps from logging me in with this identity until I re-log in.
6. If my device drops connectivity while in the process of creating an account/signing in, I am made aware the of the lack of connectivity and asked to try again later.
Created attachment 800979 [details]
settingsAccountsV0.3.pdf

UX proposal spec for this feature attached.

Updated

5 years ago
Whiteboard: [ucid:System3] → [ucid:System3][systemsfe]
Assignee: nobody → sergi.mansilla
No longer depends on: 929388

Comment 2

5 years ago
Created attachment 822290 [details]
WIP update to Settings Flow

Comment 3

5 years ago
Created attachment 825050 [details]
FxA_Settings_2013_30_13_v.4.pdf
Attachment #822290 - Attachment is obsolete: true

Comment 4

5 years ago
Created attachment 825368 [details]
FxA_Settings_2013_30_13_v.4.pdf

Fixes a few typographic + formatting errors in previous. Adds errors.
Attachment #825050 - Attachment is obsolete: true
Whiteboard: [ucid:System3][systemsfe] → [ucid:System3][systemsfe][qa+]

Updated

5 years ago
Flags: in-moztrap?(edwong)

Updated

5 years ago
Whiteboard: [ucid:System3][systemsfe][qa+] → [ucid:FxA3, 1.4:p2][systemsfe][qa+]

Comment 5

4 years ago
Update whiteboard tag to follow format [ucid:{id}, {release}:p{1,2}, ft:{team-id}]
Whiteboard: [ucid:FxA3, 1.4:p2][systemsfe][qa+] → [ucid:FxA3, 1.4:p2, ft:systems-fe][qa+]
I am starting on this, assuming the fxa_iac_helper[1] is available to the settings app (same assumption as [3]), and using sergi's preliminary settings app work[2] and shane's work integrating FTU and iac_helper[3] to guide me. If anyone wants to follow along, I'll keep my work in this branch: https://github.com/6a68/gaia/tree/bug-905637-fxa-settings-app

[1] the file shared/js/fxa_iac_client.js in https://github.com/mozilla-b2g/gaia/pull/14101/files
[2] https://github.com/borjasalguero/gaia/commit/ced49a4
[3] https://github.com/borjasalguero/gaia/pull/30

Procedural questions for Sam: should I file a separate bug for the actual dev work, to keep the user story bug clean? Is this user story bug going to be replaced with a bug from a new tree?
Flags: needinfo?(spenrose)
In my branch, I've merged [1] and [2] from my previous comment, and I am able to run this patched gaia on 12-18-2013 nightly, now that ferjm's fxa patches have landed.

:-)
Another question for sam or ferjm (since sam's sick and ferjm's touched gecko pieces) - From looking at the specs, it seems like we really need a locally-cached copy of the FxA account info when the settings app starts up. Is this cache in the fxa gecko code somewhere? If so, how can we ensure it's warmed (to avoid weird UI states where we don't have data and are waiting for slow networks)?

Also, if the user doesn't yet have an account, how/where should the settings app listen for "logged-in" events (in case the user creates an FxA account inside Marketplace, or something)?
Flags: needinfo?(ferjmoreno)

Comment 9

4 years ago
Jared, I apologize, I haven't cleaned this up as aggressively as I should. This is now superseded by the equivalent bug in the 1.4 tree: https://bugzilla.mozilla.org/show_bug.cgi?id=949052 . C.f. 930074 and the whole tree at https://bugzilla.mozilla.org/showdependencytree.cgi?id=941723&hide_resolved=1
Flags: needinfo?(spenrose)
Flags: needinfo?(ferjmoreno)

Comment 10

4 years ago
In answer to Comment #8, services/fxaccounts/FxAccounts.jsm saves the logged-in user locally ("signedInUserStorage"). There is an onlogin event, and I think you are correct that we will need to listen for it, but we should take a closer look.
Actually, the cache for the signed-in user that the Settings app will be consuming is handled by FxAccountsManager [1], which also does the appropriate email verification check if needed. The Settings app just needs to use the FxAccountsIACHelper.getAccounts function. The platform will make sure that the account information is correct and updated.

> Also, if the user doesn't yet have an account, how/where should the settings
> app listen for "logged-in" events (in case the user creates an FxA account
> inside Marketplace, or something)?

This is a very good point! We should allow consumers of FxAccountsIACHelper to listen for 'onlogin' and 'onverified' events. I'll file a bug for it. Thanks!

[1] https://mxr.mozilla.org/mozilla-central/source/services/fxaccounts/FxAccountsManager.jsm#223

Updated

4 years ago
Flags: in-moztrap?(edwong)

Updated

4 years ago
Whiteboard: [ucid:FxA3, 1.4:p2, ft:systems-fe][qa+] → [ucid:FxA3, 1.4:p2, ft:systems-fe][qa+],[dependency:Marketplace]
Hmm, not sure why this bug is still open. Closing as a dupe of 949051.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 949051
feature-b2g: --- → 2.0
You need to log in before you can comment on or make changes to this bug.