Closed Bug 905640 Opened 6 years ago Closed 6 years ago

[MP] Defect - Circular progress remains filled forever after a download

Categories

(Firefox for Metro Graveyard :: Downloads, defect, P2)

x86_64
Windows 8.1
defect

Tracking

(Not tracked)

VERIFIED FIXED
Firefox 26

People

(Reporter: jimm, Assigned: emtwo)

References

Details

(Whiteboard: [preview] feature=defect c=tbd u=tbd p=1)

Attachments

(2 files)

STR: 

- download something
- note the circular progress fills up

from this point on, the downloads button will always display the blue ring. Clicking on the download button does nothing, which might be a separate bug.
Summary: Circular progress remains filled forever after a download → Defect - Circular progress remains filled forever after a download
Whiteboard: [preview-triage] → [preview-triage] feature=defect c=tbd u=tbd p=0
Let's clear the download ring when the downloads are done instead of when a user clicks a button on the download-complete infobar.
Attachment #792248 - Flags: review?(jmathies)
Comment on attachment 792248 [details] [diff] [review]
v1: Clear download ring on dl-done instead of on button click

do we need to worry about clearing this in the dl-failed handler?
Attachment #792248 - Flags: review?(jmathies) → review+
(In reply to Jim Mathies [:jimm] from comment #2)
> Comment on attachment 792248 [details] [diff] [review]
> v1: Clear download ring on dl-done instead of on button click
> 
> do we need to worry about clearing this in the dl-failed handler?

Yes, thank you. We would need to clear on fail as well.

https://hg.mozilla.org/integration/fx-team/rev/c1fb5aec3201
Whiteboard: [preview-triage] feature=defect c=tbd u=tbd p=0 → [fixed-in-fx-team][preview-triage] feature=defect c=tbd u=tbd p=0
p=1
Assignee: nobody → msamuel
Blocks: metrov1it13
No longer blocks: metrov1backlog
Status: NEW → ASSIGNED
Priority: -- → P2
QA Contact: jbecerra
Summary: Defect - Circular progress remains filled forever after a download → [MP] Defect - Circular progress remains filled forever after a download
Whiteboard: [fixed-in-fx-team][preview-triage] feature=defect c=tbd u=tbd p=0 → [fixed-in-fx-team][preview] feature=defect c=tbd u=tbd p=0
Whiteboard: [fixed-in-fx-team][preview] feature=defect c=tbd u=tbd p=0 → [fixed-in-fx-team][preview] feature=defect c=tbd u=tbd p=1
https://hg.mozilla.org/mozilla-central/rev/c1fb5aec3201
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team][preview] feature=defect c=tbd u=tbd p=1 → [preview] feature=defect c=tbd u=tbd p=1
Target Milestone: --- → Firefox 26
Duplicate of this bug: 908890
Mozilla/5.0 (Windows NT 6.2; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
Build ID: 20130827030201

While testing this using the latest Nightly for iteration #13, I can still see the circular progress of the ring while the file is downloaded, but afterwards the blue ring disappears completely.

Is this the expected behavior?
Flags: needinfo?
(In reply to Manuela Muntean [:Manuela] [QA] from comment #7)
> Mozilla/5.0 (Windows NT 6.2; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
> Build ID: 20130827030201
> 
> While testing this using the latest Nightly for iteration #13, I can still
> see the circular progress of the ring while the file is downloaded, but
> afterwards the blue ring disappears completely.
> 
> Is this the expected behavior?

Yes this is the intended behaviour. We have a download complete infobar to indicate to the user that their download is complete and thus the progress circle does not need to remain visible except throughout the download progress.

Though I think this works from a UX perspective, another option is to keep the blue circle visible until the infobar for a download complete is closed. Yuan what do you think?
Flags: needinfo?(ywang)
I think keeping the blue circle visible until the user interacts with the info bar makes sense.
Flags: needinfo?(ywang)
Flags: needinfo?
Marking this VERIFIED FIXED, based on comment 7, comment 8 and comment 9. Thanks!
Status: RESOLVED → VERIFIED
I was able to reproduce this issue, while testing for iteration #14, with the latest Nightly (build ID: 20130915030208).
Attached image screenshot.png
The blue ring only disappears after a second download. Please see the attached screenshot for details. (the blue ring becomes gray again after a second download)
Another relevant thing worth mentioning is that the behavior in comment 11 and comment 12 only appears if I download .pdf files. If I download a build from http://nightly.mozilla.org/ for example, everything works as expected.
Depends on: 927729
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.