Closed Bug 927729 Opened 8 years ago Closed 8 years ago

Defect - Regression - Circular progress not clearing once download is completed

Categories

(Firefox for Metro Graveyard :: Downloads, defect, P2)

x86_64
Windows 8.1
defect

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: kjozwiak, Assigned: mbrubeck)

References

Details

(Keywords: uiwanted)

Attachments

(1 file)

Once a download has been completed, the circular progress bar isn't being cleared. This is a regression from Bug 905640.

Steps to reproduce the issue:

1) Open Firefox Metro
2) Download something (in this case, downloaded VLC executable)
3) You'll notice the circle being filled up. Once downloaded, it will stay completely filled and the circle will not be cleared (viewable in different tabs)

Current Behavior:

- Circular progress bar is not being cleared and dismissed once the download has been completed

Expected Behavior:

- Circle should fill up and then disappear once the download has been completed.

Used the following build:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-10-16-03-02-02-mozilla-central/
Whiteboard: feature=defect c=Downloads_app_bar u=metro_firefox_user p=0 → [triage] feature=defect c=Downloads_app_bar u=metro_firefox_user p=0
This was an intentional change from bug 923828 comment 2: we now wait until the user chooses to run or show the file before hiding and resetting the download button.  (This is similar to desktop Firefox where the download button remains highlighted after the download completes, until the user interacts with it.)

Stephen, should we change the button state when the download completes?
Blocks: 923828
Flags: needinfo?(shorlander)
Keywords: uiwanted
Whiteboard: [triage] feature=defect c=Downloads_app_bar u=metro_firefox_user p=0 → feature=defect c=Downloads_app_bar u=metro_firefox_user p=0
Whiteboard: feature=defect c=Downloads_app_bar u=metro_firefox_user p=0 → [release28] feature=defect c=Downloads_app_bar u=metro_firefox_user p=0
Let's do this.  Michael, would you like to provide a new "completed" state for the download button, or should we just used the regular "enabled" state?
Assignee: nobody → mbrubeck
Status: NEW → ASSIGNED
Flags: needinfo?(shorlander) → needinfo?(mmaslaney)
Blocks: metrov1it20
No longer blocks: metrov1backlog
Priority: -- → P2
QA Contact: jbecerra
Whiteboard: [release28] feature=defect c=Downloads_app_bar u=metro_firefox_user p=0 → [block28] feature=defect c=Downloads_app_bar u=metro_firefox_user p=1
Matt, would happy to provide a couple of options.
Flags: needinfo?(mmaslaney)
Couple questions about the functionality:

After download is the button actionable? If not, I would suggest removing it all together, as to not confuse the user with it's functionality. Instead, I would suggest using the blue rule as a progress indicator (same color gradient as page load) which fills in 360° when downloading. The button can remain on it's active state, but with a 50% transparency.
Flags: needinfo?(mbrubeck)
(In reply to mmaslaney from comment #4)
> After download is the button actionable?

Yes - tapping the button toggles the visibility of the "download(s) complete" prompt.

Here's a screenshot of the button in its "download complete" state as of today, with the prompt visible.

Once the user has chosen an action in the prompt, the prompt and the download button both disappear.

Given this, are there any changes needed to the assets or the interaction?
Flags: needinfo?(mbrubeck)
Ok, I'm getting this. Because it's actionable, I would leave all interaction states (normal, hover, click/active) as is.
Resolving based on comment 6.
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → WONTFIX
Blocks: metrov1backlog
No longer blocks: metrov1it20
Whiteboard: [block28] feature=defect c=Downloads_app_bar u=metro_firefox_user p=1 → feature=defect c=Downloads_app_bar u=metro_firefox_user p=0
Matt is there a way to make the progress rule the same as the page load; going from dark to light?
We could probably manage that; could you file a new bug for it, please?  The progress circle is drawn on a canvas by this code:
http://mxr.mozilla.org/mozilla-central/source/browser/metro/base/content/bindings/circularprogress.xml
No longer blocks: metrov1backlog
Whiteboard: feature=defect c=Downloads_app_bar u=metro_firefox_user p=0
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.