Closed Bug 906012 Opened 8 years ago Closed 8 years ago

[SeaMonkey] TEST-UNEXPECTED-FAIL | test_contextmenu.html | checking item #2 (*chubbiness) name - got context-undo, expected *chubbiness

Categories

(SeaMonkey :: General, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

(seamonkey2.21 fixed, seamonkey2.22 fixed)

RESOLVED FIXED
seamonkey2.23
Tracking Status
seamonkey2.21 --- fixed
seamonkey2.22 --- fixed

People

(Reporter: mcsmurf, Assigned: mcsmurf)

Details

(Keywords: intermittent-failure)

Attachments

(1 file, 1 obsolete file)

Currently this test fails (on beta at least, no test results for other trees):
 168909 ERROR TEST-UNEXPECTED-FAIL | /tests/suite/browser/test/test_contextmenu.html | checking item #2 (*chubbiness) name - got context-undo, expected *chubbiness:
168871 INFO TEST-PASS | /tests/suite/browser/test/test_contextmenu.html | Starting test #18
[...]

168906 INFO TEST-PASS | /tests/suite/browser/test/test_contextmenu.html | checking item #0 (popupwindow-reject) name
168907 INFO TEST-PASS | /tests/suite/browser/test/test_contextmenu.html | checking item #0 (popupwindow-reject) enabled state
168908 INFO TEST-PASS | /tests/suite/browser/test/test_contextmenu.html | checking item #1 (---) name
168909 ERROR TEST-UNEXPECTED-FAIL | /tests/suite/browser/test/test_contextmenu.html | checking item #2 (*chubbiness) name - got context-undo, expected *chubbiness
168910 ERROR TEST-UNEXPECTED-FAIL | /tests/suite/browser/test/test_contextmenu.html | checking item #2 (*chubbiness) enabled state - got false, expected true
168911 ERROR TEST-UNEXPECTED-FAIL | /tests/suite/browser/test/test_contextmenu.html | checking item #3 (---) name - got context-redo, expected ---
168912 ERROR TEST-UNEXPECTED-FAIL | /tests/suite/browser/test/test_contextmenu.html | checking item #4 (spell-add-to-dictionary) name - got ---, expected spell-add-to-dictionary
168913 ERROR TEST-UNEXPECTED-FAIL | /tests/suite/browser/test/test_contextmenu.html | checking item #4 (spell-add-to-dictionary) enabled state - got null, expected true
[...]

I think http://hg.mozilla.org/mozilla-central/rev/6b29a5c94955 (Bug 856270) might be related here.
Also see:

Bug 905176 - Don't show the Check Spelling menu item for spellcheck=false contenteditable elements
Attached patch Test fix (obsolete) — Splinter Review
Straight-forward port of http://hg.mozilla.org/mozilla-central/rev/6b29a5c94955 to SeaMonkey, trivial test fix, no review needed.
Assignee: nobody → bugzilla
Status: NEW → ASSIGNED
Attachment #793711 - Flags: review+
Attached patch Test fixSplinter Review
Attachment #793711 - Attachment is obsolete: true
Attachment #793712 - Flags: review+
Comment on attachment 793712 [details] [diff] [review]
Test fix

[Approval Request Comment]
Regression caused by (bug #): Bug 856270
User impact if declined: -
Testing completed (on m-c, etc.): Works fine locally, test fix only
Risk to taking this patch (and alternatives if risky): Test fix only
String changes made by this patch: -
Attachment #793712 - Flags: approval-comm-beta?
Attachment #793712 - Flags: approval-comm-aurora?
Comment on attachment 793712 [details] [diff] [review]
Test fix

As these are just test fixes, they probably could have just landed with a suitable a=
Attachment #793712 - Flags: approval-comm-beta?
Attachment #793712 - Flags: approval-comm-beta+
Attachment #793712 - Flags: approval-comm-aurora?
Attachment #793712 - Flags: approval-comm-aurora+
Pushed: https://hg.mozilla.org/comm-central/rev/480f28c2f35f
Target Milestone: --- → seamonkey2.23
Pushed to beta: https://hg.mozilla.org/releases/comm-beta/rev/9a18d0a991cc

Will file a new bug for the issue in Comment 1
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.