Closed Bug 906549 Opened 8 years ago Closed 8 years ago

[Flatfish][LockScreen] add support for large device for portrait

Categories

(Firefox OS Graveyard :: Gaia::System::Lockscreen, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v1.2 fixed, b2g-v1.3 fixed)

RESOLVED FIXED
Tracking Status
b2g-v1.2 --- fixed
b2g-v1.3 --- fixed

People

(Reporter: gweng, Assigned: gweng)

References

Details

(Whiteboard: [Flatfish only])

Attachments

(2 files)

Attached image LockScreen_P.png
Expect:

Modify and Merge experiment tablet work from 

https://github.com/gaia-local/gaia

to master

----
Note: Since orientation in large device is not ready yet, we fire separate bugs for landscape and portrait to not block the development progress
Blocks: flatfish
It's a must for flatfish. Marked as koi+ according to triage result.
blocking-b2g: --- → koi+
Whiteboard: [Flatfish only]
--- Since the basic layout works and 1.2 is target for minimum tablet support
blocking-b2g: koi+ → ---
I needinfo Patryk here for the 1.5X and 2.0X arrow bitmap used in the lockscreen, and would fixed the bug after our lockscreens use them to replace the old 1.0X image under larger resolution.
Flags: needinfo?(padamczyk)
We don't support 2x size. I believe those arrows were vector.
Przemek, can you comment / if needed provide the 1.5x graphics?
Flags: needinfo?(padamczyk) → needinfo?(pabratowski)
Today I got the 1.5X arrow image, so clear the needinfo here.
Flags: needinfo?(pabratowski)
Assignee: nobody → gweng
Attached file Patch
UX provide us the new 1.5X image.
And according to the mail, there's no 2.0X image at all.

I want to close the LockScreen bugs related to Flatfish. The landscape one had been closed due to one CSS adjustment, so this one can be the last step to finish these bugs.
Attachment #821555 - Flags: review?(timdream)
Attachment #821555 - Flags: review?(timdream) → review+
master: https://github.com/mozilla-b2g/gaia/commit/6d42c3ec5565bb1f07e0aa5d0c7ca2df6b35a161
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Comment on attachment 821555 [details] [review]
Patch

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment] image update only
[Bug caused by] (feature/regressing bug #):
[User impact] if declined:
[Testing completed]:
[Risk to taking this patch] (and alternatives if risky):
[String changes made]:
Attachment #821555 - Flags: approval-gaia-v1.2?
Please complete the user impact if declined.
Flags: needinfo?(gasolin)
Comment on attachment 821555 [details] [review]
Patch

after recheck, I think it's more like 1.1hd bug
Attachment #821555 - Flags: approval-gaia-v1.2?
1.10hd not use new lockscreen style, so not need to uplift it. thanks
Flags: needinfo?(gasolin)
I pushed 7374a741fc056860331dd0511a260081107f7921 so we could see this image in it's correct size.
Comment on attachment 821555 [details] [review]
Patch

This needs to go to v1.2 (along with what I pushed) because we need to maintain support to helix in v1.2 branch.
Attachment #821555 - Flags: approval-gaia-v1.2+
v1.2: d0266d6f9b8fa15deb710389db2b282699cb2308
v1.2: 670b2c8329bca6f142939185be71274166d82bb8
The master commits are already on v1.3
You need to log in before you can comment on or make changes to this bug.