[Lockscreen] Phone can unlock in pants

RESOLVED FIXED in Firefox OS v1.3

Status

Firefox OS
Gaia::System::Lockscreen
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: janjongboom, Assigned: etienne)

Tracking

unspecified
1.3 C3/1.4 S3(31jan)
x86
Mac OS X

Firefox Tracking Flags

(blocking-b2g:-, b2g-v1.3 fixed, b2g-v1.3T fixed, b2g-v1.4 fixed)

Details

Attachments

(1 attachment)

The gesture for the phone to unlock is too easy. My phone got unlocked three times during the weekend. Here's how it's done...

1. Don't put the phone on standby (but in the lock screen). F.e. you just checked a notification.
2. The gesture to show the lock button is very easy. You have to move the bar like 30 pixels or something which is very easy to trigger by movement of your pants.
3. Now the lock button is visible, and stays visible because the screen is touched. A touch at the right place by your upper leg will now unlock the phone.

We should either make an unlock movement that requires a larger move, or think of something else.
(Reporter)

Updated

5 years ago
Summary: [LockScreen] Phone can unlock in pants → [Lockscreen] Phone can unlock in pants
Oh this can also happen if you get a notification that turns on the screen of course.
(Assignee)

Comment 2

4 years ago
Created attachment 8364369 [details] [review]
Gaia PR

Here's a simple patch greatly improving this issue in my experience.

It's 2 fold:

* First |states.slideReachEnd| wasn't cleaned up properly, so *after a first unlock* double taping the area caused the phone to unlock

* Second, we now reset the detection completely when we detect a second touch (that's what iOS does by the way)
Assignee: nobody → etienne
Attachment #8364369 - Flags: review?(alive)
Comment on attachment 8364369 [details] [review]
Gaia PR

\O/
Attachment #8364369 - Flags: review?(alive) → review+
(Assignee)

Comment 4

4 years ago
https://github.com/mozilla-b2g/gaia/commit/2946ccc07ec28cea44994d98598b85db301edd12
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

4 years ago
I wonder if we should uplift this patch because of this:

> *after a first unlock* double taping the area causes the phone to unlock
blocking-b2g: --- → 1.3?
That might also solve my bug 872035
(In reply to Etienne Segonzac (:etienne) from comment #5)
> I wonder if we should uplift this patch because of this:
> 
> > *after a first unlock* double taping the area causes the phone to unlock

I think that's a case that we should ask approval, but not block the release. Can you ask for 1.3 approval on this patch?
blocking-b2g: 1.3? → -
(Assignee)

Comment 8

4 years ago
Comment on attachment 8364369 [details] [review]
Gaia PR

[User impact] if declined:
> *after a first unlock* double taping the slider area causes the phone to unlock

[Testing completed]:
Tested with and without sim lock, tested the incoming lockscreen too.

[String changes made]:
none
Attachment #8364369 - Flags: approval-gaia-v1.3?(fabrice)
Attachment #8364369 - Flags: approval-gaia-v1.3?(fabrice) → approval-gaia-v1.3+
Duplicate of this bug: 872035
status-b2g-v1.3: --- → fixed
(Assignee)

Updated

4 years ago
Blocks: 965286
status-b2g-v1.3T: --- → fixed
status-b2g-v1.4: --- → fixed
Target Milestone: --- → 1.3 C3/1.4 S3(31jan)
You need to log in before you can comment on or make changes to this bug.